Flashing #3 Diagnostic Light in Optiplex 790

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Flashing #3 Diagnostic Light in Optiplex 790

This question has suggested answer(s)

Hi, I have problem with my Optiplex 790 It won't turn on. When I pressed the diagnostic button the #3 amber light is flashing. I followed the instruction from this edocs it says it might have problem with the processor so I reinstalled the processor and restarted the system many times but still no luck. When I pressed the diagnostic button all fans are working including the fan inside the PSU.

What seems to be the problem? Does my processor already damaged?

Thanks in advance! Wink

All Replies
  • The processor seems to be okay because I tried to install it in other machine with same specs and it's working.

  • Hi there,

    As the #3 diagnostic LED is flashing, I would assume that the power button is amber or completely off. This would indicate a different error. If it's okay with you, I'd like to ask you to try some steps and if you can let me know how you get on after each step, it would be very much appreciated.

    Most of these steps will involve removing internal components from the system so please make sure that you have removed the AC power cord from the back of the system and also taken anti-static precautions to prevent damage to the system or its components. Also, if you need assistance removing some components, the manual for your system can be found at this link: http://support.dell.com/support/edocs/systems/op790/en/index.htm

    1) Please remove all external peripherals - mouse, keyboard, monitor etc... - and switch the system on. Please tell me the following:
    a) The colour of the power button LED.
    b) What diagnostic LEDs are lit or flashing.

    2) Please open the system and disconnect the following to take the system to the bare minimum it needs to complete POST. To do this, please remove and reconnect all power connectors from the PSU to the motherboard. Also, please remove the following:
    a) All power and data cables to the HDDs and optical drives.
    b) Any data cable attached to your media card reader (if it is installed)
    c) Any PCI/PCI-Express expansion card connected to the system.
    d) All but one stick of memory in memory slot DIMM_1

    3) After doing step 2, please reconnect the power cord and monitor then attempt to switch the PC on. Please tell me the following:
    a) The colour of the power button LED.
    b) What diagnostic LEDs are lit or flashing.
    c) If you see any image or error message on the monitor. 

    4) If the system does not show any error message on the monitor, please try each individual stick of memory in slot DIMM_1 to rule out any memory problems. After doing this, please tell me if you see any change to the colour of the power button LED or diagnostic LEDs when using a different memory stick.

    5) Please ensure that the power cord is removed from the back of the system. Next, please remove the CMOS battery and I/O panel cable from the motherboard. To do this, please refer to your manual. Once you have done this, please attach the power cable to the back of the system and ensure that the monitor is still plugged into the back of the system. Do you hear any beeps coming from the PC or see any image on the monitor?

    If you can try the above, it would be a great help. Thanks and I hope to hear from you soon.

    John C
    Dell | Social Outreach Services


    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • hi, thank you for your guid...

    but it dose not work i really not understanding what is the problem i'm having...

    when i plug the ac power to psu the front light of dell optiplex 790 blink orange but there is another switch at back of psu when i press it i mean keep press not pressing not just presss just keep the finger on it till optiplex is start it shows dell logo everything but when i realease my finger from back of the psu it off evrything is off the same conditiong appear again orange light blinking ... i really don't understand what happened to it...

    please is there anyone know that condition of my otiplex desktops i'm waiting for yours replay....

                                                                           thank you....

  • I have same problem as you.  

    Can you please share your solution to me?

    Thanks and Regards,

    Ms.Debby

  • Hi I have a problem with my Optiplex790 when it is turn on it does not boot . can help me or may it be that the HDD is bad  or what?

     

    Thanks in advance pls

  • I also have the same problem, the power button and all led's are flashing orange.

    Did many procedures found on forums, but didnt help.

    Any solution Plz?

  • My Dell pc optiplex 790 is not working. it shows dell logo and option to press f12. but nothing happens by pressing f12, after passing dell logo it only shows blinking cursor,

    the power button light is orange and other all  leds are blinking orange. please help me to solve this issue.

    thanks

  • Hi sajad.wani,

    Since how long you are facing this issue?

    Have you made any recent hardware or software changes to computer? 

    Optiplex 790 has four variants: Mini-Tower (MT), Desktop (DT), Small Form Factor (SFF), Ultra Small Form Factor (USFF). Please share the exact system model. 

    You may drain out the residual power of computer by following the steps below:

    • Power off the system from the power button or the wall jack.
    • Disconnect the power cable from the wall jack and remove all the cables connected to the back of system tower including the power cable.
    • Press and hold the power button pressed for 30 seconds.
    • Connect the power cable, keyboard and monitor cable only.
    • Power on the system and see if it works. 

    Once you drain out the residual power, try running the diagnostics again:

    1. Restart your computer and tap F12 at Dell logo.
    2. Select 'Diagnostics' and hit Enter.
    3. Make a note of error code if any. 

    If the diagnostics pass and issue persists, you may refer to the system service manual: http://dell.to/WYjSEp and let me know the exact status of the diagnostic indicators on your computer.

    Select the correct form factor to access the correct manual of computer. If the power button LED is blue and diagnostic indicator# 3 flashes, a possible processor failure has occurred. Though processor is not a customer replaceable unit, you may try to reseat the processor using the instructions from service manual. Please ensure to follow safety instructions in manual.

    If the issue persists, after re-seating the processor, it might be an issue with system hardware and might need replacement. 

    Please share the findings. 

    Thanks and Regards,
    Chinmay S
    #iworkfordell 
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/10GaKAc  

  • Thanks for your reply

    Its mini-tower.

    i did same thing but same problem.

    Its shows dell logo and F12 boot options.

    if i press f12 it gets stuck at the same position.

    aotherwise it proceeds to next postion.

    the next snapshot is blank screen with blinking screen if i connect PS2 keyboard

    and if i connect USB keyboard it shows following, but does nothing

    Alert! Air temperature sensor not detected.

    Alert! CPU 0 fan failure

    Alert! Hard drive fan Failure

    Alert! Keyboard initialization failure.

    To continue press F1 key

    To change setup option press F2 key

    To run onboard diagnostic press F5 key

    but nothing happens if i press any key. the USB keyboard even doesnt show power.

    Regarding the issue time

    it was working on a project then they shifted to another project where it doesnt work.

    please advise the solution

    thanks in advance

  • Press F2 and Load BIOS defaults, might be F9 or Alt F -> you shd head beep sound, or Choose Maintenance --> Load Defaults. Go to Maintenance and select Event Log -> Clear event log. Then Esc -> Save and Exit. Even after doing the above step you get the same Alert! errors then The fans inside are not spinning. Try opening the computer and see if all the fans are spinning, if not try to reseat the cables from the Fan to the motherboard.

    For the keyboard try using a different USB Port. Check if Num lock Caps lock work when you press the Num lock or Caps lock keys

    Mark my answer as resolved if your issue is resolved

    Best Regards,

    VeejDeej

    Endorse me: http://goo.gl/C3567
    Dell user
  • when keyboard doesnt function at all, how can i press F2. I changed keyboard also. i used ps2 also. but nothing.

    regd fans, they spinning very well and i reseted all the cables

  • Thanks for your reply

    Its mini-tower.

    i did same thing but same problem.

    Its shows dell logo and F12 boot options.

    if i press f12 it gets stuck at the same position.

    aotherwise it proceeds to next postion.

    the next snapshot is blank screen with blinking screen if i connect PS2 keyboard

    and if i connect USB keyboard it shows following, but does nothing

    Alert! Air temperature sensor not detected.

    Alert! CPU 0 fan failure

    Alert! Hard drive fan Failure

    Alert! Keyboard initialization failure.

    To continue press F1 key

    To change setup option press F2 key

    To run onboard diagnostic press F5 key

    but nothing happens if i press any key. the USB keyboard even doesnt show power.

    Regarding the issue time

    it was working on a project then they shifted to another project where it doesnt work.

    please advise the solution

    thanks in advance

  • To load BIOS Defaults: Turn off comp, remove power cables, You need 2 move the RTCRST - Jumper pins on the Motherboard from 1-2 to 2-3 and turn on the PC to load defaults. Again turn off PC and put back the Jumper to 1-2 from 2-3.

    Mark my answer as resolved if your issue is resolved

    Best Regards,

    VeejDeej

    Endorse me: http://goo.gl/C3567
    Dell user
  • Hi sajad.wani,

    In addition to what 'Veejdeej' suggested, you may also try to re-seat/replace the CMOS battery of your computer and check if it makes any difference. For detailed information on re-seating/ replacing CMOS battery, you may refer to system service manual. Please ensure to follow safety instructions in manual.

    @ Veejdeej : Thank you for assisting the customer.

    Hope this helps. 

    Thanks and Regards,
    Chinmay S
    #iworkfordell 
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/10GaKAc  

  • Thanks Chinmay S,

    Is it possible onboard ports like uSB ports, VGA, PS2 ports not working. because i think there is no problem with the processor. Also, when i connect Vga cable to onboard vga port it doesnt display anything. its connected to add-on graphics card. i already re-seated cmos.

    is any alternative, if these ports not working,.???

    Waiting for your suggestion

    Thanks