OptiPlex 755 refuses access to boot sequence menu.

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

OptiPlex 755 refuses access to boot sequence menu.

This question is answered

Discovered a weird problem on a Optiplex 755 desktop tower system.

I can change any of the other available values on the system but cannot enter the boot sequence menu.  The BIOS that was on the system was A17.

Updated it to A20. No change.

Oh. That wasn't the latest. Update to A21.  No change.

Downgraded to A12.  No change. Bumped back up to A21. No change.

Downgraded to A10. No change. Bumped back up to A21. No change.

Downgraded to A01. No change. Bumped back up to A21 No change.

If there is a password on the system when I tried to access the boot sequence menu it reminded me I needed to type it in first. After successfully entering that value, the prompt went away but I still could not get into the boot sequence.

I removed the cmos battery for 20 minutes while the system was off, put it back, booted. No change.

I replaced the cmos battery with one from another system.  No change.

Tried a different keyboard. No change.

Used the jumper to reset the cmos.  No change.  Ran the onboard utilities.  No error could be found.

If I hold the enter key while on the boot sequence menu I can see the initial splash screen and flickers of the next screen that it will not advance to.

Unplugged the system and pressed the on button for 30-60 seconds. No change.

I think this is ripe for a warranty replacement.

Event_Horizon.

Verified Answer
  • I know this reply comes a little late but for anyone else experiencing this issue...

    IT CAN BE FIXED!

    This issue seems to arise after a BIOS update not completely flashing correctly. This leaves the user unable to change the boot device priority in the BIOS, consequently causing the machine to complain there there is 'No Boot Device Available'

    Upgrading and downgrading the BIOS via standard means doesn't seem to work; however with certain switches it can be done.

    Firstly, you'll need the first BIOS release, A01 (O755-A01.EXE), currently available from http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=R164252 

    Secondly you'll also require the latest BIOS release, A22 (O755-A22.EXE), currently available from http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=2DWTY

    Finally, you'll need either a USB memory stick or hard disk that is capable of booting the machine into DOS. It is recommended that you use the free tool 'Rufus' to create a FreeDOS bootable memory stick. Rufus is currently available from https://rufus.akeo.ie/

    In addition, you may need to install the service mode jumper on the motherboard; this repair was successfully performed with it enabled, although it *might* work without it installed, although this hasn't been tested.

    Firstly create a FreeDOS bootable USB device using Rufus. Once complete, copy both the A01 BIOS (O755-A01.EXE) and A22 BIOS (O755-A22.EXE) to the root of the memory stick.

    Insert the memory stick into the affected computer and press F12 at the BIOS. Boot from the USB stick. Once at the DOS prompt, type:

    O755-A01 -wipeall -wipeclean

    Press enter and follow the prompts on screen. After the BIOS has been flashed, the computer should restart. Go into the BIOS and check the Boot Sequence options under System. The boot sequence should now not only display the name of your hard disk, but will also be changeable, allowing your computer to boot normally. Set up your BIOS configuration to your liking (Including setting the date and time) and then Save & Exit. Upon rebooting, press F12 again and once again boot from the USB device.

    Flash the A22 BIOS the standard way by typing O755-A22 and pressing enter. Follow the onscreen prompts. Once the BIOS has been flashed, check the BIOS settings again to ensure that the Boot Device menu is still accessible.

    Once complete, make sure to remove the service mode jumper (if installed).

    FAQ

    Why does this work?


    From what I can tell, the earlier BIOS flashing tool includes switches that the later versions do not; -wipeall and -wipeclean are integral to this fix working as they completely erase all BIOS settings that aren't usually erased when the BIOS is updated. For some reason, Dell removed these options from later BIOS update tools.

    In addition, the earlier BIOS flashing tool actually flashes the BIOS itself under DOS instead of relying on loading the BIOS into RAM and then flashing with routines in the current system BIOS. I've no idea if this makes any difference to the process, but I imagine that it allows for more options to be passed to the flashing routine.

    Sorry for the long post but I hope this helps someone out! Having recently got my hands on a couple of these machines and having the same issue, it's incredibly frustrating.

All Replies
  • Hi Event Horizon,

    I'm not sure if you're talking about the BIOS (F2) or the F12 advanced boot menu. Do you see the Dell logo with these prompts (F2 for system setup, F12 for advanced boot menu) when you start the system?

  • I can still see boot menus Ctrl-P for the Intel AMT option (which has been disabled within), F12 for booting floppy, dvd, or hard drive (usb stick is not an option regardless of what is connected), and F2 for entering the BIOS.   As far as I can tell the only thing that I cannot configure is the boot sequence menu while in the bios.

  • My coworker in charge of parts and deliveries phoned this issue into support. Simply by reading the boot menu problem to them - 'you need a new motherboard'. (This must be a known problem.) So a replacement is on its way for delivery next week.

  • Ok, good to hear. Please let me know if things work out.

  • Sir i have the same problem even i can't boot when my sata operation set to AHCI mode. I install win8 in AHCI mode installation goes fine after installation system boot normal when i eject dvd and then restart my computer it say "No boot device found" I press f12 i cant see any drive except "on board usb or dvd" I do reset bios.. Remove cmos battery.. Press and hold power button.. Button i still cant acess boot squeence menu.. Oh one thing more when i set sata operation to "Legacy" my os start normally.. Please help if u can please. Dell optiplx 755
  • Reinstall WIN8 IN ATA MODE.

    F6 Drivers are required for AHCI out of the box.  

    Install ATA then INSTALL the Chip set Drivers.

    Then run the microsoft fix. You should be using A22 bios for WIN8.

    BIOS - BIOS

    Description Importance Version Released Supported OS Download
    Dell OptiPlex 755 System BIOS A22 Recommended A22 1/4/2013 BIOS

    Chipset - Driver

    Description Importance Version Released Supported OS Download
    Intel AMT SOL/ LMS, v.3.2.20.1049 PV, A02
    SOL/LMS Driver 3.2.20.1049 PV w/ Win7 support
    Recommended 3.2.20.1049 PV 1/22/2010 Windows Vista 32-bit
    Windows 7 32-bit
    Windows 7 64-bit
    Windows XP
    Windows Vista 64-bit
    Windows XP x64
    Intel AMT HECI, v.3.2.20.1049 PV, A02
    HECI Driver 3.2.20.1049 PV w/ Win7 support
    Recommended 3.2.20.1049 PV 1/22/2010 Windows 7 32-bit
    Windows Vista 64-bit
    Windows XP
    Windows 7 64-bit
    Windows Vista 32-bit
    Windows XP x64
    Intel Chipset Software Installation Utility, v.8.3.0.1013, A21
    Software support for Intel Chipsets.
    Recommended 8.3.0.1013 7/11/2008 Windows Vista 64-bit
    Windows Vista 32-bit
    Windows XP
    Windows XP x64


    http://support.microsoft.com/kb/922976/en-us?p=1

    To resolve this issue automatically, click the Fix this problem link.

    Then, click Run in the File Download dialog box and follow the steps in this wizard.


    Fix this problem
    Microsoft Fix it 50470


    Stop 0x0000007B Inaccessible Boot Device


    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating.

  • I know this reply comes a little late but for anyone else experiencing this issue...

    IT CAN BE FIXED!

    This issue seems to arise after a BIOS update not completely flashing correctly. This leaves the user unable to change the boot device priority in the BIOS, consequently causing the machine to complain there there is 'No Boot Device Available'

    Upgrading and downgrading the BIOS via standard means doesn't seem to work; however with certain switches it can be done.

    Firstly, you'll need the first BIOS release, A01 (O755-A01.EXE), currently available from http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=R164252 

    Secondly you'll also require the latest BIOS release, A22 (O755-A22.EXE), currently available from http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=2DWTY

    Finally, you'll need either a USB memory stick or hard disk that is capable of booting the machine into DOS. It is recommended that you use the free tool 'Rufus' to create a FreeDOS bootable memory stick. Rufus is currently available from https://rufus.akeo.ie/

    In addition, you may need to install the service mode jumper on the motherboard; this repair was successfully performed with it enabled, although it *might* work without it installed, although this hasn't been tested.

    Firstly create a FreeDOS bootable USB device using Rufus. Once complete, copy both the A01 BIOS (O755-A01.EXE) and A22 BIOS (O755-A22.EXE) to the root of the memory stick.

    Insert the memory stick into the affected computer and press F12 at the BIOS. Boot from the USB stick. Once at the DOS prompt, type:

    O755-A01 -wipeall -wipeclean

    Press enter and follow the prompts on screen. After the BIOS has been flashed, the computer should restart. Go into the BIOS and check the Boot Sequence options under System. The boot sequence should now not only display the name of your hard disk, but will also be changeable, allowing your computer to boot normally. Set up your BIOS configuration to your liking (Including setting the date and time) and then Save & Exit. Upon rebooting, press F12 again and once again boot from the USB device.

    Flash the A22 BIOS the standard way by typing O755-A22 and pressing enter. Follow the onscreen prompts. Once the BIOS has been flashed, check the BIOS settings again to ensure that the Boot Device menu is still accessible.

    Once complete, make sure to remove the service mode jumper (if installed).

    FAQ

    Why does this work?


    From what I can tell, the earlier BIOS flashing tool includes switches that the later versions do not; -wipeall and -wipeclean are integral to this fix working as they completely erase all BIOS settings that aren't usually erased when the BIOS is updated. For some reason, Dell removed these options from later BIOS update tools.

    In addition, the earlier BIOS flashing tool actually flashes the BIOS itself under DOS instead of relying on loading the BIOS into RAM and then flashing with routines in the current system BIOS. I've no idea if this makes any difference to the process, but I imagine that it allows for more options to be passed to the flashing routine.

    Sorry for the long post but I hope this helps someone out! Having recently got my hands on a couple of these machines and having the same issue, it's incredibly frustrating.