Deleting "Dell DataSafe Local Backup" Subscription Pop-up That Covers Up System Tray

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Deleting "Dell DataSafe Local Backup" Subscription Pop-up That Covers Up System Tray

This question is answered

My apologies if I am in the wrong community. Can anyone tell me how to remove the "Dell DataSafe Local Backup" subscription renewal popup that covers up my

System Tray? I have deleted the Data Safe Programs using Revo Uninstaller, but the Dell DataSafe Ad is still covering up my System Tray. It is not in "Startup" in MSCONFIG.

Many thanks from a confused and puzzled 70 year old.

Verified Answer
  • simply change the screen resolution to a lower level (like 800x600) for temporary basis. Now, you shall be able to see the Dell Datasafe popup in a correct manner. Click on the drop down as shown in the picture and click ‘DO NOT remind me’
    After you select Do not remind me, please click OK. Now that the Datasafe notification is stopped, please change the resolution back to the original settings. Restart computer to confirm if the notification appears again or not.

All Replies
  • Same problem here,  began today. 

  • simply change the screen resolution to a lower level (like 800x600) for temporary basis. Now, you shall be able to see the Dell Datasafe popup in a correct manner. Click on the drop down as shown in the picture and click ‘DO NOT remind me’
    After you select Do not remind me, please click OK. Now that the Datasafe notification is stopped, please change the resolution back to the original settings. Restart computer to confirm if the notification appears again or not.

  • Yes, this did indeed work. Thank you very much!

  • Dear All,

    I have a problem with the pop-up: "Dell DataSafe Local Backup".

    Even though I select in the drop-down menu "Do not Remind me" this pop-up keeps on coming back, directly within one minute and stay in the right corner of my screen.

    This is a very annoyong problem because there is no way to get this pop-up away (I already worked several hours on it) and it is hindering other work. Please let me know your suggestions!

    Many Thanks!

  • Check here for the answer that will stop the annoying pop-up once and for all, http://dell.to/nr0kuE

  • Worked like a charm, on my first try! Your instructions were simple and on point...if you can get me to fix a tech problem then anyone can do it. THANK YOU!!!

  • As others have pointed out, you definitely have to "stop process" in order to delete all of the components but this worked like a charm! Thank you for sharing the solution, Aziz.

    All the best!

  • Hi, were you able to fix this. I am having the same problem but i cant get rid of the pop up. Please can someone help. I dont see a drop down list to turn off.

  • There is a blue button on the lower left; it reads "tell me more" when you click on the button, a drop-down menu appears; you can then select, from the drop-down menu, that you want to stop all offers.  You won't wee the "tell me more" button or the drop-down menu unless, as described in the originating posted answer, you first change your screen resolution.  Changing your resolution will shrink the visible desktop screen so that the pop-up becomes enlarged and positioned higher up on-screen so that you will be able to view the pop-up in its entirety.  Hope this helps!

  • Thank you, thank you, thank you. Fantastic!