XPS/Dimension 630i, videocard problems

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

XPS/Dimension 630i, videocard problems

This question is not answered

Just yesterday I had them ship me my second replacement GTX 280. I have no real problem with the support. I tell them the card has died, they ask me to run through the obvious things that I already ran though the second I had a problem (update drivers, rollback drivers, etc), they send me a new one, I replace it. The problem is then fixed, at least until that replacement card dies six months later.

My problem is that I can't think of any reasonable explanation as to why my machine should have had two video cards die within six months to a year of being installed. I haven't done anything to block airflow, I'm not trying to power anything silly like USB refrigerators, I haven't added any hardware, the only time I've opened the case was to replace the cards that died with the replacement cards they sent me, when I did open it there wasn't any excess dust, I'm not doing anything to put undue stress on the cards, and I haven't overclocked anything, or changed the fan speeds or anything. I bought the machine, I plugged it in, I use it as it was intended to be used.

So from my standpoint one of two things is happening. Either the machine originally had a defective card that was destined to die before its time, which was then replaced with a defective card destined to die before its time. Or I have a machine that is in some way defective and doomed to habitually eat perfectly good video cards. Neither possibility exactly fills me with confidence in my machine, much less enough confidence in Dell to risk ever purchasing a new machine from them in the future. Which is kind of depressing, seeing as I buy about two to three thousand dollars worth of computer from them every five to seven years. Depending on how long they last.

Is is possible that this was just really bad luck. If not, is there anything I can do on my end to help me find out what the problem really is? I mean eventually my warranty will run out, and when that happens I have no desire to buy a new video card every six months. Is there anything else it could be that is causing them to die, psu, motherboard, etc.? And if so is there any way for me to find out what the real problem is? I love my machine when it is working. I just don't care for the uneasy feeling I have that this third card will die eventually, and then its replacement will die, etc.

I would really appreciate any help or advice you can give me on narrowing down the problem, or even just setting my mind at ease that this might really just be bad luck that won't repeat.

All Replies
  • You're not the only one,

    My 630i has been working fine for about a year, and like yourself, i never overclocked it or meddle with the inside of the box, i got it delivered from dell, plugged it in and have been using it. Then in October 2010 my graphic card dies with a spectacular failure during a Stacraft2 session.

    'Oh well' I think, it's probabaly had it run and it's still under warrenty so i call up Dell Tech Support and they try reinstalling the drivers (which fixes nothing) and so they send out technician the next business day (11/08/10) who replaces the card. Problems gone after rebooting the comp, so it's all good.

    Just over a month passes and bang!, another failure which is strange, since the card is only about a month old (unless it's a refurbished card...). Call Dell tech support and I explain that it was only replaced a month ago, and they confirm they can see the last service log and that the card was replaced. They decide to as me to reinstall the drivers (and i explain, they tried that last time to no avail) but hey I humor them anyway. Again no luck with re-installing the driver and they send out a Dell technician to replace the graphics card. (17/9/10). Once the new card is in, everything is back to normal, and the tech guy leaves after seeing the graphic card is working again.

    5 Days later (22/9/10) another failure. I'm getting annoyed and I'm beginning to suspect it's not the graphics card but some other part of the 630i that's devouring graphic cards like it's a bodily function. I'm not all that familiar with the internal components of a computer, so I call dell tech support and explain to them the problem. The solution is to reinstall the drivers. I try to explain that I've already tried that the last two times and that this is the third time the card has failed and that I think there might be another problem with the system and the multiple failing graphic cards might only be a symptom of that problem. Still get told to re-install the drivers, but this time Tech Support tells to remove all Nvidia drivers using a program called Drive Sweeper. So I humor him and follow his instructions. Again doesn't fix it and he says he'll arrange for a Technician to come out and replace the card.

    I have no idea what's causing the problem, and Dell tech support seems to be limited to 're-install your drivers' but given that my graphics card is a 9800GT but I'm having the same problem on a 630i  I'd hazard a guess that it's potentially something else that causing your graphics card to fry itself.

    I supposed I'll just keep trying Dell tech support but hey if Dell wants to burn through stocks of graphics cards instead of trying to help me figure out that problem, I'll have no problem helping them burn money every 4 days until my warranty is up (120 odd days to go) then I'll get Dell Recycling to take the comp away  and buy a different brand.

     

  • It seems that I'm in a similar situation as you. The replacement card I mentioned they were sending seemed to work until I tried playing a game. I exited the game after playing for five minutes only to find that my GPU was at 103C. I called and tried to explain to them why this is bad, and that it was starting to look like the dead video cards were a symptom of a separate hardware problem. Their response was to send out another video card, this one also hit 103C after only five minutes of gaming. Keep in mind I'd been playing these games for months with no problems, and before that my temps had never gotten above 84C even under full load, (82-83C under full load is where it had topped out in the past.) They then suggested that I reinstall the OS. This helped with the temp problem, and my machine worked fine for a day or so, until that video card died. That card never hit those temps, so I have no idea why it died.

    I reboot and now I have artifacts on the boot screen. Now that it is completely obvious that I have a motherboard problem, they decide to send out a tech. He replaces my video card, motherboard, and heatsink. This seems to fix the problem, until a few days later when that video card dies.

    I have no idea what could be wrong with this machine, but it isn't fun talking to the "technical support" people for hours, only to have them suggest things that have already been tried. It is also obvious that this isn't the fault of the people on the other end of the phone, in the case of a few of them, they didn't seem to have much technical knowledge, and seemed limited to whatever script, flowchart, or program they're told to use. It has become pretty obvious that they have this "ask question 1, make suggestion 1, 2, and 3, move on to next step" role, and either aren't capable of, or allowed to deviate from it. I'm starting to feel like I'm being purposefully led in circles.

    The only upside is that my warranty lasts until the end of 2012. Hopefully at some point between now and then they'll be able to fix my PC in a way that has it work for more than a few days at a time.


  • mikeoconnor

    I would suspect Dell's so-called 'Refurbished' replacement video card, I had a video card replaced under warranty with a 'Refurbished' card and after two months it failed, I purchased a retail card and have had no issues since.

    Bev.

     

    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell

  • Mike This is exactly what is going on with my 2 Nvidia 9800GTs

    I have 2 SLI and Dell has replaced them now 3 times.  Seems if I un-SLI them, I don't have a problem with one.  But that is not proven yet.  They have replaced the mother board as well.

    Now they are sending new ones.  We'll see.