Vostro 220 will not boot up

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Vostro 220 will not boot up

This question has suggested answer(s)

Hi,

I have a Dell Vostro 220 running windows Vista Home Basic. It will not boot up. When I power it on, the fans kick on and it sounds as if it will start up normally but it never actually does. The indicator light glows a solid amber yellow color. It does not beep or give any other indications. Nothing ever appears on screen.

I bought this cpu new in Feb. 2009. In Sept. 2009 I had the same problem. Luckily it was under warranty the first time. Dell sent out a Service Tech the next day. The tech could not pinpoint the exact problem but said it was a power issue. I was ordered a new power source, ram and motherboard. Dell overnighted the parts and the tech came back and repaired the unit the next day. All was well, but I was sceptical.  To me, that seemed like a major repair to a CPU that was only 7-months-old.

That was about 8 months ago, now I have had the CPU for 15 months total. I have called customer service to see what could be done. Since I am a repeat customer and have a cpu that is obviously defective or at least has a significant problem, I thought maybe I would get some level of satisfaction. I was told "we wish we could help but you are out of warranty". I asked to speak to a manager and was told the same thing. They recommend that I buy all of the same components that were replaced last time (without even doing a diagnostic)  at my own expense. BTW this totals more then half the original purchase price.

I expected more from Dell. Has anyone else had the same problem??? I feel like I got a lemon and instead of being offered any assistance at all I am being told too bad, we fixed it once, now it is your problem. That does not seem right to me. I will not buy again!

Sad

Dissatisfied!

All Replies
  • ballenbert

    The Vostro 420/220/220s Troubleshooter is HERE.

    Have you tried opening the case, remove and reconnect all the power and data cables, remove and reinstall the memory and the video card if installed, to see if it makes a difference?

    Bev.

     

    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell

  • Hi, I would take out your memoty modils and replace them one at an time. If that does not work, try making sure your PCI cards are well seated in the board and free from dust and dirt around the slot on your mobo. EDIT: Close behind you Bev.

     

    • If the power light is steady amber, a device may be malfunctioning or incorrectly installed.

    • Eliminate interference. Some possible causes of interference are:

      • Power, keyboard, and mouse extension cables
      • Too many devices on a power strip
      • Multiple power strips connected to the same electrical outlet
          

    If my answer Was helpful?  Please let me know by clicking on the 'Did this answer your question' and clicking on the Yes button.  Thanks.


     

     

  • Hi shesagordie,

    Thank you for the suggestion. Yes I tried all of the basic trouble shooting and nothing I have done, including what you listed, has made any difference. I was mainly wondering if this is a big problem for the Vostro 220. Are many other users are experiencing the same thing? The second service rep I spoke to said something to the effect of "we have had a bunch of problems related to the power supply with the Vostro 220 within the first few months of use, but they have all been fine after the first repair or parts replacement." Seeing that is not the case with mine and I am having the exact same problem again ( 3 months out of warranty) I think that there is a bigger issue with this specific computer (if not the 220 series made at that time - Feb/March 2009) in general. I have tried everything and am not getting any sastifaction or customer service from DELL. I am going to talk to the Better Business Bureau and see if I can file a complaint. I feel I have certainly gotten a Lemon... at least that is what you would call it if a new car had the same amount of problems in the first 15 months that you owned it. If anyone else is dealing with the same issue, let me know. I should have more information in a week or so.

  • Hi Robin,

    Thanks for taking the time to make a suggestion. I have tried all of the basic trouble shooting, I was through the same entire process only 7 months ago so it is still pretty fresh. Nothing is working however :(

  • If it really is the power supply that's at fault, a different make and model of replacement can be bought here.

    The power supply is standard TFX and can be sourced from a number of independent vendors.  And at $35, it's a reasonably cheap solution.

  • RDUNNILL,

    Thanks for taking the time to post. Unfortunately, it is not nearly that simple. After being unsuccessful with all of my trouble shooting efforts, I finally took the CPU to the local and trusted repair shop. They called me back this morning to tell me the "Vostro 220 is shot". I never told them what went wrong with it back in September so I asked them to tell me exactly what needs to be replaced. They told me that there is a major failure with the Power Supply, Motherboard and Processor. Funny, that is exactly what I replaced last time; they even replaced the RAM 9/09 as well. So, my problem was never fixed, I have a faulty CPU and the same parts are failing in 7 month intervals. That is exactly what I was afraid of the first time.

    I am in disbelief that DELL is handling my issue with such blatant disregard. I have a faulty product, a lemon an inferior CPU and they will not even acknowledge it. They offered enough repair help over the first 12 months to get me to limp along until the warranty had run out and now they will not discuss it with me any further. “Sorry, wish we could help but you are out of warranty!”  They do not wish to help, apparently they do not even care if I buy from them again ( I am a repeat small business customer. This was my third new CPU purchase) I was never offered a diagnostic, discounted service or repair or even a rebate toward a new purchase. I obviously need a new CPU now, you would think that they would at least want my business again!?!?!?!

    The local shop tells me that this series is known to be a "Disposable CPU" and that they very frequently fail right after the warranty has run out. Mine is no exception, however there were major issues that all started well within the warranty period and they were never repaired properly. That is my biggest problem. DO NOT BUY A VOSTRO 220. They are cheaply made and will not last.

    I have been left with no other option. I am taking a statement of repair work required along with my first complaint and the list of repairs preformed by Dell in Sept 09 to prove that the exact same parts have failed once again and filing a complaint with the Better Business Bureau.  I am also going to call two local TV stations that have consumer reporters that love this type of thing and share my experience with them. I will create a YouTube channel devoted to this issue. I will not stop until they resolve the issue, repair or replace my CPU.

    In this economy we cannot afford to be taken advantage of by “trusted brands” like DELL. I made this purchase to help me grow my Small Business and now I am without my central Business CPU and am left out in the cold!

     

  • @Ballenbert

    The story you've written describes my situation perfectly.

    I have a Vostro 220 as well that was purchased June 15, 2009.  In March of 2010, the same thing that happened to you happened to me.  I tried to power on the unit and only get a steady amber light.  I went through the troubleshooting process with the tech on the phone unplugging just about everything that was optional (drives and RAM), still a solid amber light.  They determined it was the motherboard or power supply.  The local tech came out and replaced the power supply and the front panel.  The unit powered up and worked okay.  June 27, 2010, we're back to the exact same issue - won't power on with a solid amber light.  I called Dell for support, I got the same non-service answer as you did  - "sorry, I would like to help you, but the system will not let me since you unit is out of warranty."  Come on, a week or two out of warranty with the same exact issue as when the unit was in warranty and you won't fix the problem!?  I also asked to speak to a manager.  Same response - "we can't help you without extending the warranty."  My contention is that they didn't fix the problem in March, since the unit only made it three months before it died again and the failure is exactly the same.  Dell support, however, wouldn't budge.

    I have purchased other brands of computers and built several of my own.  All of my other computers have been running in the 5 to 10 year range and the only reason I took them out of service was because they were outdated, not because of hardware failure.  I also, will never buy another Dell and I will tell as many people as possible not to buy a Dell!  They are junk!

    Super Angry

    Extremely Dissatisfied!

  • All,

     

    Add me to the list of frustrated customer when it comes to amber light for Vostro 220.   My Desktop malfunction for almost a week now, and I came across this forum via google search.  I will call Support and see what they have to say.  I checked my Hard Drive by attaching it to a USB ENclosure Drive, and the files are still there.

    It is a HW problem for sure.  Wish I did not try to save money for a Vostro, as I got the brand new PC (purchased in lat Jan 2009) cheap.

    Frustrated customer.

  • A followup on my situation...  I took apart the computer, removed the PSU and disassembled the PSU.  I found that one of the toroid inductors got hot and one of the capacitors looked suspect with a bulge on top.  I ordered a new Rosewill supply from newegg.com per rdunnill's suggestion above.  I replaced the PSU with the Rosewill unit and the computer came back to life!  The Rosewill PSU is lacking a long enough power cable for CD/DVD/ROM drive, so I will have to extend that cable.  At least the computer is back up and running.

    The burned out PSU brand is Bestec.  Hopefully the Vostro will stay up for more than 3 months this time.

  • @laksafan

    Seems like there are at least a few people with the same issue. Good luck with Tech Support. I can tell you this from experience, if you are out of warranty you are out of luck no matter when the trouble started. If you are still under warranty I have a helpful hint... No matter what Tech Support says, call Customer Satisfaction and tell them that you are not satisfied and that you want to exchange your CPU for a new unit. I found that out last week. It does me no good now and no one told me that was an option 7 months ago! But, maybe it will help you.

  • Hello fellow unfortunates-

    Add another notch on the post for me, please, as I have just secured my membership in the Vostro-A-NoGo Club, too. And while it's almost an exact repeat of what's been said, I'm going to add mine as it looks more and more to be something which needs to be repeated; the Vostro 220 ("220s"-slim, in my case) is:

    1. Plagued with an inherent design flaw
    2. Was built using cell phone industry standards (even top-of-the-line cell phones are built with components not expected to last beyond 2 yrs.)
    3. Makes a better doorstop than a PC
    4. All of the above

    I bought mine June '09 and it was dead by New Years. Dell replaced the motherboard Jan '10, and 3 weeks ago the system once again has kicked the bucket. When it died the first time my thought had been towards the power supply, and I am going to gamble that this is the problem now, and try putting in a replacement. In looking it over thoroughly the power supply, in my opinion, lacks adequate ventilation if nothing else.

    But, for myself the trouble isn't just in the failures it has had, but also in how it has performed all along. This machine was bought for a very light-duty application, and it has been a "slow dog" from day one. As the extremely happy owner of 2 PowerEdge servers, 2 Inspiron laptops, 4 Precision Workstations, 5 Dimension series, and 2 Optiplex machines I am very disappointed with the Vostro.

    If the replacement power supply works, I'll post back and add that info; otherwise I will be looking to buy a really big cigar box, some daisies and a shovel!

     

  • I didn't have any such problems with my 220s, and it was bought as a stripped-down refurb on eBay (no CPU, memory, heat sink, etc.) I do agree the power supply runs hot.

  • I understand how you all feel. I have 20 Dell  Vostros 220s. Out of the 20 I have had 11 blow on me right after the warranty expired. I have placed a complaint to Dell and asked that they research the PSU as I felt it was defective. Out of the 11 Vostros that blew all of them had the Bestec PSU. The other 9 I have are made by another company and have not had any issues. One user mentioned the Bestec as their PSU. Did anyone else have another type of PSU that blew? My fix was to replace the PSU with a non Bestec made one and so far all my Vostro's are running with no issues. It has been almost a year since I replaced them and Dell still denies there is an issue with the Bestec PSU. I still feel this is not the case and wish Dell would do more research.

  • Rich- Yes, ours was also a Bestec, and unfortunately it took out part of the motherboard (which was board #2) with it as well when it croaked. We've not yet replaced the dead MB, as we have been very happy with it's performance since then; it is just heavy enough to hold the office door open securely, but slim enough to not get tripped over, and the CD slot makes a great place to stick outgoing mail!

  • I have the same problem with my Vostro 220s that I have been using very seldom for just over a year.

    I will replace the PSU to see if the problem gets resolved. I will post how it went.