Optiplex GX270

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Optiplex GX270

This question is not answered

Hello, 

I have a Dell Optiplex GX270 running Windows XP that is running extremely slow even without being on the internet. The hard drive has over 3/4 unused space left on it but the RAM is over half used up. The system came with 512 MB of RAM. I have tried cleaning out the system by running virus scans, spyware and malware scans, cleaned the temporary files, cache and internet browsing history, cleaned the registry and defragged the system. I have also removed some programs which I do not use anymore but I am not sure what else to do at this point. 

I would appreciate any suggestions to clean up the computer and get it running faster. 

 

Thanks

All Replies
  • 512 MB is kinda low for Windows, but I take it the system is even slower than usual... When you say RAM is 1/2 used, does that mean 256 MB are used to load Windows and whatever's running in the background?

    Reboot and press F12 before Windows starts to load. Go to the Utilities partition and run the RAM tests and extended hard drive tests, just in case you have a hardware issue.

    Open Task Manager (press ctrl-alt-del) and look in the CPU column. See if can you identify some process that's hogging CPU time, other than System Idle process.  That may tell you what may be slowing down the machine.

    If you boot in Safe Mode (press F8 before Windows starts to load), does it run faster in Safe Mode? In that case a driver or something else loading in the background may be causing the problem.

    Are antiviral scans or Windows Indexing Service, both resource hogs, running in the background?

    How big is the Page File setting?

    And last but not least, after a while Windows just gets so mucked up with garbarge that it slows to a crawl. And in that case, the only real fix is a clean install.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • One more thing...

    Reboot and press F2 before Windows starts to load to open BIOS setup. Look for the CPU Speed Option. It should be set to Normal (or something similar) , not to Compatible (or something similar). Make the change, if necessary, save it and exit setup.

    Your system has the ability to slow the CPU speed down to run older software and hardware. If you accidently pressed  Ctrl-Alt-\  on the keyboard, you may have toggled the CPU to its slow speed. The change takes effect without rebooting and stays that way until you toggle the hotkeys again or reset CPU speed in BIOS setup.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee