Dell OptiPlex 755 memory error. - General Hardware - Desktop - Dell Community

Dell OptiPlex 755 memory error.


Desktop computer Forums (Audio, General Hardware, Video)

Dell OptiPlex 755 memory error.

This question is not answered

We have a Dell OptiPlex 755  where the diagnostic lights will often show a 3 4 pattern.  This fault usually occurs about once per week.  I realize this light pattern indicates the system has detected a memory failure, though I have replaced the two DDR2 memory modules three times over the past year.  The memory was twice replaced using new Dell modules (Nanya) and once with modules ordered from

What’s the problem and how do I fix it?


<ADMIN NOTE : Service Tag removed per Privacy Policy>

All Replies
  • Have you considered that it might be one of the dimm sockets and not the ram at all. Try removing 1 module and see if the error code remains. If so try the remaining sockets. This should enable you to find out if its the MB or not. Good Luck.

  • Take it one step further ... boot to the 32-bit diagnostics to test the memory with MPMemory.  This will tell you which DIMM, then you can swap positions to see if it follows the memory or stays with the slot.

  • Take it one step further ... boot to the 32-bit diagnostics to test the memory with MPMemory.  This will tell you which DIMM, then you can swap positions to see if it follows the memory or stays with the slot.

  • That possibility did occur to me.  I shifted the pair of memory modules to the remaining two DIMM slots and the outcome was the same.  The system would POST without problem for about a week then the 3 4 diagnostic light pattern would return.  I’ve tried using single modules in all DIMM slots with the same end result.  Over time, 8 unique 1GB DDR2 (533MHz) modules have been used, in matching pairs as well as individually.  The temporary fix is to simply reseat the modules within the same DIMM slots. 

    I also considered the possibility of the system BIOS rejecting the memory modules’ SPD settings.  If memory data is incorrectly interpreted, either for the size, speed or timing values being reported, the BIOS might not allow the system to complete the POST process.  Reseating the memory modules apparently allows the BIOS to requery or at least accept the SPD information presented and permits the system to boot.  Since the system is using the most current BIOS version available (the latest of several revisions) and given the fact memory modules from three different manufacturers have be used, I suspect the root cause of the problem is not memory related.

  • I would agree with you that it is not the memory but the board itself.  I have also seen PCI cards cause what seemed to be memory or processor errors ... as a long-shot final follow-up ... do you have any PCI cards in the system?

  • I have already run the internal memory diagnostics as well as the full 32-bit diagnostics including MPMemory.  There is never a problem detected only the issue where the disk test queries the empty DVD drive and mistakenly suggests a potentially failing drive.  In an earlier reply, I incorrectly stated the speed rating of the memory modules as 533MHz, the actually speed of each is 667MHz.

    When the 3 4 error occurs the system never completes POST to allow booting to the diagnostic media.  So, I can only run the diagnostics after I have cleared the fault in this case by reseating the memory modules.  Once inside the diagnostics no real problem is ever detected.

    I’ve considered this problem as being a capacitor issue as I have experienced so many times in the past with the older OptiPlex GX models.  In this case, that doesn’t appear to be the reason the system halts at this specific point.  Once booted, the system appears to function normally.

    Something in the BIOS is not allowing the system to complete the POST process, apparently stopping at the point where the memory test begins.



  • Nothing in the adapter slots.  It's a basic system in a desktop style case.

  • Yes, the actual problem must lie within the system board itself.  While searching for a solution online, I found what seems like an almost endless number of support queries involving the Dell OptiPlex 755.  Given the volume of technical complaints it’s somewhat obvious this particular model suffers from extremely poor design and engineering.  Almost all of our 755’s experience this exact same trouble, some much more often than others, with the worst case being weekly POST failures requiring the temporary fix of reseating the system’s memory modules.  Many others of this same model also experience network connection and multicast failure issues which until now I had not connected to faulty system hardware.

    At this point, it seems our only option is to have the system boards of all of our OptiPlex 755 machines replaced under warranty.

  • Hi John

    Did you get this resolved - was it a warranty job?
    I have a 755 sff that now only manages to complete about 1 post in 20, and then doesn't stay working for more than 10 minutes!
    A real shame, it's been faultless for 9 months running with core2quad, 8gb RAM as an ESXi test rig at home. Just the last week it went flakey with regular reboots several times a day, now the 3+4 LED issue with no post :(

  • That's just how computers work.  As small-scale as they are and as finely-tuned as they are, one minute they will work fine, then after the moment something happens, it doesn't work.  Heat, electricity, dust, vibration, etc. in the smallest amounts can cause damage in split milliseconds - works one minute, not the next.  Run the diagnostics, swapping DIMM's to isolate which is the problem, then call it in for a replacement.  I'm assuming this is still under warranty since it is only 9 months old - if not, memory is not expensive to replace.

  • While rebuilding a 780 mt I got the same error code and after a little looking around I found the CPU to be bad, after installing a new core 2 dual the error cleared and all was well.