XPS 420 Bluetooth: How To Disable?

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

XPS 420 Bluetooth: How To Disable?

This question is not answered

The blue Bluetooth LED on my Dell XPS 420 is constantly on (which I assume means Bluetooth is active all the time). I want to turn off / disable Bluetooth. I would really appreciate someone letting me know how this is done. Thanks!

All Replies
  • I think we need some more details here. Do you have a built-in card reader with bluetooth, or a bluetooth keyboard or mouse..?

    Where is this bluetooth LED?  The power button on the 420 should be solid blue (not blinking) when it's running. Are you sure that's not the blue LED you're seeing?

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Thanks for your reply Ron.

    My XPS 420 has the built-in card reader.

    The Bluetooth LED is located on the card reader itself. Whenever I power up the Bluetooth LED (blue colour) is on.

    Definitely not the power button...100% sure of that!

     

    Greg

  • Sorry, had to ask if you were looking at the blue power button....  Wink

    Any particular reason you want to disable bluetooth?

    If the card reader puts an icon in your system tray over by the clock, right-click it and see if there's an option to disable bluetooth.  If not, look in in the Control Panel (start>settings>control panel) for a control panel either for the card reader itself or one for bluetooth. Open it and see if you can disable bluetooth there.

    Since I don't use that carder reader or bluetooth, I'm not even sure you can disable it.  Surprise

    Ron

     

     

     

     

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I've also asked if any of the forum's gurus know how to do what you want...

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Try this in XP:

    Click start>run

    Type in: bthprops.cpl

    Click OK

    Assuming that opens the bluetooth control panel, look for options to disable it, then reboot.

    If you have Vista or Win7, try typing in: services.msc instead of bthprops.cpl

    Look for the bluetooth service in the list and double-click it. On General tab, set the Startup type to Disabled.

    Do not change anything else in services.msc!

    Exit services.msc and reboot

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Hi Ron,

     

    I want to be able to disable the Bluetooth because:

    1. We don't use it on this computer.

    2. My kids use this computer and I would rather switch it off as I'm unsure of the potential health risks...(controversial, I know!).

    There is no longer a Bluetooth icon on the system tray. There used to be but I think it is no longer there after a previous attempt to disable the Bluetooth.

    I can't find anything in the Control Panel for the card reader itself.

    In Control Panel > Hardware and Sounds > Bluetooth Devices, I click on 'Bluetooth Settings' tab but nothing opens. I assume this is for the same reason I have no icon in the system tray!!!

    Not sure if this information will be useful or not...either way, thanks Ron...I appreciate your help.

    Greg

  • I'm using Vista Ron.

    I opened services.msc but nothing Bluetooth related on the list.

  • I'm using Vista Ron.

    I opened services.msc but nothing Bluetooth related on the list.

  • Do you have a bluetooth device to see if it will sync? I see posts claiming bluetooth won't show up in Vista's control panel or system tray until an active BT device is synced. Seems odd, but we're dealing with microsoft here. Big Smile.

    What happens if you run  bttray.exe from the Start menu?

    And read the post by Srinivas R here.  Modify the registry at your own peril!

    Ron

     EDIT: I fixed the link

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Doji

    Control Panel>Bluetooth>Bluetooth settings (up top).

    This will open a menu with a number of tabs which allow you to decide your bluetooth settings.

    You can set your computer to be discoverable or not, and decide whether or not to allow other computers to connect.

    You can also turn on the bluetooth icon in the system tray from here.

    If you do put the icon in the tray, you can right click on it to get to the bluetooth settings.

    Hope this helps.

    :)

  • Thanks Peppurr101...I wish it was that straightforward!

    I do have Bluetooth Devices > Bluetooth Settings in Control Panel.

    Whenever I click on the Bluetooth Setttings tab...nothing happens.

    Frustrating!

  • Ron, I have tried to sync my Logitech mouse and keyboard, as well as my mobile phone (w/ Bluetooth on and discoverable). Nothing happens!

    I reinstalled the card reader w/ bluetooth driver from Dell...still won't sync.

    I then also installed the Setpoint software from Dell...still nothing!!! I have uninstalled both.

    Not sure if this is useful, but when I run bttray.exe I get a notepad config document:

    [ConfigList]
    0 = "Widcomm"
    1 = "Toshiba"
    2 = "Sony"
    3 = "Microsoft"


    [Microsoft]
    File0 = "WINSYSDIR\DRIVERS\BTHUSB.SYS"
    FILE1 = "WINSYSDIR\DRIVERS\BTHPORT.SYS"
    FILE2 = "WINSYSDIR\DRIVERS\BTHenum.SYS"

    [Widcomm]
    VerChkType = Reg+FileVer
    VerChkData = "HKEY_LOCAL_MACHINE\SOFTWARE\Widcomm\Install: INSTALLDIR + BTTray.exe"
    version = 5.0.1.2500
    REG_STRING1 = HKEY_LOCAL_MACHINE\SOFTWARE\Widcomm\BTConfig\General:WizardLink%LOGITECH
    op1 = ||
    REG_STRING2 = HKEY_LOCAL_MACHINE\SOFTWARE\Widcomm\BTConfig\General:WizardLink%LOGICOOL

    [Toshiba]
    File0 = "WINSYSDIR\TosBtAPI.dll"
    RegKey0 = "HKLM\Software\Toshiba\BluetoothStack"

    [Sony]
    File0 = "WINSYSDIR\DRIVERS\OIIBTUSB.sys"
    FILE1 = "WINSYSDIR\DRIVERS\oiind2ku.sys"
    FILE2 = "WINSYSDIR\DRIVERS\oiivcomu.sys"

  • In my "Hidden Icons" I have a bluetooth icon (this is Windows 7 HP 32 bit on an XPS420) and if I right mouse click and then open settings I get a Window up which has a box on it saying "Allow Bluetooth devices to find this computer" - on my system, which I haven't changed in this area because I just can't be bothered to figure out how to make Bluetooth devices work sensibly - the whole thing is a nightmare, this box is unticked. I assume this means that the Bluetooth capability is switched off, however the blue light on my card reader panel continues to be lit up. If I switch Bluetooth on on my mobile phone and tell it to make itself visible to other Bluetooth devices nothing happens on my XPS420, so I assume from this that the Bluetooth radio is not operational on my 420 with the box unticked. Could be wrong but that's my guess for now.

    Bernard

    XPS 420, 8GB, Windows 7 Home Premium SP1 64 bit 

  • Your txt file looks like it shows all the right drivers are installed. I'm certainly no bluetooth expert so I can't tell you if that file doesn't have any errors, or why it won't sync. Perhaps the transmitter is off, even if the light is on.

    The card reader is connected via an internal USB port so, with thanks to Mombodog, in Device Manager select View Hidden Devices, and then select View by Connection. See if the card reader shows up there and then see if you can disable bluetooth that way. 

    And if all else fails, you could always, power off and unplug, then open the case and disconnect the card reader from the motherboard. But you won't be able to use it at all afterwards.

    Ron

     

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Doji

    Can you get yourself a Bluetooth device and try and see if it attempts to connect to your 420. You never know you may be trying to achieve something you don't need to. If you have a mobile phone there's a good chance it has a Bluetooth capability - activate this near to the 420 and see if the 420 recognises it - if it does you will get messages up on the Vista screen saying a device wants to connect with your 420. If you don't get that then you can be fairly certain your 420 does not have Bluetooth active - I never seen anyone suggest that the blue light on the reader means anything other than that there is power on to the device - after all, all the other lights on the front of your 420 are blue with the exception of the card reader light when there is a card inserted (then you get a green light). As a further check when you have the Bluetooth device near to the 420 and Bluetooth activated on it take a look at Task Manager - if it says Bluetooth Network Connection is disconnected on the Networking Tab then again that's a good indication that your Bluetooth is not switched on.

    Bernard

    XPS 420, 8GB, Windows 7 Home Premium SP1 64 bit