XPS 400 Lights 2 and 4


Desktop computer Forums (Audio, General Hardware, Video)

XPS 400 Lights 2 and 4

This question is not answered

I have a dell XPS 400 that i usually leave on all the time and the other day I passed by it and it had a blue screen with an error code which I didn't write down or remember so I turned the computer off then back on and now I get the 2 and 4 lights on on the tower but no picture or anything. I ordered a new video card and installed it but still same problem. I have tried reseating the memory and reseating all plugs on board. Power light on tower is solid green

All Replies
  • Hi, mmatt21e:

    So with the new video card, you still get lights 2 and 4? Did you try setting BIOS defaults?

  • Yes the 2 and 4 light is still on. As far as the Bios I don't have a picture at all to be able to set the bios. The monitor is in standby mode like it's not getting a signal from the cpu. 

  • I still haven't solved this problem yet. I have searched and tried many things

    Swapping memory in each slot indivudally. 

    New video card

    new monitor

    reset bios by removing battery and holding power. 


    Any other things I can try?

  • This is 5 years too late but I had the same problem and was finally able to get the system to boot into bios.

    When the cpu turns on, the errors lights are 1-4, then 2-4 where it stays indefinitely. I first disconnected the power cable, then while pushing the power button down I connected the power cable. This sounds like a bad idea to do and probably is, but I accidentally did this and it cleared the error and I was able to get past all the error lights and get into bios.

    I checked bios and tried restoring things to their factory defaults in case anything had been changed and was causing the problem. When the system boot the OS, it had this error,

    " floppy diskette seek failure. Strike F1 to continue or F2 to run the setup utility."

    Now as far as I know, there isn't even a slot for a floppy disk on this computer, so I unplugged the optical drives in the computer.

    I restarted the machine and did the same trick I mentioned earlier to get past the errors. I went into bios and disabled the what I think was optical drive and I told it to use PCI not PEG for the graphics. This seemed to work and the floppy error went away.

    Now the only problem is that even the system boots, the OS will freeze and I will be stuck with the windows logo. I tried to install windows 7 instead and it still gives the same issue. Also, I occasionally have to try the same power trick to get past the errors when booting.

    At this point I am thinking it's the hard-drive of the machine that is going bad. If anyone has any thoughts on what could be done further, let me know.