Dimension 5150 - flashing amber light - General Hardware - Desktop - Dell Community

Dimension 5150 - flashing amber light


Desktop computer Forums (Audio, General Hardware, Video)

Dimension 5150 - flashing amber light

This question has suggested answer(s)

I've got a Dimension 5150 that refuses to boot. On/Off switch is flashing amber, and hard drive LED is lit. Dell suggests power unit is OK, and the problem is elsewhere. Anybody got an answer?

Thank you

All Replies
  • Hi, Gerry:

    Unfortunately, there seem to be a large number of posts reporting this same problem. I recently helped a guy on another forum by pointing him to this thread, where the solution involved replacing the front I/O board:


    Let me know if that's helpful.

  • Try a different power cord. This worked for me.

  • Super AngryHi Gerry, I have the same problem on a friends  dell 5150, but no hdd light. Check the front usb ports are not dammaged inside. make sure none of the pins are touching the sides or each other.This has worked for some people. This stoped my amber light flashing, but it still wont boot. I now have a solid amber light. Hope this works for you.

  • Gerry,

    Unplug the front panel connector.  The machine will boot right up.

    The usb pins are usually the culprit.  I pulled the front the little board out and took a pair of pilers and removed the bad usb port and it fixed it.

    If it works without the board plugged in the only drawback will be no power switch.  The machine will turn on when you plug in the power cable so its not the end of the world.


  • I have an E510.

    A flashing amber light in most cases is a failed power supply.  That is what the Dell manual says about a flashing amber power light and what the overwhelming majority that have had the flashing amber power light have had fail.  There have been a couple of motherboards and one front panel assembly and one with the USB pin issue, that I know of and all the rest have been the power supply. 

     This has been the major failure in the 5150/E510 that has been reported on this forum in last two years, or so (the failure reports started on the old Dell users forum).  The problem in the power supply, as reported by a computer tech, is several capacitors. 

    The E510 power supply is a standard ATX supply that has a 24 pin or a 20 plus 4 pin motherboard power connector, a 4 Pin Molex for the motherboard,  two SATA for the Hard drive(s) and two PATA/Molex for the CD/DVD drives.  If there are any other optional devices obviously there will be power needed for that.  A minimum 350 watt power supply with a 400 watt being better.  As there is limited space for extra cables inside the unit a modular type power supply is recommended as these only have the needed power cables connected.

    I am not a Dell Employee

    Dell forum member since 2002

    Inspiron 15 - 5577 Laptop

    Home Built Desktop PC with ASUS Z170, i7 6700K CPU,  Windows 10 64 bit Pro. SSD drive.  Sonar Platinum Recordng Studio Software.

    Dell SE2717HR 27" Monitor


    Member of Nashville based R.O.P.E.