Inspiron 530 - Windows 7 - Intel 82562V-2 network card

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Inspiron 530 - Windows 7 - Intel 82562V-2 network card

This question is not answered

Hello

I installed Windows 7 on a Dell Inspiron 530.

Adter a reboot everything works fine until I put the computer to sleep.

After resuming from sleep the cpu usage is extremely high even when the computer should be idle. Task Manager shows that the System (PID 4) process is using some cpu. Resource Monitor shows that a lot of time is spent in System Interrupts - Deferred Procedure Calls and Interrupt Service Routines.

My conclusions at this time is that the integrated network card (Intel 82562V-2) does not properly resume from sleep and creates a lot of system interrupts.(Disabling the network card makes the problem go away right away, and the problem comes back right away after re-enabling it.

Tried upgrading BIOS of computer and driver of network card but that did not help.

Any suggestions? Somebody else tried Windows 7 on a Inspiron 530?

 Thanks.

All Replies
  • Running Win7 a couple of days here. Fresh install of 64-bit version. Win7 recognized all of the board components including the onboard Intel 82562V-2 nic.

    I put the system to Sleep, then resumed after a time. No issues here with the nic being a resource hog after the resume.
    I'm using bios 1.0.18 and the nic driver is from the default Win7 install. This driver working fine for me without issue and it is newer than both the Vista 32-bit and 64-bit versions supplied from the Dell drivers download for the Insp530. If you are using a Dell driver for the onboard nic, maybe uninstall it and let Win7 install it's own default driver for that nic??

  • Thank you for your help DrunkMonkeyboyx

    I am using a 32-bit version of Windows 7 which is an in place upgrade on top of the existing Vista install. Mabe doing an in-place upgrade was not a good idea after all...

    I tried the default Windows 7 driver, the latest from Intel, and the Vista driver from Dell. The behavior is the same regardless.

    What is strange is that different people report different problems with this card or with Windows 7 networking in general. For example:

    http://en.community.dell.com/forums/t/19300552.aspx

    http://en.community.dell.com/forums/p/19301399/19578499.aspx

    http://en.community.dell.com/forums/p/19300646/19575929.aspx

    http://en.community.dell.com/forums/p/19301539/19579245.aspx

    http://communities.intel.com/message/71749#71749

    It is hard to see a clear pattern.

    Anyway I'm glad everything is working fine for you. I will wait a few weeks to see if Dell releases a new BIOS or new drivers. I am currently using hibernation instead of sleep and that is an acceptable (but not ideal) solution. And maybe I will try a clean 64-bit install on a new hard disk... Thanks.

     

  • I also did the in place upgrade, and like you was having problems with the integrated network card when returning from sleep.  I solved it by going to Add Remove Programs and removing the Intel Pro Network connection manager that the upgrade had left in place.

     

     

  • Thanks

    I will check this out tonight. What were your symptoms exactly?

    EDIT: the only thing I see from Intel in Add/Remove programs is the network driver I installed the other day.

    Please post more info about the problems you had and what you did to solve them.

    Did you install the Intel Pro Network connection manager yourself in the past? What is it?

    Thank you!

  • gartaud

    Please post more info about the problems you had and what you did to solve them.

    Did you install the Intel Pro Network connection manager yourself in the past? What is it?

    Thank you!

    I think I probably did - when I installed the official Intel drivers for Vista I seem to recall installing it then.

    My symptoms were identical to yours - the NIC would just sit there interrupting endlessly and my CPU consumption was always high.

    It looks to me like the in place upgrade leaves traces of the Vista drivers around, which was why when I removed the intel Pro  drivers it started working.

    Sorry I can't be much more help.

     

     

  • Thank you for your reply.

    I uninstalled the Intel driver and reverted back to the MS driver. Sadly that does not help in my case, even when playing with the Power Management options.

    So I will be using hibernation until Dell releases its on Windows 7 driver. Hopefully that will fix the problem. If not I will try a clean install on a new hard disk.

    Again, thank you for your help.

  • Have you tried the latest drivers from Intel?  You can find them HERE.  Once on the page click on Windows 7 and a list of 82562 drivers is listed.  The latest was released on 10/23/09.

    Vostro 460 – Intel Core i7 2600 @ 3.4Ghz - 16GB DDR3 @ 1333MHz –Kingston 240GB SSD – Seagate 320GB HDD – ASUS GeForce
    GTX 550 Ti 1GB DDR5 – 16X DVD-RW – 16X DVD-ROM - Antec 550w PSU - Windows 7 Home Premium X64 SP1- Dell E2211H 22"Flat Panel Monitor

  • Hi and thanks for your help.

    Yes I did try the latest drivers from Intel and they work fine until I put the machine to sleep. But when I resume from sleep the network card generates a lot of system interrupts and pretty much uses a core doing nothing (cpu usage is at about 60-70% when the computer should be idle - machine is dual-core).

    Note that the network still works when the network card generates interrupts but the computer is somewhat slow and the fan(s?) is(/are) running at full speed so it's quite noisy.

     

     

  • I have the same computer and the same problem. After spending several evenings searching on the internet for the solution, and after several mail conversations with Mircosoft, I found the "solution". I went to the shop and bought a new networkcard for EUR 9.99. Next I disabled the onboard networkcard in the BIOS and installed the new networkcard. No problems anymore.

  • Hi Hans

    Thank you for sharing your "solution".

    I am still hoping that Dell will eventually release a fix because all my PCI/PCIe slots are already used but it is good to know that I am not the only one to have the problem and that disabling the onboard card is an option.

    By the way, is your microphone input working? Mine never did and it I have read reports of other people having a problem with the microphone input on the Inspiron 530. I wonder if there could be a relationship (i.e. some form of conflict between the integrated sound card and the integrated network card on a certain batch of motherboards)...

     

  • You might ask the operating system liaison DELL-Jesse L, but I thought if your PC was on the Tested for  Basic Windows 7 Functionality side, we would not be writing Windows 7 drivers for it. You would have to use the Windows 7 native drivers or the Vista drivers. On the positive side, DrunkMonkeyboyx got his Inspiron 530 to function with sleep/wake. But, he did a clean install of the 64 Windows 7 and you did a dirty install of 32 Windows 7. Maybe that is the solution.

    (Liaison for Desktops, Alienware, Monitors)
    Quick link for Manuals and Drivers

  • I did exactly the same thing, even a cheaper solution (9,95), but the problem is still there. Very slow network activity.

  • The problem has been resolved by disabling the intergraded Intel network adaptor in the bios of the Dell Inspiron 530 PC and then installing a 3rd party new network adaptor - I used a D-Link 10/100 Desktop PCI Adapter Model DFE-530TX+ and the Windows 7 plug and play driver.  Cost $10 from Tiger Direct.  No problems since then.  Dell, Intel, Microsoft, or a combination of these needs to write a new driver update for Windows 7 compatibility.  Microsoft Helpdesk agreed with me.  The equipment was previously working trouble free with Vista.

  • It appears that the latest driver from INTEL solved the problem...

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18590&lang=eng

      Multi language: PROWIN732.exe Download
    Ver:15.0 Date:1/14/2010 Size:14116 (KB)

     

  •  

    I had a similar problem,  (am using the built in windows 7 driver for the network card)...

    When returning from sleep, the LAN card link light would be off, and network component would say 'cable is unplugged'.

    Could not get it to relight easily without unplugging/replugging cable, disable/enable adapter.. etc

     

    I solved this by going into 'Device Manager', selecting the 82562V-2 Lan adapter,

    Advanced

    Set 'Log Link State Event' = DISABLED

    Set 'Wait for Link' = OFF

     

     

    Hope this helps someone....