How to enter BIOS setup on Inspiron 530? - General Hardware - Desktop - Dell Community

How to enter BIOS setup on Inspiron 530?


Desktop computer Forums (Audio, General Hardware, Video)

How to enter BIOS setup on Inspiron 530?

This question is not answered

Just got a used Inspiron 530.  Want to occasionally change the disk boot sequence via BIOS setup.  Problem is I do not see the boot screen that offers the option of selecting F2 to enter BIOS setup when the system starts.  Tried hitting F2 as system starts up with no result.  It just continues to Vista startup.  The only solution I have found so far is to reset the CMOS by using the jumper on the MB.  After doing that I see the basic system info displayed along with the F2 choice to enter BIOS setup when the system is restarted the first time but it doesn’t appear during any startups after that.  Also did not see any options in the BIOS setup that were related to system info display during system boot.

All Replies
  • I have a  Inspiron 530 with BIOS version 1.0.18.  On the main BIOS screen, one of the menu options is "Boot Device Configuration".  From that option, you can permanently change the boot order of the various devices (CD Drive, USB, hard drive) as well as the hard drive order if you have multiple drives.

    If you want to just temporarily change the boot sequence, also try pressing F12 instead of F2.  That allows you to temporarily change the order for the current reboot.

    Hope this helps.


  • Thanks for the suggestions.  Problem is I never see the boot (POST) screen.  I have only seen the boot screen once after resetting the CMOS using the jumper on the MB. That time F2 worked. I have the latest BIOS (1.0.18) from DELL and tapping F2 or F12 during start-up (before Vista initiation) does not bring up the BIOS setup screen.  If I tap too much the boot stalls and I have to restart the system.

  • What do you see on the screen when the PC first comes up?  With the latest BIOS, I see the circular Dell logo in the middle of the screen and the word Insprion at the middle bottom.  Do you ever see this?

    After hitting post, I had another thought ... you said if you tap the F2 or F12 during start-up does not bring up the BIOS setup screen and if you tap too much, the boot stalls.  Maybe you are actually getting into the BIOS but there some type of display problem and you aren't actually seeing the video output when you are in the BIOS setup.

    Does your 530 have a video card or you are using built-in graphics?  If you have an external card, you might try pulling out the card to see what happens.  Or do you another
    monitor you can try connecting to see what happens.


  • You solved it!!  Hooked up a different monitor and I see the Dell logo along with the F key selection options.  Apparently the LaCie monitor I have been using isn't really "on" until Vista boot starts on the 530.  Worked on the previous machine? 

    Thank you for your help.

  • Glad to hear that you found out the problem.   

    Not sure why the LaCie monitor doesn't work -- maybe there is some type of power setting in the monitor that can be changed to turn it on before Vista starts up. 


  • Tried everything I could think of with the LaCie setup.  Nothing worked so far.  I'll post the solution if I find one.

    Thanks again.

  • Oh my god I've been trying for a whole day (no joke) to get to the bios on my new inspiron 530s and didn't realise the tv wouldn't display the bios for whatever reason (maybe something to do with resolution).  Hooked up a monitor and bang.  I felt so stupid not trying a monitor the first - only did it to save time! I've now been learned.  

    I was about to have some kind of seizure as I didn't know what to do if i couldn't get to it - i had a catch 22 type situation as i got the error message 'ensure that the disk's controller is enabled in the computer's bios menu'  when trying to install the os (win 7), but couldn't get to the bios to do it!  

    Thankyou so much.