F12 Key Won’t Bring Up Boot Menu – Inspiron 530s - General Hardware - Desktop - Dell Community

F12 Key Won’t Bring Up Boot Menu – Inspiron 530s


Desktop computer Forums (Audio, General Hardware, Video)

F12 Key Won’t Bring Up Boot Menu – Inspiron 530s

This question is not answered

I am attempting to bring up the boot menu by pressing the F12 key on my Inspiron. I have made numerous attempts (at least 20 by now) using every combination of pressing the F12 key once the Dell logo appears. The upper right hand corner of the display says “Enter Setup – F2” and “Boot Menu – F12”.


I have tried every combination of pressing the F12 key imaginable once this display appears. I have tried pressing the key just once or twice slowly, or once or twice rapidly, many times rapidly, many times slowly, etc. but I simply can’t get the system to bring up the boot menu. It just proceeds to bypass the boot menu and boot up completely each time (and regardless of how often or how little I press the F12 key and regardless of the timing of pressing it).  


On the other hand, if I press the F2 key during the same time period, it goes right into “setup” mode.

Does anyone have any idea what might be going on here?


All Replies
  • Scott_SK,

    Turn off Start tapping F12 before the Dell screen appears. If still no go, change the boot order in the F2 Bios Boot Device Configuration screen.

  • Thanks for the input. I finally had to go to F2 and change the boot order so that it went to the CD-ROM first and the hard drive later.

    I’m not sure I understand why that should have been necessary however. One thing that seems *very* clear is that the timing of getting both to “Setup” via the F2 key and the “Boot Menu” via the F12 key appears to be extremely critical. It’s not the greatest thing to have to deal with if you are in the process of troubleshooting system problems.