Optiplex 320 memory problem - General Hardware - Desktop - Dell Community

Optiplex 320 memory problem


Desktop computer Forums (Audio, General Hardware, Video)

Optiplex 320 memory problem

This question has suggested answer(s)

Have 1g from factory, 1 stick. I added the correct 1G second stick of memory. The bios sees it and it is list in the setup but windows can't find it. The only other thing I have that might be causing trouble is a Matrox P690 video card with 256 of memeory on it.


Any thoughts. Dell tech support was stumped. Have not removed the video card yet to try. that is next.


Any ideas??



All Replies
  • Removing the video card did nothing. I tried the new stick alone it worked fine.

  • What silly switch etc. do i have to flip (that is of course not in the instructions) to get this  to work right??

  • Both 1G stick work fine independently, one or the other, in either slot.  If both are installed I still only get 1G.

  • Not sure if you have found a solution yet. I am experiencing the same problem...

    This Dell post (http://en.community.dell.com/forums/p/19243086/19374153.aspx#19374153) provided even more info about the Optiplex 320 memory issues. I think they are on the right track (optiplex can't accept 4gb or 2 Dimms)...I went down the wrong rabbit these are all the things I did to no avail...don't bother repeating.

    1) After installing 4gb of ram in both dimm slots, the graphics drivers were gone on the system...Crucial thought the drivers got clobbered,

      1a) So I chased down the graphics drivers. Installing was not possible as the graphics card was not recognized...Installing the drivers from Nvidia provied the error "NVidia setup program could not locate any drivers that are compatible with yourcurrent hardware."

      1b) I noticed that the Display Adapters in the Device Manager listing was missing. (bad sing)

       1c) BFG (Nvidia reseller) said it was the power supply, the extra memory was preventing enough juice to getting to my graphics card...$70, 2hours,  and an additional 150W later, I had a 450W prower supply installed. No dice....same errors.

        1d) Tried another graphics card...still not a working...but in worse ways, could not even get to the login screen

    2) Online I found postings from some people were having similar problems ("Display Adapters" missing from Device Manager) with different computer systems. They solved it via reinstalling the chipset. Found the chipset on Dell's site...installed...no dice...same problem persists.

    3) Switched the old memory back in...viola! it works again.


    Still looking for exactly the problem...can the Optiplex not handle 2 Dimms? 2 Dimms that add up to 4GB, or 4GB?


    My Relevant Specs:

    Optiplex 320
    XP PRO SP3
    GeForce 9400 GT 512 MB
    1 GB RAM 1DIMM (trying to upgrade to 4GB RAM 2DIMMS)

  • Update:
    I worked with Dell and Crucial most of today as well to get to the bottom of this.

    It ends up that Dell has it in their specs for the Optiplex 320 that the max ram can be only 2GB. Crucial has it in their specs as 4GB. So that was apparently the prob. Crucial is pulling up their dell 320 in their lab to retest.

    Incase you are thinking it, if you upgrade the bios to 1.1.11 for the Optiplex 320 still only 2GB works.


  • I think the problem is memory speed its suppose to support up to 4GB DDR2 of 533mhz and you probably installed 4GB DDR2 of 667mhz.

    Try and let me know if it worked!

  • I'm experiencing the same problem as the original poster.  Upgrading from 1G (1 Stick) to 2G, and the OS won't see the 2nd stick.  Both sticks are 533.  I'm going to make sure I have the most current bios, but if anyone finds a solution, please post it!

    Thanks in advance.

  • I just purchased 1GB ram and had the same problem.

    How come the bios showed DIMM 1 and DIMM 3 on memory slot?

    Is there any DEll teckie here to give us some words?  To me, this is a design issue to DEll!



  • Any updates on this?  I too went to Crucial's site and bought 2 2GB PC2 5300 sticks and I cannot get 4GB RAM installed with a video card installed.  BIOS is updated all drivers are updated, and Dell just sent out a tech to replace the motherboard.  The problem is still here.

    I have a choice of running with 4 GB RAM (3.3x seen by XP of course) and onboard video, -OR- running with 2 GB RAM and a video card (nvidia 8400GS).

    I've worked hours on the phone with 2 techs and ended up thinking bad motherboard.  When the motherboard was replace today and the problems were still here I worked with a third phone tech who seemed a bit more junior and first was told I needed a new motherboard, and then once I got them to understand I'd just had a new motherboard, was told that oh that's too much memory.

    Has anyone gotten 2 x 2GB (=4GB) to work with a video card in a 320?

  • I also purchased the 4GB kit from Crucial , updated bios etc , screen goes blank after exiting setup screen . I am usiing a ATI Radion HD 3400 graphics card.

    Machine works fine when  I refiited the  original 2 * 1 GB chips.


  • HTML clipboard

    I have Also these kind of problems with my Dell pc

    Watch Anime Online

  • Tried chips on another 320 where we use on board graphics card.

    Machine booted into Windows without any problems so appeaps to be a problem when using a PCI express graphics card.

    I  informed Crucial of the problem and returned memory.

    Hopefully Dell / Micron can resolve the problem.



  • All,

    The maximum <ADMIN NOTE: Broken link has been removed from this post by Dell> is 2GB. Here are the Dell non-ECC DDR2 memory offerings for this PC -
    CM633 1GB 800MHz
    C6844 1GB 533MHz
    HT212 512MB 667MHz
    F6761 512MB 533MHz
    F6659 256MB 667MHz
    D6492 256MB 533MHZ

  • This does not address the problem as 4GB works with the on board graphics card but only 2GB with PCI express graphics card..

    Presumably the solution is an update to the bios ???


  • We are not going to write a bios to support something we never validated.