No Boot Device Detected

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

No Boot Device Detected

This question has suggested answer(s)

I have a Dimension E521 that will not start properly. It comes to a black sceen that says:

"NO BOOT DEVICE DETECTED, INSERT SYSTEM DISK AND PRESS F1 TO CONTINUE OR PRESS F2 TO SETUP MENU"

I have tried  Cntrl, Alt, Delete and it goes to the same screen. I have tried F1. I don't know what it could be.

Can someone help me??

All Replies
  • Could be damaged system files or a failed hard drive. You should post your operating system. Boot to your operating system cd/dvd and try a repair. XP has a Recovery Console you can use to repair boot files, run Checkdisk and hard drive diagnostics.

    4

  • Chrystalyne

    Check to see if the hard drive is recognized in the system setup.

    See HERE for the System Setup details.

    Bev.

     

    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell

  • shesagordie

    Chrystalyne

    Check to see if the hard drive is recognized in the system setup.

    See HERE for the System Setup details.

    Bev.

    I do believe that the hard drive should be listed as Drive 0

    but it doesn't list the drive id.

  • Chrystalyne

    Yes, the primary C:/ hard drive is 'Drive 0'.

    The setup should list the hard drive's, Model ID and Size, if this is not listed, then you are looking at a failed SATA hard drive.

    If you still have a warranty, you should contact Dell's Technical Support for a replacement.

    Bev.

     

    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell

  • ....or.......

     

    just remove the USB drive that it's picking up.  or remove it from boot devices menu in BIOS.   usually USB drive is higher on BIOS boot menu than internal HDD.   this one gave me fits until I figured out trial and error. 

    --------------------------------------------------------------------------------------------------------------

    C521 - Athlon64x2 5600+ Windsor, 2GB DDR2-800, Galaxy Nvidia 9600GT LP Video Card (my gamer)

    E521 - Athlon64x2 4400, 4GB DDR2-800, Nvidia 8500gt (wife's C4 machine and my backup gamer)

    prior Dell's:  Optiplex GX110 (owned 3 of these), Dimension C521, D400 laptop, E1501 laptop, and many others.

  • what OS you use? XP or Windows Vista?

  • if you have windows Vista  after computer starts up press F8 before windows Logo and  maybe you can reset to Manufactery Condition if it still can read your Harddrive

    Hundeson