Upgrade Vostro 400 Processor & Memory Upgrade Info

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Upgrade Vostro 400 Processor & Memory Upgrade Info

This question has suggested answer(s)

I was unable to find any authoritative information from Dell (or others without really digging) about what replacement processor & memory I could put in my Dell Vostro 400 so after posting in various forums I wanted to share the information I learned so everyone else could benefit.  I've indicated below the changes I made & what worked & didn't work.

Processor Info
It appears the Inspiron 530, Vostro 200, Vostro 400 all used the Foxconn G33M02 with dual core processors, and the Foxconn G33M03 with quad cores. (Similarly, the dual cores came with 300W power supplies, and quad cores came with 350W power supplies.) The G33M02 had simpler (cheaper) CPU voltage regulation circuits, which were unable to support a quad core.  You can examine your motherboard to determine if it is the 02 or 03 model.

If you have the 02 model your option is to swap out to the E6850 (3Gz).  Pay attention to CPU generations. E8400 and E8500 are Wolfdale (45nm), not Conroe (65nm), so they are less likely to be supported by the stock motherboard. The safer choice, more likely to work on the stock motherboard, is the E6850, which is also a Conroe (similar to the E6550, but @ 3.0 GHz), and was one of the original options for the Vostro 400.  I went with an E6850 & it works fine.

Note I tried a quad (Q9550) in my Vostro 400 with the Foxconn G33M02 motherboard & it didn't work.  Since most processors have restock penalty, do yourself a favor & don't try it as it won't work.  If you are fortunate to have the Foxconn G33M03 motherboard then you might be in luck.

Memory
Again, very little info online confirming if you can use >4GB, but a lot of rumors.  I had read the 1.0.15 bios upgrade supported >4GB, so I tried it.  I bought Kingston memory in 2GB sticks with same specs as the existing 1GB sticks, and confirmed in the bios that computer saw 6GB (remember if you're not using 64 bit OS, OS won't see it).  So you can take a Vostro 400 to 8GB, which is good.

Motherboard
For those that want a more cutting edge motherboard, or want to use a quad procssor, and you have a Foxconn G33M02 motherboard, your only option is to upgrade the motherboard.  MelvH from Yahoo Ask was very helpful and knowledgable on options.  Per Melv:

 the Gigabyte GA-EG31M-S2 should swap in as a directly replacement for a G33M02. (They're both standard mATX boards.) Keep in mind, 4GB is a hard limit, on the G31 chipset. If you need more RAM than that, or want other higher-end features like RAID, firewire, more advanced overclocking options, etc., then there are other good mATX motherboards you could use, for more like $120.

The reason I like the GA-EG31M-S2 is, the G31 performs the same as a P35, which performs the same as the P45. DDR2 RAM at CAS4 at 800, performs the same (within a couple percentage points) as CAS5 RAM at 1066, which performs the same as CAS7 DDR3. (Only DDR3 @ 1600 is actually faster, and much more expensive.)

People only look at the numbers, and think higher numbers are always better, but in this instance, you have $50 motherboards that are 98% as fast as much more expensive configurations. Further, a motherboard that's simpler in features, is often the most reliable, and simplest to configure in terms of drivers.

If you really want more RAM, or bells and whistles, this looks pretty good, in terms of price and features, Foxconn G45M-S (G45 chipset, firewire, RAID controller, onboard HDMI, solid capacitors),

http://www.newegg.com/Product/Product.as...

You should probably plan on putting in a bigger power supply. In any case, if you plan to add a video card too, then you will definitely need a bigger power supply. On the other hand, if you want to try running the onboard video (or a really low-end video card), the stock 300W power supply may be okay with the quad core. (All you can do, is run it, and see if it stays stable under load, see if it locks up, or reboots, or etc.)

Both the Gigabyte GA-EG31M-S2 and Foxconn G45M-S motherboards should be able to support your current DDR2 RAM modules, with the difference being the Gigabyte board would be limited to 4 GB total, because the limitation of the G31 chipset.

The Q9550 CPU is awesome, but the Vostro 400 with a E6550 was already a pretty good computer. There's a tipping point. If you need to buy a motherboard and power supply, to make the quad core work, at some point you might as well buy a case, and just build a second computer. The original computer is a little too good to just gut, unless you have a plan to reuse or resell the old parts. (The Dell case is nothing special.)

Gigabyte GA-EG31M-S2 CPU support,

http://tw.giga-byte.com/Support/Motherboard/CPUSupport_Model.aspx?ProductID=2806

___________

I trust this info is helpful to others.  I went with processor & memory upgrades, but decided to not change out motherboard.  As Melv said, there is a tipping point, beyond which you're better off with new computer.  I also upgraded to Vista Ultimate x64 from XP Pro 32 bit.  Had to do a dual-boot, but the results were worth it and the Vostro flies.  Make sure if you do this you install the version with SP2 (beta) included, or you will have a horrible time.  I tried with SP1 only & it had to completely resinstall as nothing worked.  If you are a technet subscriber, there is a 12/08 download which includes SP2 beta.  It installed & worked flawlessly.  Fred

All Replies
  • fgaston

    Fred.

    Thank you for posting the very informative guide on upgrading the Vostro 400.

    There one small item I would like to add, if a non-Dell Micro ATX motherboard is used, then a new retail copy of windows would be needed, as Dell's OEM copies are tied to their BIOS. 

    Bev.

     

    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell

  • Howdy,

    Thanks alot for a great post!

    I was wondering if the Dell G33M02 can handle an AMD cpu instead of Intel?

    I was thinking of upgrading a friend's PC with the AMD Athlon 550.

    Any help would be appreciated!

    Thanks,

    Rob.

     

     

  • No, to the AMD CPU - the socket type and core logic for the chips are totally different.

  • Just wondering if anyone could supply further information on swapping out the mobo to the mentioned gigabyte model. I am interested buy have read conflicting opinions as to whether this will work.

     How intensive is the switch? It looks as if all  rear panel connections such as the usb, ethernet, etc. are attached to the case itself. I have not really got in there and inspected yet as I am waiting on a definite answer.

     Also, concerning CPU switching, the WolfDale's are a no go then? I know that the process is smaller on WolfDale than on the Conroe but never thought about the incompatibility.

    Thanks

  • Thank you to the original poster. I was just about to buy a Q9650 to replace the E4500 (2.2GHz)  in my Vostro 400. Figured it would work fine since it has the same socket (LGA775). I am increasing the RAM from 2GB to 4GB but not sure an upgrade to E6550 (3GHz) would be that beneficial or cost-effective. Will check my motherboard designation.

  • About a month ago I upgraded a Vostro 400 from the stock Core 2 Duo E4500 (2.2GHz, 65W TDP, 2M L2, Conroe 65nm) to a Core 2 Duo E8500 (3.16GHz, 65W TDP, 6M L2, Wolfdale 45nm) and it worked. However, I did run into some issues that at least partly seem to be related to the BIOS not supporting the E0 stepping of the E8500. I'm posting this info in case it is helpful to anyone else...

    Note that the system has the G33M03 motherboard, BIOS 1.0.15 (the latest for the Vostro 400 as of this writing), stock 350W power supply, and stock heatsink/fan assembly. When I swapped processors I thoroughly cleaned the heatsink of old thermal paste and used Arctic Silver thermal paste when re-installing onto the new processor.

    With the side cover still removed, I powered up the system. The system POSTed fine, the BIOS detected the new processor correctly, and the system booted into Windows and ran just fine, in fact it seemed noticeably more responsive with the faster E8500 installed. However, I noticed a few things that were not normal compared to how they were previously:

    1) The chassis fan was no longer running. With the E4500 installed, the fan would spin up to a very fast speed when the system was first powered on and would then settle down into a slower speed. With the E8500 installed, the fan would spin up normally when the system was first powered on but would then slow and come to a stop. The fan would not start back up regardless of the CPU load or temperature.

    2) The CPU fan would no longer increase in speed when the CPU was under full load (for example using the Prime95 Torture Test). With the E4500, the fan speed would increase dramatically when the CPU was under such a load, and then drop back down to a normal speed when the CPU load returned to normal. With the E8500 installed the CPU fan no longer changed speed regardless of load.

    3) A couple system-monitoring programs (SiSoft SANDRA, HWMonitor) reported a "motherboard temperature" of 85°C with the E8500 installed, but normal (~35°C) temperature with the E4500 installed. The reported high temperature was basically constant regardless of system load, whereas with the E4500 installed the board temperature increased when the system was under heavy load and decreased when the load was removed.

    After doing more research I came across some reference to the Vostro 400 BIOS only supporting the C0 stepping of the E8500. It turned out that the E8500 I'd bought was the newer E0 stepping (S-spec SLB9K)! So I decided to try and swap to a C0 stepping to see if that resolved things.

    I eventually found a C0 stepping (S-spec SLAPK) at a reasonable price and installed it. The chassis fan then ran normally, but only at the slower speed; it wouldn't increase in speed when the system was under heavy load. The CPU fan also would still not increase in speed under load. Also the supposed 85°C board temperature is still being reported by system monitoring programs.

    That's basically the current situation for the system, except that I discovered just yesterday that the current beta version of SpeedFan (4.46 beta 2) allows me to control the chassis and CPU fan speeds in the Vostro, including automatic fan control based on CPU temperature. The system is noticeably faster and more responsive in general, and works fine in benchmarking and stability testing.

    It's unfortunate that the BIOS doesn't seem to fully support even the C0 stepping (in terms of the board itself no longer automatically regulating fan speeds), and I find it hard to believe that anything on the board is at a constant 85°C (a 50°C increase over what it was with the E4500 installed).

    Hope this info helps, and if anyone has any input on the situation feel free to share. Dell, feel free to release an updated BIOS for the Vostro 400 that fully supports the E8500. :-)

  • We've had this PC since 2007. Around February 2013, I upgraded the system with more RAM, a 2.5" hotswap tray in the 3.5" bay, a 2.5" SSD, a regular 2.5" HDD, more USB ports, and a used Intel E8600 SLB9L into my Dell Vostro 400+. I have my reasons which include dual boot Windows XP and Windows 7 on separate hard drives (windows-7 XP mode just didn't cut it). The mobo is a G33M02 series.

    The system worked fine for about a year - although I did notice the case fan would only spin up at computer startup/bios check. I ran some utilities to monitor cpu core heat - which would hit 43C occasionally - the case fan would never really work right so I installed a separate case fan powered from the power supply and the original OEM plugged into the mobo - max core temp came down 1C and would run around 39C to 40C. A year later, I had intermittent issues - and another 3-4months later, major problems developed that was symptomatic of CPU failure. Various diagnostics fail at different times giving a very inconsistent message(s).

    So, after reading the above article, I replaced the E8600 SLB9L with an E8500 SLAPK CPU. The OEM case fan spins more regularly again and all the symptoms went away. We'll see if this was a good long term solution but I suspect it will be.

    I give thanks to MrWhsprs for his time in research about the stepping. I hugely suspect this was the problem I had in this computer. Although we'll see what happens after another year.

    I share this in case someone else needs a similar workhorse PC. This is really a secondary PC for me but it still needs to be fully functional and versatile. The "E8500 SLAPK" is probably the way to go.

    I share with you it's current config:

    Vostro 400+ w/ Intel e8500 SLAPK CPU,
    RAM: Crucial CT765233 - DDR2 PC2-6400
    HDD: 2.5" Crucial SSD 128gb (Win-7), 2.5" Western Digital HDD 250gb (Win-XP), 3.5" WD HDD 80gb (OEM)
    PCI USB 2.0 Cart-port (to give 4 more internal USB Ports in the back)
    The rest of the system is still OEM - CDR-Burner and a regular CD (two optical drives), 300w Power supply, et cetera.

    -Calvin

     

    MrWhsprs

    After doing more research I came across some reference to the Vostro 400 BIOS only supporting the C0 stepping of the E8500. It turned out that the E8500 I'd bought was the newer E0 stepping (S-spec SLB9K)! So I decided to try and swap to a C0 stepping to see if that resolved things.