Desktop computer Forums (Audio, General Hardware, Video)

Dimension E310 won't turn on - solid amber power light and 1 2 3 4 diagnostic lights on

  • Hello,

    I have a 2 year old Dimension E310 that won't power on.  The power light is solid amber, and all four diagnostic lights are on when I try to turn on the machine.  Unfortunately the warranty has expired last year, so I tried to troubleshoot the issue on my own, though without any success. 

    I have tried swapping in a new power supply, a new CMOS battery, reseated the processor, reseated RAM dimms, and reconnected all connections to the motherboard.  Still no luck.  My final guess is that it's either the processor or the motherboard.  Any help with this issue would be greatly appreciated.

  • Very good trouble shooting. From your statement that all the lights are on according to the troubleshooting section of your manual here

    the processore is more than likely the cause.

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003