Dell Optiplex 320, 745 and 755 usb stops working. - General Hardware - Desktop - Dell Community

Dell Optiplex 320, 745 and 755 usb stops working.


Desktop computer Forums (Audio, General Hardware, Video)

Dell Optiplex 320, 745 and 755 usb stops working.

  • Trying to get to the bottom of this. I deal with alot of the Dell Optiplex 320, 745 and 755's on a daily basis and have noticed on alot of these machines the USB just stops working. You get no response from the keyboard and mouse. Also whiteboards stop responding.


    Now most of the time you can get them to work. I found just unplugging the device and plugging it back in DIDNT work. I have to switch the ports. eg if mouse is in USB port 1 and keyboard is in USB port 2 if I plug the mouse into port 2 and the keyboard into port 1 it works. For a while but the problem always comes back.


    With the whiteboards I have to power off the board, switch the port and power the board back on. Have also noticed this starting to happen the the Dell D531 and D630 laptops.


    This seems to be completely random so I am trying here to see if anyone has seen the same problems. I am quite good with computers and I am DCSE but still can't figure out why this would be happening.


    Thanks in advance..:smileytongue:

  • bump!

  • Hi Michael,

    I am experiencing a very similar issue with an Optiplex 755 (Windows XP, SP3)  I am using a barcode scanner (IT 3800g), in conjunction with a USB Mouse and USB Keyboard.  Within Device Manager the barcode scanner is detected as a HID Keyboard Device, so there are two listed one for the actual keyboard and one for the handheld scanner.  As you operate the computer, all of a sudden the USB mouse ceases to illuminate the red optical light, and does not respond in Windows.   The keyboard randomly experiences a similar loss of functionality  If I unplug the mouse or keyboard (which is not responding) and reconnect it then it functions fine.  I have swapped workstations, replaced all peripherals even the scanner and I have determined that this must be a Windows XP issue.  I did a fresh installation of  Windows XP using the Dell OEM installation media, and I encounter the same issues.  I have used an external powered USB hub all to no avail.  The one I have noticed is that when we image our workstations with using our VLK XP installation media the problem is seen.  If we take a brand new Optiplex 755 out of the box from Dell there are no issues whatsoever.

    Has anyone else experienced this issue?  I have been researching possibly updating the following drivers:

    USB Composite Device 5.1.2600.0
    Dell USB HID Collection

    If any one else could shed some light on this chronic issue it would be greatly appreciated.

  • I have a similar problem where the mouse just stops working. This has happened on a Optiplex 620 and 745 so far. My users don't have anything other than the KB and mouse. To temporarily resolve the issue i just unplug and replug, no swapping of ports but...on occasion it will freeze again and then I must swap ports. I've tried doing BIOS updates, new drivers, patches you name it and I've been trying it. I am searching all over for a solution but have yet to find one. If you get lucky and find one please do share! :)

  • Exactly the same problem on Optiplexs 755

  • Same here.

  • Same problem here on a Optiplex 320 and 330. If I boot from a Linux live CD, it works fine. USB works fine until windows boots.

  • I replaced motherboad 2 weeks ago. No problems so far. Still monitoring ...

  • Dell Optiplex755 tower WinXP sp3 -  an external pwrd usb hub fixed my NCR iTran 8000 scanner (huge 8 foot bank check scanner) from falling asleep within 7 minutes of inactivity.  The fix before the hub was to cycle the power on the scanner and the operators hated this.

  • I have the same issue with Optiplex 330 since last few days , started with printer and was keep switching the port but last friday all of a sudden all the ports are dead....Can anyone suggest as try going to CMOS but not able to do so as its not taking F12 .or. F2 as input....How can i reset CMOS on 330. I have not tried but read on other forum that this might help. My OS is Win XP SP2 booting fine ...tried to go using remote admin through other pc too but fail..Can any one Help

  • If you can unplug power from the computer, and then open the computer, you will see a button battery CR2032, you take it out and after one minute plug it in again, your CMOS should reset.


    I have Optiplex 755, and I am having the same problem, after I did the above step, I can use keybord for F2, F12..., But I couldn't get Contol_ALT_Delete work to begin?????

    If someone knows what the problem is, please advice.



  • Still the same issue , Can i use ps/2 port available on it

  • Uncheck the power saving on ALL the USB Root Hubs.  Do not allow USB to power down to save power and ALLOW USB to wake the computer in the bios.

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • SpeedStep

    Uncheck the power saving on ALL the USB Root Hubs.  Do not allow USB to power down to save power and ALLOW USB to wake the computer in the bios.

    Has anyone had success with SpeedStep's proposed solution?

  • The Optiplex 755 I'm working on has no power saving features in the BIOS Setup for USB devices. And about 3 sec. after the XP startup Logo appears the numlock and caps lock lights go out and the keyboard and mouse appear to be dead. I've tried other KB & Mouse but the results are the same.

    My problem started after I started restoring drivers from the drivers CD after restoring the system with XP rescue disk that came with the system. Both mouse and KB worked until I rebooted (required!) after installing the mb chipset drivers. KB and Mouse work when booting from the Diagnostic/Driver CD and other boot disks, they just seem to die seconds after windows starts booting. I've tried "safe mode", "last known good config.", and "VGA mode" with the same results. Just making an educated guess here but I suspect a bad driver for the MB Chipset here. If I knew what the exact driver name was I think I can delete it booting from a special boot CD.