HELP: XPS 420 bios 04 update problem - keyboard and mouse not working

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

HELP: XPS 420 bios 04 update problem - keyboard and mouse not working

  • Hi all,

    in trouble, brand new XPS 420 QX9650. just flashed the urgent bios 04 upgrade. System start up incl keyboard, but duing initialing get a process both mouse (logitech wireless laser) and keyboard (logitech G15) go dead and cant useit. Can only hard reboot after which same happens agin. Safe mode works without any problem

     

    your help/views very much appreciated! 

     

    JB

    Message Edited by jb77 on 04-16-2008 06:34 AM
  • jb77,

    Are those devices using the PC rear USB ports?

    (Liaison for Desktops, Alienware, Monitors)
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?
    Drivers
    Order Status

  • yes, just been on the phone with dell support for an hour, problem persists and they suggested a bios 04 problem, now flashed back to 03, pc working again. Will have to wait for new version I guess

     

    ps now you mention it, at start up the pc showed an error stating that devices would work faster if connected to 2.0 USB ports, funny thing is that my pc only has 2.0 USB's

  • Just wondering: Dell states that BIOS 04 is important for using new processors. Is performance with QX9650 fine without the bios update? Do you know anything more specific about what bios 04 is suppose to do? Thanks.
  • According to Chris M it is to allow you to run the yorkfields and wolfdales on the 420, Plus some minor performance fixes...

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003

  • funny thing is that I have a qx9650 that worked fine with 03, system problems started with 04!

  • FWIW:

    There have been reports of USB Ports not functioning after a Microsoft update from Tuesday:

     

    Oh this is not good...

    A recent Vista update is causing headaches for users with USB devices.

    Microsoft last week re-released a
    software update intended to provide performance and reliability enhancements for Windows Vista -based and Windows Vista Service Pack 1-based systems. It was one of eight security bulletins and updates the company made available on April 8.

    Users who installed the update, however, soon found their USB devices unresponsive, particularly
    mice and flash drives. Removing and re-installing the programs reportedly did not immediately solve the problem.

    Microsoft confirmed the bug, but declined to provide further details.

    Full Article Over On PCmag.com

     

    Borrowed from windows central

     

    Regards

     

  • Chris

     

    can you let me know if this problem is now solved, can I install 04 bios?

    thx for letting me know

     

    JB