Drive Letter Access Component has a problem (terminated) after Hibernate Mode

Desktop

Desktop
Desktop computer Hardware and Software discussion

Drive Letter Access Component has a problem (terminated) after Hibernate Mode

  • I have a Dell Precison 490. Whenever I use the hibernation mode to shut down, resume of the PC causes a general protection fault "Drive Letter Access Component has a problem and will be terminated (translation from the German expression). I have all DELL updates. Has anybody an idea? Thanks so much.

     



    Message Edited by HaraldM1 on 12-22-2007 11:08 PM
  • HaraldM1
     
    Item 1
    In the future please do not post service tag information.
     
    Item 2
    The problem you experience is a direct result of the Operating System polling feature.
    When the computer responds to wake from hibernation, the OS will attempt to re-establish all connections. There are a number of reasons for the drive letter confusion.
     
    If you have a USB or SATAe drive connected, with or without an auxiliary operating system, the OS will attempt to read that drive and invoke the first executable boot sector.
     
    On wake; the first drive to boot "should" be drive letter C. If that is not the case, the next logical drive will attempt to boot. In some cases a bootable CD will attempt to assume control as the primary drive. It all depends on what the boot order is at POST. POST=power on self test. This occurs during the initial computer start-up when the system BIOS is read.
     
    In order for a computer to "resume" it needs to go through what is called a soft boot initialization process. The computer hardware is scanned (polled), then the devices (hardware list) are started.
     
    Conflicts may arise if memory cards, USB drives, or auxiliary drives are present with or without a bootable sector. More often if one or more contains a bootable sector.
     
    Make sure the first bootable device in your hardware list (System BIOS) is the hard drive.
     
    MD
  • Thanks for your assistance, I appreciate your immediate response. Indeed the boot sequence had to be changed and now # 1 is the main SATA hard drive I received with the DELL PC and Win XP PROF SP2 -  OS . However, the error is still present. It seems to me that the system works well despite the problem. However I have a second DELL pc (2007 model)  that works without this problem.