Inspiron 530 bios problems

Desktop

Desktop
Desktop computer Hardware and Software discussion

Inspiron 530 bios problems

  • Hey guys we have 3 inspiron 530 machines running at our store,
     
    they were purchased a different times,
     
    machine 1 had bios # 101
    and machine 2, and 3 came with bios # 103
     
    we neded to do a fresh install on one of the 103 machines,
    but the bios wont boot from the cd rom, it will boot from usb, but not the cd rom.
     
    I didnt understand why, so I checked the other 2 machines to see if they would boot
    from the cd rom, only one does, tried the cd rom that would boot, on the other 2, with no luck.
     
    I upadated the bios on all 3 machine to #105, but still only 1 machine boots from cd rom.
     
    I also noticed that the original 101 bios machine shows a energy star logo upon boot,
    the other 2 dont, funny thing is even with the bios update to 105 that machine still shows the
    energy star logo on boot, it wont go away, and theres no place to disable it.
     
    is there a spot on the bios that is not getting updated, is there a way to force a full bios update, I noticed the first part of the bios update dosnt get updated,
     
    also where the heck is the actual bios chip, I dont see anything.
     
    hope someone can help, I cant reload vista because it wont boot from the rom,
    by the way we tried 3 different roms, none boot.
     
    Thanks
  • Have you checked the boot order in the BIOS? Should be CD, and then Hard Disk. I'm having trouble on a 531 where hard disk boot priority is ignored, but CD booting does work.
  • These might be stupid questions:

    1. If you have multiple optical drives, are you trying to boot from the master or first drive?
    2. Did you select the optical drive in the F12 menu?
    3. Are you trying to boot a CD in a DVD drive? Some people have had trouble with this. I've never encountered this myself.


    When you update the BIOS, does the machine show the new BIOS version?

    Peter
  • Also did you see the firmware update for the TST DVD-RW driver? BTW Do check with device manager, that any downloads won't be downgrades, DELL don't seem to have a way to check on versions of things, and some of their notes are careless to about it.
  • Hey guys
     
    To answer some questions,
     
    all screens show bios 105 at start, after flashing.
    no matter what I use to boot first, HD, CD, doesnt matter, the unit will not boot from CD
    to install windows.
     
    I also noticed the service tag is gone, its blank, even if I try and insert it it wont stay after boot.
     
    also this is wierd, the system tries to boot from the intel boot agent first, then it hunts for the nic card boot, if I hit escape, it skips the scan and then will boot from Hardrive. but not the CD ROM.
     
    yes this is Vista dvd, no nomatter what CD Rom, or bootable cd or dvd we try it just doesnt seem
    to boot from sata,
     
    no nomatter what we set in bios, it still tries to use the intel boot agent, even if we only enable HD, and disable all other drives in bios, yes we have tried everything.
     
    its like something messed up in the bios, and the settings arent being read or writen,
     
    we can swap the hardrive from a good unit, and after the intel boot agent scans the nic at startup, it will then proceed to boot from the HD, and after loading the operating system will show the cd rom, and everything works normal, we can run the CD rom, access the hardrive, but at startup, it goes back to intel boot agent, and no CD boot.
     
    like I said even after bios update 105, one unit still shows energy logo, yet the others dont.
     
    is there a way to buy a bios, im not sure if the building electrical had a surge or got hit.
     
    thanks for the help
  • I have the same problem! even the guys at Dell dont know What is going on or they would have responded. The only way to boot to the CD-ROM is to take the hard drive out and wipe it on another machine. Once there is no OS, it will boot to the cd. Another check is that if I disconect the HDD, It will always boot to the CD. I have disabled all boot devices except for the CDROM and even turned off the network controller and its boot option, and it will still boot to everything but the CD. I hope some one comes up with a solution soon. Even the new BIOS update was useless.
  • Rc Helis,

     

    A couple of suggestions...... first, on your problem machine try clearing the CMOS.  This will at least rule out the possibility of a conflict between the BIOS and the hardware information stored in the CMOS.  To clear the CMOS, just click here for directions from your model's on-line Service Manual. 

     

    Secondly, regarding the Intel Boot Agent, make sure the boot order doesn't list Legacy LAN or LAN as a boot device.  Also in the Integrated Peripheral sub-menu, make sure the option for OnBoard LAN Boot ROM is disabled.