Forums

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Primary Drive 0 not found

  • I have a Dell Optiplex GX270 that I took home from work.  Thing is, the company kept the harddrive because there was sensitive info on it.  The computer was working fine, as far as I could tell, before the HD was taken out.  I have a couple of harddrives at home each 10GB.  Every time I try connecting a harddrive and restarting the machine I get the error "Primary Drive 0 not found.  Hit F1 to reboot, F2 to enter setup".  When I hit F2 to enter the BIOS setup, under Primary Master Drive it says "Unknown Device" and it is set to auto detect.
     
    I tried a different IDE cable and no dice. I checked the pins on the motherboard and on the HD and they are all fine. I disconnected the CD ROM drive and plugged the Harddrive in its place and I got the same error. I tried it with a different harddrive, but I got the same error again. I plugged the CD ROM back in and it found the CD ROM. This leads you to believe its the harddrive, but I tried 3 different harddrives and I know 1 works on my old machine just fine, but when I plug it into the new machine it fails to find it. I tried playing with the jumpers setting it to CS, Master, Slave, but all that really does is give me a different error... a blue screen saying somthing along the lines of a problem was detected, make sure you do not have a virus on your hard drive, run chkdsk, etc... (even on the HD that runs fine on my old Dell computer... so i don't believe it is a HD issue.)
     
    I could try replacing the CR2032 battery, but I really don't believe that is the issue.  Does anyone have any advice?
     
    I read some other posts and it was also suggested to clear the NVRAM.  But doesn't clearing the NVRAM defaulted all your BIOS options back to their factory settings?  If so the Harddrive I'm plugging in now is not the original factory HD.  Will that be a problem?
     
    Any advice would be greatly appreciated!
     
    Thanks
     
  • Are you trying to BOOT from this drive? Chances are, that won't work. When an OS is installed, it makes LOTS of discoveries about the hardware, and configures appropriately. You can't take a drive from one system and boot on another, unless the two systems are identical.

    You should use CS jumpering, and plug the drive into the END of the cable (if it has two IDE connectors). Make sure the power plug is in snug, then turn on your computer and press F2. If you can see the HD, you are in business. Put in an OS install CD and boot from that CD. You should be able to erase any partitions on your drive, then re-format and install an OS for your system.

    Don't bother with the battery, unless you get config errors after turning your system off (the battery just keeps the memory alive when you kill the power - you can run a system without it, but you'd have to re-set the clock and config every time you turn the system on).
  • I'm not sure if I can see my drive.  When I hit F2 and enter the BIOS it says Unknown Device under Primary Master Drive.  I get the same Unknown Device status when I unplug the IDE connectors and not plug them into anything.  I do have an old OS on these drives I'm trying to use (Win 2000 I believe).  I've tried this once before.  I removed a HD from an Optiplex 110 to a Dell Dimension and when I rebooted the HD did detect new hardware and settings so it did all the necessary updating it needed to do and it worked fine.  Now I'm trying to take that same HD and put it into this Optiplex GX270 and it can not see the drive.  But it sees it fine on my old computer.  I also tried adding these 2 other drives I spoke of above, but both times I get the same error "Primary Drive 0 not found".
     
    I could try booting from My XP installation CD and see if it sees the HD to install XP onto it, but I doubt it will.  Any other suggestions?
  • OK, looks like the issue is now resolved.  What I need to battle with now is getting all the drivers I need.  Here's what happened.  I reinstalled windows XP from my CD.  When I booted from my CD, the XP installation process saw my harddrive (even though my BIOS did not).  I repartitioned it as I wanted and installed XP onto it.  During the installation, XP required that my machine reboot.  Once it rebooted I received the same error message "Primary Drive 0 not found".  I then turned off the computer and changed the jumper setting for Primary Master to Cable Select.  I then restarted my machine and the BIOS was able to read my hard drive and boot into XP.  It now sees both drives that I was having a problem with before (My Cable Select and Slave drive).
     
    Originally I had moved my HD from a pentium III Dell machine to another Pentium III Dell machine.  Even though they were different models (and only 1 year appart I believe), the BIOS was able to pick up the HD and boot into XP.  Upon booting it realized it was in a different system and began loading all sorts of drivers and making changes for the new hardware environment.
     
    I began encountering these Primary Drive 0 not found errors when I was taking this same HD from the Pentium III machine and puting it into a Pentium 4 machine.  Maybe the Hardware environment between the old computer and new computer was so different that I couldn't just plug the HD in and use it (as suggested by Duhhh)?
     
    My other question is what is the difference between Cable Select and Master jumper settings?  Why did the computer have a hard time continuing the installation of XP when the jumper setting was set to Master, but it continued fine when I changed it to Cable Select?
  • When you use MASTER/SLAVE jumpers, you are letting the drives select which one will be the master (one and only one can be set to master). When you use cable select, you are letting the position on the cable determine which drive will be master (the connector on the end of the cable is master, and should always be used in a single-drive setup). If you have no master, the system won't be able to find your drive. That may have been your problem.

    You have witnessed the problem of moving a boot drive to another system. Sometimes, the OS can reconfigure itself. It's usually not worth trying. You can move a DATA drive back & forth, but not a boot drive.

    Dell's driver download system is great for refreshing drivers. Get a big USB drive and go to a working system with a fast internet connection. You can download the latest driver for ALL devices on your system, and then take that to your system and install them. The only complaint I have with the Dell download system is the file naming convention (they still use 8.3 names). I always rename the files to tell me the system they are for, the device, and the revision. I also leave the Rxxx so if I ever go back to the support site, I can tell what file I already have (my files end up looking something like XPS610-Audio-A01-R1234567.exe)
  • Thanks Duhhh.  Just so you know, when I was encountering those Primary Drive not found errors, I did play with the jumpers to set them to Master and Slave, but that never resolved the issue and the BIOS never seemed to find the drive.  In any case, I now have my boot drive on Cable Select and my secondary drive on Slave (I set it to slave by removing the jumper completely and it is on the second connector on the IDE cable).  Do you forsee any problems with this?  I haven't encountered any problems thus far so it seems like ths system is working fine.
     
    Thanks!