Another E521 BIOS Update Failure - Mother Board is Toast - General Hardware - Desktop - Dell Community

Another E521 BIOS Update Failure - Mother Board is Toast


Desktop computer Forums (Audio, General Hardware, Video)

Another E521 BIOS Update Failure - Mother Board is Toast

  • If you are not having problems with your E521, you may want to think twice before updating your BIOS with the latest Dimension E521 1.1.8 System BIOS. 
    I noticed there are several other posts on the failure of the  "recommended" BIOS and want to add that I had the same problem. I followed the instructions and disconnected all USB devices except the keyboard and mouse, as well as closed all programs so I am not sure why this happened.  I have a wireless keyboard but am not sure if that would make a difference.
    After the update, I had no video display, no active USB's, no diagnostic LED's, and my hard drive was spinning and spinning. Also, the Power button was glowing orange.  However, I still spent over an hour with the chat support people taking nearly the entire PC apart to "troubleshoot" by taking out this card and that module, etc then trying to reboot.  After an hour or so  and at least 5 attempts to reboot, I finally told them enough is enough and to send a motherboard and a tech  - my E21 is only a week old so it is covered under warranty.  It is pretty obvious there is no magic you can perform on a box with no working floppy, display, keyboard or mouse.
  • I have  a simular problem with my E521, dell support pop up told me to update the bios, which i did and followed the instructions. Even download the update to save on a usb memory stick just in case, waist of time that was. Also saved it to the desk top. Followed on screen promps, then system died big time.
    will now only power on the green light on the power button and bleps at me, with number 4 in the dispaly.
    Did a bit of checking on the dell site with my laptop, and nothing of any use to help.
    I did find one article on resetting a bios jumper, but according to the dell drawing for my E521 there is no bois jumpper?
    I also looked for a bios recovery program but could not find anything.
    So by the sound of it, my motherboard is also toast.
    No one around to contact at dell on a weekend either to get it sorted or get it returned for a repair.
    So now have to wait till monday if they work on a bank holiday, if not tuesday, then spend hours on the phone trying to get it sorted out or returned to dell, what a waist of time, wish i never took any notice of the pop up, to up date the bios in the first place.
    Seems like many others on here have the same sort of problem, dell must be getting loads of systems back with motherboards that are toast, which is all down to them in the first place.
    I hope this is covered as my system is only 2 months old. I guess i wont see my pc back for a while, thank good I have my laptop as a back up.
  • I used the Technical Support Chat instead of calling.  It seems someone is always available on the chat support - no Memorial Day weekend in India, anyway (ha ha).  They were the ones that issued the dispatch # to get the motherboard and arrange a tech to come on Tuesday.  I have used the chat support many times and have never been disappointed with the outcome.  On 2 separate occasions, they have arranged warranty replacement parts to be sent to me and were on my doorstep in less than 18 hours - I was amazed both times!

    Here is a list of my system in case you see any similarities with yours:

    AMD Athlon 64 X2 Dual-Core 5600

    4 GB DDR2 SDRAM 667MHz

    500 GB EIDE SATA II Hard Drive

    48X CD RW/DVD Combo Drive

    16 x DVD+/-RW SONY SATA,

    ATI Theater 650 PRO Combo Analog/Digital TV Tuner

    1394 Controller Card

    ATI Radeon X1300 Pro PCI Express

  • Thanks for the reply, I had a go at getting on the tec support chat today, and all I got was that no one was available, then when I looked closer at the info displayed it said opening hours were monday to friday,????
    I was on the dell uk site. you could of been on the euro or usa site??
    It said the same thing for telephone support.
    Unless you have a better warannty than me, I just have the standard CAR, RTB.
    thanks mike
  • I have to agree with Tina's advice about not updating the bios if you're not having problems.  I've done bios upgrades many times in the past on other machines, but toasted my  MB with this one. 
    And what really bugs me is this: the bios upgrade came as a Dell recommendation that was delivered to my computer.  After i toasted the MB, I talked to folks in online chat and basically was told, you should never flash the bios.  Well, so why did Dell tell me to do it?
    I have to disagree with the person below who suggested that chat support is helpful.  I've used it several times, including the night I bricked the motherboard, and it's pretty much a waste of time.  They start the conversation off by saying, I can help you with that, then read pat answers from a manual.  Or at least that's the impression I get.  The process is long, frustrating and I've never felt like I'm dealing with someone who knows a lot about computers.
    Anyhow, my two cents.
  • I had a similar problem, My Dell Support Center said there was a recommended update for my Inspiron 620.

    It was to upgrade from ms-ao8 to ms-a10, downloaded, and saved file, and when I tried to install it received an error message "GetMeVersionError, GetLastError=2. I did the online chat, they are sending someone to replace my motherboard. I'm not sure the motherboard needs replacing, I think it's a bad update.

    Any idea what that error message means? The My Dell Support Center program says my motherboard is ok.

    If there is something wrong, would it not show up when I run the checkup program?

  • Those sound like Windows errors, and typically BIOS updates are run from DOS.

    If your 620 still boots Windows, it's OK. A 'bricked' motherboard will not boot at all, still less Windows.

  • I tried installing in windows and tried using command prompt (windows 7 home premium).

    Still get same error message.

    Let me know if you hear of anyone with a successful upgrade of this.

  • The Command Prompt is not DOS. You need to boot from a DOS-formatted floppy or USB flash drive to perform the upgrade.