Primary drive 1 / secondary drive 1 not found - General Hardware - Desktop - Dell Community

Primary drive 1 / secondary drive 1 not found


Desktop computer Forums (Audio, General Hardware, Video)

Primary drive 1 / secondary drive 1 not found

  • I have a Dimension 3000 that started out with a curious set of BIOS settings. I've solved most of the problems, but still get an error message at boot that Primary Drive 1 and Secondary Drive 1 are not found. Hitting F1 makes the PC continue boot into Windows, and everything seems to be working.

    BIOS updated to A03.
    Running XP Home

    Any suggestions appreciated.
  • Check ribbin on board and on drives  if that doesnt do it look at jumper setting m,s cs.ect.. M=Master S=SLAVE CS=Cable Select...
  • Wecoyote189, try reseating the ribbon cables to the drives and to the motherboard.  Then try clearing the NVRAM by following the procedure I have listed below.  The clearing of the NVRAM will cause the system to redetect all the installed hardware including your drives as well as default the BIOS options back to their recommened factory settings.
    • Reboot system and enter the BIOS Setup by pressing F2. 
    • Turn on Caps Lock, Scroll Lock and  Num Lock.
    • Press ALT + E then ALT + F (should hear beep) then ALT + B

    In the event after clearing the NVRAM you get an error regarding the diskette drive on boot up and you don't have a floppy drive then just go back into the BIOS Setup.  Turn Off the option for the Diskette Drive and the error message will be gone on the next reboot.  That option can be found in the Drives sub-menu.  The reason this occurred was that clearing the NVRAM defaulted all your BIOS options back to their factory settings. On some models this defaulting will turn on the Diskette Controller even though there is no floppy drive in the system.


    I would also recommend running the Dell Diagnostics on the system.  An F1 - F2 boot up scenario can be an indication of a failing drive.

    Message Edited by Majestic on 03-09-2007 07:33 AM
  • Thanks,

    Reseated all the cables without effect. The cables look to be in good condition with no kinks and the connectors are all clean.

    The ALT + E, ALT + F, ALT + B worked, and the "Not Found" messages are gone and the box boots straight into XP.

    I turned off the floppy in BIOS - box doesn't have one.

    I can see the CD-R/W in My Computer, and even cause the tray to eject, but it won't recognize any media. I installed the updated driver [DL_NT(XP)] for the CD-R/W (a GCR-8483B) without effect.

    Looks like I may need a replacement CD-R/W.
  • Wecoyote189, you're welcome.
    Prior to going out and purchasing another optical drive you might consider posting in the Dimension - CD / DVD forum.  Possibly there is something we're overlooking and that forum may provide some fresh ideas.  If you decide to post there then be sure to list what you have done so far so you can eliminate the duplicate suggestions.
  • Majestic

    You are a Genius. Thank you soooooooo much. I had the same exact problem. I'm working on my friend's computer and that F1 - F2 screen bugged me to no end. I did exactly what you suggested and it worked! Now the D3000 goes right from the DELL splash screen to Windows.

    By the way... Just for my own edification, what does NV stand for in NVRAM?

    It's probably something so obvious that I'm just not seeing it.

    Thank you again.
  • 4Me2Know, you're very welcome.  I'm glad you found the previous information useful and that it resolved your problem.
    As for the NVRAM, it is an acronym for Non Volatile Random Access Memory.  You can click here for a better definition of it.
  • This just worked for me too!  It's been driving me nuts.  I have Dimension XPS (2004) and the battery on the motherboard died.  So I got a new one and have had this problem for a few months.  Finally did some searching and found this.  Worked great.

    The machine has been upgraded since I got it in 2004 with more memory, another hard drive and Windows 7.  It's been a great machine and still does what I need.

    Thank you!