Forums

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Mass Storage Device USB problem

  • Dimension 8300.  Recently started having problems with USB and Mass Storage devices.  When I plug in a USB mass storage device, my Olympus digital camera, Ipod shuffle or my HP printer/card reader, it says the drives are not formatted.   Can't download photos or get I-tunes to recognize the devices.  Any suggestions.  I've deleted all the drivers and reinstalled all devices one by one.  The USB ports work with all other devices including allowing me to stream video from my Sony camcorder.  The devices, camera and IPOD work fine and are recognized on my other computer.
     
    Went so far as to buy a PCI USB card but same problem.  Any suggestions?
  • Are all those devices overloading the power available on the USB hub? Do you need an externally powered USB hub?

    Have you tried disconnecting all USB devices, except mouse and keyboard, and then uninstalling all USB entries in Device Manager, and rebooting. When you reboot XP should reinstall the USB ports. Connect the devices back one at a time to see if they're recognized. If you get to a point when connecting another device causes them to fail, you probably need the powered hub, or to connect fewer at a time.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Done all you've suggested.  Even when the Mass Storage Device is the only device connected, they cannot be accessed.  Says the drive needs to be formated or that the drive is not readable.  Again, only on this computer.
     
    This is a problem that has developed recently and it only happens with Mass Storage Device
     
  • Just tried it with a flash drive that works on every other computer and it advises that drive needs to be formatted, but then advises that windows cannot format.  Under drive properties, it says there is 0 mb; same for digital camera and card reader on HP printer
  • I am also having problems with my usb mass storage device driver.  I use Canon Pixma 6700 printer and Windows 7.  Printer was doing fine until a week ago when I began getting error Code 10 that there was problem with USB Mass Storage Device and printer no longer would print.  I tested the cable and that was fine.  My drivers were up to date including the Mass Storage Device driver.  When I plugged my back up device into one of the usb ports it works fine.  Is the problem in the printer and if so can it be fixed somehow??  I hate to think of purchasing another printer.