New 5150 won't display anything on 1907FP monitor

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

New 5150 won't display anything on 1907FP monitor

  • I've just received and set up my new Dimension 5150 but no picture displays on my 1907FP Monitor.
    I've connected the DVI cable to the back of the ATI Radeon 600 video card and the USB cable to a USB port.
     
    The self test function works and so there's nothing wrong with the monitor.  I've tried going through the on-line Dell Support, but nothing there helps me.
     
    When I turn the monitor on first, I see the Dell Genesis screen briefly but then blank.  Pressing the select input button gives the analog self-test screen.  Pressing it again gives "2. Digital" for a moment and then blank again.
     
    The equivalent thing happens if I disconnect the DVI cable and use the VGA cable instead.
     
    I would contact a Dell Technician on-line but I need my Service Tag and unfortunately this is illegible - a couple of the characters are blurred and I gave up after guessing about 30 combinations!
     
    When I turn the PC on, it makes a few very short  whirry noises and then stops.  The power light is green and solid and there's the numbers 3 and 4 lit up in green.
     
    I was hoping getting a new PC would be straightforward, but I seem to have fallen before the first hurdle! :smileysad:
     
    Does anyone have any idea what I should try?
  • Have you tried booting it WITHOUT a USB cable connected?
  • Your service tag will also appear on your invoice as well as a sticker on the computer. Not sure where you were reading it from. You don't need the tag to contact support. Use Chat or email and contact them asap.
  • I hadn't tried that, Tigerwolf7.  But I have now and it makes no difference.

    BTW, this morning there's no beepy noises when I try to power up, whatever's connected - just the green light and the quiet noise of the fan.

  • Thanks Mary G

    I was looking at the silvery shiny sticker on top of the PC case, but have since seen a normal black on white printed sticker on the back of the PC case.

    I'd emailed them, but I'll go in again and try chat.

  • Look in your manual for what the code your system is displaying means. Could be something simple, like you just need to reseat your memory. Or the system may just be bad.
  • Got there thanks.  You were right - I had to take out the memory and replace it, then it all worked fine.

    Thanks