Install missing service tag in bios


Desktop computer Forums (Audio, General Hardware, Video)

Install missing service tag in bios

  • I have a Dimension 8200 desktop. Motherboard replaced by Dell tech and he never re-installed my service tag to the bios.  When help and support reads my system it says Dell 2. Can someone point me in the right direction to do the install please.
  • Dell has two utilities available for download that may or may not help with installing the Service Tag number.  I have listed them below and you can give them a try.  The utilities are not for all Dell systems and in the event they do not work on your model you will have to contact Dell Tech Support again.  After you explain the problem with the motherboard replacement and the need for installing the Service Tag number, Tech Support should send you out the right utility.  Since the Service Tag number is basically the serial number of the machine, it should be installed in the event of possible re-sale and Dell should have no problem with that reasoning.

    Click here for a download of SVCTAG.EXE which is a Service Tag utility.

    Click here for a download of ASSET.COM which can be used to install the Service Tag using the following command switches.....

      asset /s [XXXXXXX] Sets either a 5 or 7 digit code. X's being the tag.
                                     (Try using both a small and Capitol "S" if one switch doesn't work)

  • In addition to your Private Message I answered earlier, I ran across another program that will create a bootable disk with the program.  According the documentation this program works on the 8300 and 8400 models so it may also work on your 8200.  Create the disk using the download and then reboot your system with the floppy disk still in the drive.  The program will then boot up.  Use the command I listed in my previous posting for the ASSET.COM utility.  The " /s " is a hidden switch that won't show up in the on-screen help, but is used to change the Service Tag.   Click here for that download.
  • Hi,

    I have a Dell XPS T500 and thanks to Majestic for SVCTAG.EXE. I could change the service tag.

    I would also like to change the Service Tag field to an in-house number. Both SVCTAG.EXE and ASSET.COM are unable to make the change. I have upgraded the BIOS to version A11. Any suggestions/ideas/thoughts are welcome. Appreciate it very much.

  • Kadoodle, is the number you are try to install contain the necessary 5 digits or does it contain more letters and numbers?  With the XPS T series the Service Tag number should be limited to 5 characters, if you are trying to install a larger number that maybe the reason it isn't working.  As for the ASSET.COM program, that program won't change the Service Tag number on a XPS T model.   

    P.S. (For future readers)  In checking the BIOS history for the XPS T model BIOS version A07 expanded the characters for the Service Tag Number from 5 to 7.  If you are using BIOS version A07 or later then a maximum of 7 characters can be used in the Service Tag number.

    Message Edited by Majestic on 11-01-2005 08:25 AM

  • Majestic,

    Thanks for the super fast reply. I meant asset tag that is not working. Changing the Service Tag using SVCTAG.EXE is fine - thanks to you.

    I tried SVCTAG.EXE and ASSET.COM, both unsuccesful. The number that I would like to put into the Asset Tag field contains one letter and followed by 6 number ie Txxxxxx. Asset.COm gave error "Working Buffer Size provision failed. Error Code 86"


  • Kadoodle, as far as I know the XPS T model doesn't have an Asset Tag.  In fact I just logged off and rebooted my system to double check and I didn't see anything listed in the BIOS Setup.  With that era of computer Dell computer systems none of the Dimensions had an Asset Tag option in the BIOS that I am aware of although the Optiplex product line did.
  • Majestic

    I could be wrong, but the original Service Tag number was put into the Asset Tag field. And, Service Tag field was originally empty. I run a vbscript to query the BIOS and Assert Tag does exist. I had changed the Asset Tag field on a Dimension PC's before.

    Many thanks for your help.

  • Majestic

    You are right. I reboot my machine and asset tag field is not display in the BIOS.

  • "I could be wrong, but the original Service Tag number was put into the Asset Tag field. And, Service Tag field was originally empty."
    It may have been that way in the earlier XPS T BIOS versions although I don't recall it.  Even the documentation doesn't show an Asset Tag as being displayed on the main page of the BIOS Setup. 
    In the BIOS history for the XPS T there was a couple of tweaks related to the Service Tag number.  With BIOS version A09 there was the following change.... "Display Service Tag using DMI Type 3 Serial Number instead of Type 3 Asset Tag."   This may have affected the ability to access a Asset Tag number, assign it or display it.  I see now there was another change that increase the Service Tag number to 8 characters instead of the previous 7  I mentioned.     
  • Hi,
    this may help you to resolve the problem.

    Dell ASSET.COM Version 1.07 is capable of handling 7-Digit Service Tag numbers.  Version 1.05 of ASSET.COM will not support a 7-digit service tag product shipping from Dell.

     If the old version of ASSET.COM is run on the new 7-digit service tag product, the service tag will not be displayed properly by ASSET.COM

  • comi66,

    Is there any specific file names that correspond to the ASSET.COM Version? I would like to try them.



  • help me

     When I put my Service Tag or Express Service Code it show me that it is not a Service Tag number ?

    1)   how can I register my laptop ?

    2)  how can I contact with dell support  {Chat Technical Support} ?   

  • Asset 209 is the last version I know of. 

    Newer Bios and system will allow a 1 TIME typing of the tag into the field if its blank.  This is one time only however.

    1. its for desktops  Don't even go there it does NOT work with laptops.

    2. its not for anything current its for the OLD series,

    DCCU will allow the owner tag to be changed but not the Service Tag.

    ASSET 209   Asset Version 2.09
    Release Title: System Utilities:
    Dell Asset Utility, Utility, English, Multi System, 2.09

    Release Date: 09/27/2005
    Description: Asset Utility

    Utility : Dell Asset Utility

    Version 2.09
    For Dimension : 4700, XPS Gen 3, 4700C, 5000, 9100, XPS (Gen 5), XPS Gen 4, 5100C, 5100, DXP061, DXC061, DM061, 8400; OptiPlex : 170L, GX280, SX280, 745c, 745, GX620, GX520, 210L, GX270 / GX270N; Precision : 670, 470, 370, 380, 690, 490, 390
    For Operating Systems : Any Operating System
    Languages : English

    ASSET new_asset_tag Specify new asset tag
    ASSET /d Delete asset tag
    ASSET /o new_owner_tag Specify new owner tag (if applicable)
    ASSET /o /d Delete owner tag (if applicable)
    ASSET /? This help screen


    Hidden Options

    ASSET /s new_service_tag Specify new service tag
    ASSET /s /d Delete service tag
    ASSET /b Specify new system board tag
    system board tag must be "ssssssssssssssssssss-vvv-", where
    s..s is the 20 digit system board Part number string,
    vvv is the 3 digit system board rev,
    - is a don't care character, but must be present
    ASSET /b /d Delete system board tag
    ASSET /f [other_options] Force Affirmative response
    ASSET /x [other options] eXtended display - displays all tags


    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating.

  • amjadkhan1237

    help me

     When I put my Service Tag or Express Service Code it show me that it is not a Service Tag number ?

    1)   how can I register my laptop ?

    2)  how can I contact with dell support  {Chat Technical Support} ?   

    If you bought the system directly from Dell, it may take a few days to 1 week (or more) for the Service Tag to be visible in their Support database.

    If you didn't buy the system directly from Dell, you have to register the Service Tag in your name.

    EDIT: Tech Support via chat may not be available in every country or for every PC model So if you need immediate assistance for warranty support, you will have to use the phone number or email address for your specific country or region.

    If this answers your question, please click  Yes  


    Forum Member since 2004

    I am NOT a Dell employee