Power Supply has blown a fuse

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Power Supply has blown a fuse

  • i have bought a new power supply for my dell optiplex Gx270 SMT and after placing it inside my computer i turned on the mains and then came a bang from inside and now my PC wont turn on, im sure its not the power supply cos the site said it was compatible, the supply is a 425 watt. Can anybody tell me how to fix this problem and what damage i have done?. At the end of the day i want my PC working with the power supply so i may have placed the wires in the wrong connectors. Can anybody help?
  • James9112,

    Thank you for using the Dell Community Forum.

    It sounds like you may have fried your motherboard if you heard a loud pop when you turned it on. Pull all the cards and memory off the motherboard and turn it on. If you do not hear any beeps then, the motherboard is broken.

  • Im sure it was the power supply and you now have a fried system. The GX270 DOES NOT USE the proprietary Dell power supply aka the one for the GX1, GX110, part number 9228C.


    You are sentenced to death and may microsoft have mercy on your data.

    Report Unresolved Customer Service Issues here:

    Dell - Unresolved Customer Service Issues

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • Did you re-wire the 20 pin connector? or just connect it upside down?

    is this the psu from PC Power and Cooling?  If so you shouldn't have had to re-wire it

    HAs the problem been fixed?

    what did dell say?

     
    Please let me know before i do the same thing?
    I am planning to upgrade PSU for Nvidia 6800 GT
     
     
    2004 Optiplex  GX270 user ( Small Tower case)
  • Yea it was my powersupply that was faulty and i blew the fuse in the lead