Primary hard disk drive 0 not found - General Hardware - Desktop - Dell Community

Primary hard disk drive 0 not found


Desktop computer Forums (Audio, General Hardware, Video)

Primary hard disk drive 0 not found

  • Every once in a while for no reason the screen goes blank and the following message is on the screen:


    Phoenix ROM BIOS PLUS Version 1.10 A03

    Copyright 1985-1988 Phoenix Technologies Ltd.

    Copyright 1990-2003 Dell Computer Corporation

    All Rights Reserved

    Dell System Dimension 8250 Series

    Primary hard disk drive 0 not found

    Strike the F1 key to continue, F2 to run the setup utility


    After striking the F1 key then it says:


    Strike F1 to retry boot, F2 for setup utility


    I have not tried anything striking the F2 key.  The only way I can get the computer to restart is to shut it down by pushing the power button.

    Thank you for any help you might have to offer on this.



  • Are you eventually able to get the computer to start by shutting down and restarting?  If not, hit the F2 key when the error message appears to go into the BIOS setup.  Change the Primary IDE dveice setting to "Auto" then hit the Esc key to save changes and reboot.  If this doesn't solve the problem, shut down the computer, open the case and make sure all cables between the hard drive and motherboard are securely connected.


  • Hi Steve,

    After I push the power button the computer does shut down.  Then I push the power button again to restart the computer and it restarts fine.  All is well until I get that message again.  I say it happens on the average of once a week.



    Message Edited by tc27407 on 05-25-2003 02:58 PM

  • Hi Tim,

    You still might want to try Steve`s suggestions, too a loose connection can cause erratic behavior. You might try "Clearing the NVRAM"

    Best Regards


    "Live Free -- Die Hard"

    Forum Member since March 1998

  • the same thing happens to me but it doesnt restart fine it goes back to that primary drive not found thing...its like a cycle. i put it on auto and now it says Secondary Master: Cd-rom reader....or something like that....i really need help. i am completely stuck although i havent tried the opening thing. can you tell me how to open it and what the cables look like? i have a dell 4550 thanks.
  • thanks guys i got it i pressed space bar a lot and it brought me to a window thanks

  • Thanks for all the help so far everyone. 

    I just opened the case and looked at everything and didn't see anything out of the norm.  I also unpluged and checked all of the harnesses going to all of the drives and going to the motherboard and all looked good and made sure all was pluged in good.

    So now I wait and see.  I'll let everyone know if that took care of it or not.

    Thanks again,



  •  This sounds like what happened to mine. I have to restart by either Ctrl+Alt+Del or pushing the power button, and when it comes up this is what it says:




                                                                           F12 Boot Menu


    OptiPlex GX260 Series

    BIOS Revision A03




    then i hit F12 to go to the menu where it says:



    Phoenix ROM BIOS PLUS Version 1.10 A03

    Copyright 1985-1988 Phoenix Technologies Ltd.

    Copyright 1990-2002 Dell Computer Corporation

    All Rights Reseved


    Dell System OptiPlex GX260 Series


    Primary hard disk drive 0 not found

    Strike the F1 key to continue, F2 to run the setup utility



    but when i hit F1, it definately does not continue, it says the same message again every time. PLEASE help if you can. Thank you for your time.





    Refurbished DELL OptiPlex GX260 Desktop

    Intel P4 1.7 MHz

    256 GB of RAM installed

    20 GB IDE Hard Drive

    Windows XP Pro installed

    IDE CD ROM Drive installed (various speeds)

    1.44 Floppy Drive installed

    2 DIMM slots

    2 PCI slots and 1 half height AGP slot

    2 PS/2 Ports

    4 USB Ports (2-back, 2-front)

    2 Serial Ports and 1 Parallel Port

    Onboard Network and Audio installed

  • LeeAnnMoody

    First open the case and check that the data cable is properly connected to the hard drive and motherboard. No difference, then it would seem that hard drive has failed and should be replaced. You need to buy a 3.5" IDE/EIDE 7200rpm hard drive, any size up to 120gb should be fine.


    Please don't send me questions about your system by DCF Messenger.
    Post the issue in the appropriate Board, where they will be answered.
    Message Edited by shesagordie on 08-15-2008 10:06 PM


    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell