GX280 Sysprep - USB Keyboard / Mouse Inop - General Hardware - Desktop - Dell Community

GX280 Sysprep - USB Keyboard / Mouse Inop


Desktop computer Forums (Audio, General Hardware, Video)

GX280 Sysprep - USB Keyboard / Mouse Inop

  • How have you gotten this to work?  Our XP SP1 sysprep was made on a platform other than the GX280 and mini-setup has issues with the keyboard/mouse or even the NIC sometimes.  I built a sysprep on the GX280 and that one won't work on our other systems.  What am I missing here???  What's the secret??  Dell Premier support doesn't seem to know.



  • Tushino, could you please post what you have done to fix this issue. None of the posts here are helping me.

    We are currently moving towards a universal image. What this means is that we will have one image that will work across multiple platforms. To do this, and to avoid corrupting the OS, no drivers are loaded onto the image. *Using a special utility called 'Universal Imaging Utility': http://www.binaryresearch.net/index_products_services.html

    I've ran into problems in the past where if you load too many devices onto an image that the registry, particularly the area that is used during boot up, gets too big and then produces an error message on boot up. The only way to recover from it is to take a backup copy of the registry and load it in. If you have a recent emergency repair disk it might not be as painful but who has that? Since you have to use a backup of the registry you must also load any programs that run as a service as well as all the drivers. The time it takes to do all that you might as well backup personal data and re-image.

    If it is determined that there is no way around this issue except to load the drivers for the USB devices first then so be it. I guess a few drivers installed wouldn't be that big of a deal. I would have thought Windows would use drivers already stored in the OS but perhaps that is not the case with this new model.

    I also do not use a drivers directory within the sysprep directory so that fix won't work for me.

  • I am also having problems however I have the optional PS\2 adapter card installed. My sysprep image is locking up during Mini-setup presumebly while it is trying to plug n play the keyboard\mouse? If I make an image on the Gx280, imaging all other Gx280s work fine however I'm trying to create a universal image and I need to build the image on a different model. anyone else using the optional PS\2 adapter card?
  • Ok, I've figured out how to get this to work:

    Copy 'usb2ndrv.cat' file (located in the Chipset driver) to the 'sysprep\i386\$oem$\GX280\USB' directory. *You can use whatever drive path you want here but if you do use a different path make sure you use that path in the below listed OemPnPDriversPath

    Add the below line to the [Unattended] section of the 'sysprep.inf' file:

    OemPnPDriversPath= sysprep\$OEM$\GX280\USB

    Now all that is needed is to run sysprep and make your image. When you deploy the image the USB keyboard and mouse should work fine...

  • I managed to get my sysprep mini-setup to detect the mouse. I can move it around while it's still detecting devices. When it reboots and I get to my login screen, I get a mouse cursor but no response from it. Same with the keyboard.
    Why does it work when the mini setup detects it then stops working upon reboot? Makes no sense to me.
  • For what it's worth I opened an incident with Microsoft 2 months ago on this issue and it has been escalated to development.  They even went and got a GX280 and re-created all of our problems.  At least we aren't crazy!  I'll post a resolution if I ever get one.  I've been getting around the issue by using the GX280 to build my image on and doing a fully unattended setup.  Post build I run a script to rename the computer and other tasks.
  • Building a seperate image just for the GX280 isn't an option for us. We have a Master Image that works for GX1, GX115, GX150, GX200, GX240, GX260, GX270.  All those models work well using just one image. We have many updates installed on it and I can't be creating multiple images. Would be a nightmare to keep them all up to date.

    I'm currently trying out the latest chipset version from Dell (A09) as part of the sysprep setup. We'll see what that does in a few minutes.

  • I had the same issue before. I downloaded the Intel Chipset drivers instead of the Dell drivers, extracted the files and placed them in my drivers directory.  Use the ich6 drivers only, if you use the 5-6 there will be a conflict with the usb 2.0 and no usb device will work.
  • For Health Canada....  I only have one Master Sysprep Image and it is now created on the GX280.  It works just fine on our other Dells, Compaq's and IBM's as long as I run a fully unattended mini-setup.  Once the the PC is rebooted and the desktops builds the keyboard and mouse work just fine.
  • centu,
    I'll try what you suggested if this latest attemp fails.
  • let me get an email, I'll send you an screenshot of the files that I have for the gx280. I stumbled accross this because I build one machine from scratch and by using the dell drivers it shows a conflict for the usb 2.0 in device manager. Email me at danny@mbia.com

  • Health Canada wrote:
    I managed to get my sysprep mini-setup to detect the mouse. I can move it around while it's still detecting devices. When it reboots and I get to my login screen, I get a mouse cursor but no response from it. Same with the keyboard.
    Why does it work when the mini setup detects it then stops working upon reboot? Makes no sense to me.

    Did you try the procedure I posted earlier in this thread? It sounds like the wrong USB driver is being loaded during Sysprep. I'm trying to figure out how you got the mouse/keyboard work during Sysprep without doing what I posted actually so I'm a little baffled.
  • Yes, I had done that procedure before even coming to the forum. I put everything that was ICH6 related into a folder and pointed the sysprep.inf to that directory.
    Like I said before, the mini setup finds the mouse and it is operational. After it reboots and gets to the logon screen, all I have is a cursor that I can't move around.
    This is on Windows 2000. Not sure if it's much different than on XP, but it doesn't seem to be.
    I loaded a brand new GX280 with the pre-installed Win2000 OS and the driver giving me problems is the Intel 82801FB/FBM USB2 Enhanced Host Controller - 265C. Driver details points to C:\WINNT\SYSTEM32\DRIVERS\usbehci.sys
    If I install Win2000 from scratch, that controller has a conflict on it. It can find an updated driver compatible with it, but gives me an error while trying to load it. It finds the driver in ICH6USB.INF
    How else are you supposed to load this USB2 controller?

    Message Edited by Health Canada on 11-18-2004 08:29 AM

  • I found out why the driver wouldn't load on a fresh install of Win2K. You need Service Pack 3 and up to be installed in order to get the Enhanced USB2 Controller loaded up properly.
    I also figured out a way to load an image ranging from GX1 up to GX280, but I had to build a brand new image from a GX280 and forget about my old image. Doing it from a 280 allowed me to load the enhanced usb2 controller that the GX1 was lacking.
    To get it working across all platforms, you need to change the computer type in Device Manager from ACPI Uniprocessor PC to Advanced Configuration and Power Interface (ACPI) PC. By doing this, the computer won't lock up on AGP440.sys or MUP.sys when booting up.
    Hope this can help other people looking for better ways of imaging their PCs.
    There might be a way to get an older image to load the GX280's USB2 controller, but I've given up looking for an answer to that.