Dell XPS 27 NEW (7760) FAIL upgrade SSD M.2 - General Hardware - Desktop - Dell Community

Dell XPS 27 NEW (7760) FAIL upgrade SSD M.2


Desktop computer Forums (Audio, General Hardware, Video)

Dell XPS 27 NEW (7760) FAIL upgrade SSD M.2

This question has suggested answer(s)

The other day I bought this wonderful computer. This is an excellent machine with a new hardware. But my configuration consisted of HDD 2T + SSD 32 Gb. M.2. I decided to fix it:)

I bought a new SSD ADATA SX8000 512 Gb. M.2 PCIe Gen3x4.

But the problem is that the BIOS refuses to see this SSD.

I was able to install windows on a new SSD. But BIOS still does not want to see my new SSD. The computer is working. But each time it turns on, it gives an error. But it should not work like this.

All Replies
  • Maybe there are ideas?

    My friend works in a service center for computer maintenance.

    Through his channels, he learned that only certain SSDs are included in the BIOS.

    Is this really so?

  • M2 is not a specification its a form factor.  There are 2 kinds of M2 one which is MSATA and one that is PCI-E  NVME. The 2 types are not interchangeable.  One connects directly to the PCI-E bus and the other goes thru SATA.



    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • Yes. M.2 can be in two versions. In the XPS 27 model, these two options are combined into one M.2 port. The port can accept mSATA and PCIe. This works in both cases. I checked.

    I was able to make friends, my new SSD 512 M.2 PCIe and BIOS,  in RAID ON mode. This works fine at the stated speeds (R 2500 Mb / W 1000 Mb). The problem is solved! The only thing I could not clone was the Windows image HDD ➡ SSD.

    But this problem is solved. Install a clean original image. And further activation through the hardware part.The key is in the hardware part.