Dell Inspiron One 2305 WOL (Wake on LAN) not working

Desktop

Desktop
Desktop computer Hardware and Software discussion

Dell Inspiron One 2305 WOL (Wake on LAN) not working

This question is not answered

The LAN card is supposedly a Realtek RTL111E, which fully supports WOL magic packets. However, right out of the box, WOL doesn't work at all. 

After updating the Realtek NIC driver (from Realtek as the Dell driver doesn't work), I managed to get WOL to wake from Sleep mode, but not from S3 shutdown.

The computer will not start from shutdown upon receipt of the magic packet. It will wake-up from regular sleep.

The active light is on, on the switch when the computer is powered down, so I know the NIC adaptor is getting auxilary power. Also, because it does wake from sleep via a magic packet, I know I am forming my packet correctly and it is being received.

This leads me to think there is an issue with the BIOS not forwarding the PCI -> PXE.

I have the proper BIOS settings made, as well as the NIC settings. These are:

NIC Advanced Tab Settings:

Shutdown Wake On LAN: Enabled

Wake on Magic Packet: Enabled

Wake on Pattern Match: Enabled

WOL & Shutdown Link Speed: 10mbps First

NIC Power Management Settings:

[ X ] Allow computer to turn off this device to save power

[ X ] Allow this device to wake the computer

[     ] Only allow a magic packet to wake the computer

BIOS Settings:

AC Recovery: Power On

Remote Wake Up: Enabled

Auto Power On: Disabled


Have I missed anything here?

-Mike

All Replies
  • Under NIC Power Management Settings have you tried unchecking:  "Allow computer to turn off this device to save power"?

    Just a thought...

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • We just purchased 30+ Inspirion One 2305's and are having the same issues with the WOL!!!  

    I have checked the BIOS version and it is A05, checked the BIOS settings:  AC Recovery: Power On, Remote Wake Up Enabled, and checked the NIC Power Management settings:   Allow computer to turn off this device to save power is checked and Allow this device to wake the computer is enabled.

    I have been in contact with DELL and it has been 6 calls, the same questions:  What BIOS version? ; What driver version on NIC? ; What BIOS settings are enabled?  ; Check Power Management setting on NIC!

    I have done all of these and I cannot Wake up the Inspirion One even in Sleep Mode!!!!!

    I am using the DELL KACE management server to perform the WOL.

    I have 375 other DELL Optiplex's, Inspirion's, ect. that all WOL with my current network configuration.

    We may be sending the 30+ Inspirions back to DELL and purchase something more reliable.

  • MSUGFJohn

     ...Allow computer to turn off this device to save power is checked...

    Surely you meant unchecked. Correct?

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • If you uncheck "Allow computer to turn off this device to save power"  then you cannot enable "Allow this device to Wake the computer."  

    If you have an email address I can show you this with screen shots.

    To place a check for "Allow this device to Wake the computer"  you must first check "Allow computer to turn off this device to save power."

    Doesn't make sense to me either?????

  • Sounds like there's a bug somewhere!!

    What if you check "turn off this device", then check "Wake on LAN" and go back and uncheck "turn off"? Does that automatically uncheck the "wake" box too? Even if it does that, will it wake on LAN that way?

    You can post screen shots here on the forum. Click the "Use rich formatting" link to left of Reply button instead of using the 'quick response' box to type your message. On the toolbar on the rich text screen, click the button, 2nd to the left of the Microsoft Word (W) button to insert an image and follow the prompts.

    I'm going to flag this for the forum liaisons. Maybe they can get to the bottom of this.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • You can check "turn off this device, and then check Wake On Lan, but when you uncheck "turn off" the Wake On LAN is greyed out, with the check mark there.

    I have tried my WOL with this setting with NO luck also.

     

     

  •  

     

     

     

     

  • Before you can even select "Allow this device to wake the computer"  you first have to select "Allow the computer to turn off this device to save power."

     

    Doesn't make sense to me?

     

  • I believe you.

    I posted a query for the Liaisons to look at this thread. I don't work for Dell so no promises a Liaison will respond here. And even if they do, they may have to huddle with the tech engineers to figure this out.

    BTW: you can include more than 1 image in the same same post. And if you need to edit one of your posts, click the little pencil icon at the bottom of that post, just to the right of the "Report Abuse" link. Wink

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I see that a bunch of new Realtek drivers were posted on their site in last few days for XP through Win 7. Maybe they fix this problem.

    Confirm the new driver matches your hardware and version of Windows before installing. And probably be a good idea to manually set a System Restore point before you update the driver, just to be safe. Wink

    Ron 

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Don't know if either of you were able to solve the WOL problem by installing one of the recently updated RealTek drivers, but I came across a post on these forums today about a WOL problem with a RealTek NIC that the user fixed by modifying the Win 7 Registry.

    Be sure to back up (export) your Registry before making any changes. I take no responsibility for the accuracy of the other user's fix for this problem, or if it will work for the Inspiron.

    Cavet emptor! Wink

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • This would be a really good time for Dell to jump into the thread and give Realtek a beat-down

  • The latest Realtek drivers for the RTL8111 as of 2/22/2012 (almost a year after this thread was started):

    www.realtek.com.tw/.../downloadsView.aspx

    Win7 and WinServer 2008 R2 Driver 7.050 2012/1/20

    RTL_8_111E, yea?

    "RTL8111B/RTL8168B/RTL8111/RTL8168

    RTL8111C/RTL8111CP/RTL8111D(L)

    RTL8168C/RTL8111DP/RTL8111E

    RTL8168E/RTL8111F/RTL8411"

    Please somone try it; I wont have a chance to try until the weekend and it would be to get some traction here.