eSeries IRRT mode giving BSD's on XP (Sp1) (SP2) (Sp3) (Sysprep's) - General Hardware - Desktop - Dell Community

eSeries IRRT mode giving BSD's on XP (Sp1) (SP2) (Sp3) (Sysprep's)


Desktop computer Forums (Audio, General Hardware, Video)

eSeries IRRT mode giving BSD's on XP (Sp1) (SP2) (Sp3) (Sysprep's)

This question is not answered

Hi Guys,

FYI, yesterday, Saint Patrick’s Day is the day that eSeries BSD and its so famous SATA mode, IRRT will not be an issue any more for existing Master XP images.

-No matter what version of the Intel(R) Matrix Storage Manager Driver you had (Version Released on 3/13/09) (of course I recommend to have the latest), or even if added the proper path on the Sysprep.ini file for the controllers, it still was not letting you to boot off the SATA mode IRRT and getting that lovely BSD "Stop 0x000007B (0x00000000, etc, etc, etc) etc.

Well, here it's the fix:

--> Note1: this will work even if you have already deployed images as ATA mode :-)

-->Note 2: Here I'm just referring to the e4300 and e6400 models (I’m not sure if this fix will work on other eSeries or other models not stated here)

-->Note 3, this fix is just "as is" my recommendation is to first try it out on your systems for testing.

-->Note 4 I have tried out this on XP 32-bit systems... I do not know how well it will be on XP-64-bit

Step 1 Download the latest Intel(R) Matrix Storage Manager Driver here:*+XP+Professional&lang=eng&strOSs=44&submit=Go%21

Step 2: go to the command line, navigate to the folder you downloaded the Intel drivers; extract the drivers by typing this command from the command prompt: iata87enu.exe -A -P C:\SATA\IntelMver8   (remember this location).

Step 3 Copy and paste the following in a Notepad file in your master XP image: (including "Windows Registry Editor Version 5.00"):

Windows Registry Editor Version 5.00


Step 4 Save it as "Fix_eSeries_IRRT_Mode.reg" (here you can name it whatever you want, but just make sure you put (.reg) as the extension for that file.

Step 5 once that .reg file has been saved, close it and do a Right-Click on it, then select "Merge"

Step 6 boot to the BIOS and change the SATA mode to IRRT: click on "Apply" then "Exit"

Step 7 Your LT will boot up and it will start detecting the new controller mode and its features...

Step 8 if the Hardware Wizard asks you for the drivers, just browse to the folder were you downloaded the Intel(R) Matrix Storage Manager Driver.

Step 9 Restart the LT when asked to do so, (even if is not asked to do it so); then you are done.

Welcome to IRRT mode and its eSata features.

I hope this may be of a good help for those who, like me, were struggling trying to get XP Master images to work.

(FYI, I think there is no place in the "drivers code" (even on the latest version) code instructions to have uploaded those Registry keys into the XP Registry)

-Do not quote me on that, but for this fix, I figured out those entries were needed, and I have entered them manually to  make tht IRRT mode to work.

Thank you


All Replies
  • Hi Jcb-baz-

    I tried your step 3 and when I tried to merge it with the registry, I got the error message "cannot import Fix_eSeries_IRRT_Mode.reg.  the specified file is not a registry script..."

    What do you think I'm doing wrong?  I've tried saving it in ANSI, unicode and UTF8 with the same result.


  • Hi
    That's weird, if you followed the instructions, it should work.
    Make sure, that REG file is created on the ROOT of C:\, sometimes, user profiles would not let the process to merge reg entries due to access permissions on certain levels for user profile settings.
    Make sure of the following:
    -you must be Administrator
    -Set the Folder Options to allow you to see file extensions: Control Panel\Folder Options\"View" tab and uncheck the "Hide extensions for known file types"
    -the .reg file should be on the root of "C" (e. g.  c:\myregfile.reg) with a .reg file extension at the end of the name for that file you've created.
    Give it another try.
    Let me know if it works for you, and or, If you want, I may send you the .reg file.
    Thank you :-)



  • Hi- I ended up reinstalling a slipstreamed windows xp with the correct driver for my precision sata controller this time, so never mind...


  • Here are two methods to overcome the registry merge error.

    1. Using notepad copy and paste the following entry including the Windows Registry Editor Version 5.00 line at the top. In notepad choose save as and enter "irrt.reg" (you can call it what you want with .reg extension) using the quotation marks and select Unicode. I cannot explain why you must add the line or use Unicode but that’s the only way I could properly import the registry key.

    Windows Registry Editor Version 5.00


    2. Click Start>Run type regedit. Right click on any key and choose export saving the file to the root of C: . Open the .reg file in notepad and remove ALL current entries in the file and paste the following:

    Windows Registry Editor Version 5.00


    Click save in notepad. Right click on the new reg file and choose merge. Reboot go into the BIOS and select IRRT mode. When Windows XP restarts it will start detecting the new hardware. You can either point it to the extracted Intel Storage Matrix drivers OR you can click cancel and run the IATA89.EXE and let the program handle everything.

    Not sure what your method of slipstreaming is but I have a love hate relationship with nLite. Its works well but gives an error on sysprep. It still works, but I always have an uncomfortable feeling with any error no matter how benign.




  • I followed the steps above but still recieving the BSOD.

    Current system is a E4200 running XP SP3.  Right now the only drivers not loaded are a PCI driver and the Broadcom USH.

    Any help would be great.

  • Hi There,

    FYI, this has worked fine for all of us...


    Make sure you have all other device drivers installed... specialy for all those that relates to the "Chipset" drivers &

    and the security device drivers.

    Then have handy the SATA controller drivers as stated on the instructions... is is very important to successfully MERGE the registry values as stated on this forum.

    Let me know if you would like to have e-mailed a batch file  I have put together that it will do that for such a purpose.

    Thank you

  • Wpizzi

    Are you getting BSOD during installation of XP or after XP has already been installed?

  • I have same issue as wpizzi. Have e4200 with work image win xp loaded. Tried registry fix but stil BSOD. Even when trying with xp installation CD it BSOD before setup gets to the license agreement where you press F8 Any advise please

  • Hi there...

    As I've mentioned on the fix, in (-->Note 2: Here I'm just referring to the e4300 and e6400 models), what you should probably do is to embed the SATA controller drivers using nLite software ( to  the Windows XP CD; I hope you are familiar using that tool, its pretty much to apply common sense to learn how to us it;  or have Dell to ship you the latest Windows XP SP3 CD which I have noticed that  they have added compatible SATA controllers drivers that will work with the eSeries laptops.

    Thank you




  • I tried that on 6400 as well & it didn't work.

    But I'll just re-install XP & load drivers before installaion starts.

  • I tried this last night and it didn't work.

    Laptop: Dell E4300, clean install of Windows XP Professional (had to revert to ATA in Bios to be able to do this). Bios version A07.

    Registry merge works fine, but when I restart the laptop, I don't get to Windows ...

    Any help?


  • I have the Dell system restore CD for Windows XP SP3.  I have used the CD installed everything and everything was working which then caused another issue.  I make ghost images for all the systems at work.  When using the Dell XP SP3 CD and running sysprep on the drive before image it ask me for a product key for XP.  I currently have a XP SP2 CD with volume lic.

    I have still not been able to get the Broadcom USH device or the one Audio Device to install under the SATA mode in BIOS.  If I run in IRRT mode in BIOS I am able to install all drivers without any issue using the Dell XP SP3 CD.

  • Believe I have it up and running now.  I used nLite and added the SATA drivers to our VOL XP cd.  Everything is now loaded driver wise working on updates.  The true test is on the ghost image.

  • Make sure you have copied the latest version from Intel iaStor.sys file  and the iaStor.ini file to the proper locations:



    In addtion to that above:

    Make sure your sysprep.ini file you have low resolution settings like:


    if that, still does not work, then, add the following controllers at the section:


        PCI\VEN_8086&DEV_24DF&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver5\iastor.inf ; Intel(R) 82801ER SATA RAID Controller
        PCI\VEN_8086&DEV_25B0&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver5\iastor.inf ; Intel(R) 6300ESB SATA RAID Controller
        PCI\VEN_8086&DEV_2652&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver7\iastor.inf ; Intel(R) 82801FR SATA RAID Controller
        PCI\VEN_8086&DEV_2652&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver7\iaahci.inf ; Intel(R) 82801FR SATA AHCI Controller
        PCI\VEN_8086&DEV_2653&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver7\iaahci.inf ; Intel(R) 82801FBM SATA AHCI Controller
        PCI\VEN_8086&DEV_2682&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver8\iastor.inf ; Intel(R) 631xESB/632xESB SATA RAID Controller
        PCI\VEN_8086&DEV_27C3&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver8\iastor.inf ; Intel(R) 82801GR/GH SATA RAID Controller
        PCI\VEN_8086&DEV_27C6&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver8\iastor.inf ; Intel(R) 82801GHM SATA RAID Controller
        PCI\VEN_8086&DEV_2822&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver8\iastor.inf ; Intel(R) ICH8R/ICH9R SATA RAID Controller
        PCI\VEN_8086&DEV_282A&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver8\iastor.inf ; Intel(R) 82801HEM SATA RAID Controller
        PCI\VEN_8086&DEV_282A&CC_0104=%systemdrive%\DRV\SATA\MSD\IMver8\iastor.inf ; Intel(R) ICH8M-E/ICH9M-E SATA RAID Controller
        PCI\VEN_8086&DEV_2681&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) 631xESB/632xESB SATA AHCI Controller
        PCI\VEN_8086&DEV_27C1&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) 82801GR/GH SATA AHCI Controller
        PCI\VEN_8086&DEV_27C5&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) 82801GBM SATA AHCI Controller
        PCI\VEN_8086&DEV_2821&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) 82801HR/HH/HO SATA AHCI Controller
        PCI\VEN_8086&DEV_2829&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) 82801HEM/HBM SATA AHCI Controller
        PCI\VEN_8086&DEV_2922&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) ICH9 SATA AHCI Controller
        PCI\VEN_8086&DEV_2929&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) ICH9M-E/M SATA AHCI Controller
        PCI\VEN_8086&DEV_3A02&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) ICH10D/DO SATA AHCI Controller
        PCI\VEN_8086&DEV_3A22&CC_0106=%systemdrive%\DRV\SATA\MSD\IMver8\iaahci.inf ; Intel(R) ICH10R SATA AHCI Controller

    Good luck, let me know if it worked.

  • Ghost image worked.