XPS 420 wake from sleep issue - General Hardware - Desktop - Dell Community

XPS 420 wake from sleep issue


Desktop computer Forums (Audio, General Hardware, Video)

XPS 420 wake from sleep issue

  • I have just received my new XPS 420 with Vista Home Premium.  I'm new to Vista and have read about the new Sleep feature.  Each time I go into sleep mode, I can not wake out of it.  The power button flashes blue as it is supposed to but pressing it does absolutely nothing.  I have the Bluetooth 19 in 1 media hub with Bluetooth mouse and keyboard.  I searched other similar posts and adjusted the power options to High Performance.  I verified in the device properties for my Kbd and Mouse that they both have the 'Allow this device to wake computer" checked.


    Once in sleep mode, my only recourse is to fully depress the power button and reboot.  Then I get the typical "safe Mode" message because windows didn't like the abnormal shutdown,


    Dell XPS 420

    Q6600 2.4 Ghz

    4GB RAM at 800Mhz

    500GB SATA HD 

    128MB ATI HD 2400 PRO

    19 in 1 Bluetooth Hub

    IAMB KBD and Mouse

    Dual 48x combo and 16X DVD +/-RW

    20" SP2008WFP (w/integrated webcam and mic)

    Windows Vista Home Premium

    Message Edited by TA23e on 03-19-2008 10:41 PM
  • Your issue sounds similar to one I've experienced on the same type of computer.


    Thankfully someone posted a solution and it was easy, so I'd say to give that a try.


    Thread I mentioned

  • Only thing is that my kbd and mouse are wireless (Bluetooth), so there is nothing to unplug / re plug in and I don't have an issue with my system hanging after a reboot, the issue I am having is that I can not wake from the new Vista sleep mode.   No screensaver issues here.


    Thanks, I'll try the power button suggestion, but I can not see what that will do for me.


    Thanks again for the reply



  • Ah, I didn't really realize the Bluetooth thing at first.


    The system that was giving me problems only had a speaker wire plugged in aside from monitor, mouse and keyboard. All I had to do was unplug everything but the monitor. I'm not sure how holding down the power button while the system is unplugged and all that helps, but it did for me. It might for you, it's worth a shot. 

  • TA23e,

    For now...disable Sleep altogether
    1. Open Control Panel
    2. Open Power Options.
    3. Select the High Performance radio button then click “Change Plan Settings”
    4. Confirm “Put the computer to sleep” is set to “Never”
  • Isn't it possible under Power Management to set the POwer Button to SLEEP rather than Shutdown.


    You can disable sleep mode as stated above, but when you put it down for the night, if you want it to sleep rather than shutdown, you can put the computer to sleep by pushing the power button, it should put it to sleep and then if you push the power button again it should wake up without causing you to do a hard start.


    Or am I wishful thinking.....

    Message Edited by eskymi on 03-20-2008 09:21 AM

    2  XPS 420's, Quad 2.4ghz, 8800GT and 9800GTX, 3gigs RAM (Vista Home)

    2 Inspiron 1720's, 2.0 and 2.5 gig processors, 2 and 4 gigs RAM, 8400GM and 8600GT cards (Vista Home and Ultimate)

    1 E1705, 2.0 processor, 2 gigs RAM 7900GS. (Vista Home)

    2 Mini 9's, Black and Cherry Red......(Windows XP) Love The Mini!!!!!



  • Chris M - My issue isn't about goind to sleep - it is about waking up from sleep mode.  Is your solution telling me that my PC cannot wake from sleep, so to disable it "solves" the problem?????


    I want to be able to Wake appropriately, whether I put it to sleep or the PC goes to sleep via power management setting...


    and eskymi - Yes, this is possible, but my issue is about waking up.  Pushing the power button when in sleep mode is not working for me.  My only recourse is to hold the button in and this does a cold reboot.  (not good!)



    Awaiting reply,


    Tom A

  • based on input from others, sp1 addressed hibernate issues. You could search the various sp1 threads and microsfts site on sp1 info and see if sleep mode issues are also addressed...

    XPS 420 with Vista Ultimate 64-bit - Q6700 - 8 GB 800 MHZ Mushkin RAM - 2 500 GB Samsung - 425 Watt PSU

    Nvidia 8800gt - 24" Gateway LCD

  • I would like to add to this thread, I have an XPS 410 and I have tried several steps to resolve the issue of resuming from sleep including reinstalling the OS and the issue still persists. There are no Microsoft fixes that resolve the problem. I have installed SP1 Vista and the problem persists.



    XPS 410

    Vista Ultimate OS

    4GB Ram

    250GB HD

    Nvida 8600 GTS

    Theater Pro Tuner Card

  • KevinH - Yes - I searched long and hard and found no solution for this either on Dell's or Microsoft's web site.  None of the Vista SP1 release notes addresses this.  I installed it anyway, but still nothing works.


    I do however think it may have something to do with the video adapter though.  When the computer goes into sleep mode, the power button flashes, as it should, and the monitor goes into power save mode with the light turning amber.  I then can press the PC power button to wake up the PC, and the PC itself looks as though it has awoken, in that the button light is steady on, but the screen will not wake.  I reinstalled the video drivers that came with the PC, I went to the Dell update site and downloaded all updates and installed them as well, but to no avail.  I purchased the PC with a mediocre Video card and was going to upgrade from ATI to Nvidia, but I see that you have the Nvidia and it is an issue for you too.


    I do not know what to do now.... Is your experience similar to mine?  Next, I'm going to plug in a USB kbd and mouse and see if this wakes the PC up?

  • Yes your issue sounds similar except the power button remains solid green and the system will not wake. I can only power it off to resume operation. I have lost data also. the only way to resolve is what ChrisM has advised which I did long ago.


    Good Luck.

  • I have this exact problem with sleep.  The system will not wake up.  I must hold the power button to reboot.  In addition, yesterday I couldn't even do that.  I had to completely unplug the power cord.  I also have issues on reboot with a configuration error asking me to set the date and time in system setup.  I'm wondering if there are two different problems or both the same.  I've disabled sleep mode so this annoying problem doesn't happen any more, but there should be a solution not a workaround.

  • the same thing has just started with my machine too.

    I have always used the Vista go to sleep / quick resume feature, but now it does not work at all.

    if I hit the sleep button, the machine shuts down normally, but when I go to wake it up, I get a small amount of hd activity and then nada. Just light 1, 3 and 4.

    the only way to get it to roll again (that I have found) is to pull the jumper and set it to clear, and then move it back. at that point you have to go into setup and tell it there is no floppy drive, and it isn't 2007 anymore.


    it's weird that it just started happening. I was wondering if the CMOS battery had gone, or if there had been a Vista update that upset it, but no ideas....


    any help?


  • any information on this?

    it is very frustrating, and I am not sure why it would start happening.

  • Well here it is 2012 and in June the same issues have suddenly occurred with my XPS 420.  Been great until this started.  I've noted many problems in this regard to sleep and hibernation issues but with no luck on fixes. Once it goes to sleep, I cannot wake it without a hard reboot from the power button.  I've tried everything, drivers, upgrades, bios, etc.  terribly frustrating and little help posted on Dell or MS sites.  A solution is being sought prior to buying Apple.