Disable Intel Boot Agent Help - General Hardware - Desktop - Dell Community

Disable Intel Boot Agent Help


Desktop computer Forums (Audio, General Hardware, Video)

Disable Intel Boot Agent Help

  • Long story short, Dell in home tech came today to fix a video card problem but showed up without the replacement card. He had a new motherboard which was for further troubleshooting if the new video card didn't work.  So he replaced the motherboard and kept the exisitng NVidia card and, of course, it didn't correct the video card issues.
    So here is my new problem.  Now when the computer boots, I get this Intel Boot Agent that is scanning for DHCP.  Needless to say it's annoying.  I've used the search button and haven't yielded any results.  I've gone through the Bios settings and I made sure that I don't have the "IBA..." selected anywhere.  My first bootable is 1: removable, 2: hard drive, and 3: is cd rom.  I see in my options that the IBA is there but I haven't selected it.
    How do I disable this Intel Boot Agent that is scanning for a DHCP?
    Let me know if more info is needed.  Please dumb it down because I'm not uber computer savy
    Thanks, Tom.
    My setup is: 1 Week old Vostro 400
    Vista 32bit Premium
    BIOS ver. 1.0.10 just DL'd from Dell Previous ver. 1.0.3
    Intel Core 2 Duo E6550 2.33Ghz
    2gig Ram
    Integrated 10/100 NIC just DL'd drivers from Dell
  • One suggestion..... go into your BIOS Setup and look in the Integrated Peripherals sub-menu.  See what the On Board LAN Boot ROM option is set for.  If it is enabled then try disabling that option.
  • Majestic, thank you very much. That was exactly it.  Once I did what you said, I then had to make another change to tell the BIOS that I didn't have a floppy drive.  Now it starts up w/o all of that extra garbage.
    Thanks again.
    Tom C.
  • I have the exact same issue on my Vostro 200 Slim Tower. Dell replaced my motherboard and now the Boot Agent looks for DHCP and delays my start-up significantly.

    Unfortunately, in my case, disabling the LAN Boot ROM does not stop the Boot Agent. Any other ideas?
  • Mayhemm,


    Have you checked the boot order to make sure Legacy Lan isn't listed.  Also try disabling the option for Boot Other Device.  Both those options are listed under the Boot Device Configuration sub-menu.

  • Yep, unfortunately I've tried that already.  My boot order is as follows:


    First Boot Device:  [CDROM]

    Second Boot Device:  [Hard Disk]

    Third Boot Device:  [Disabled]

    Boot Other Device:  [Disabled]


    I don't have a Legacy LAN option but I do have something called IBA GE Slot 00C8 v as an available boot device.  It's not enabled, though.

  • Mayhemm,


    The only other thing I can think of is check the Remote Wake Up option and try turning it Off.  That option can be found under the Power Management Setup menu of the BIOS.  It's a long shot, but maybe it's having an effect on the boot up.

  • Tried that already as well. At this point, I don't think it's going to be anything logical. I guess I'll have to call Dell and listen to them give me the same advice you did so I can get it serviced. Or perhaps I'll just leave it since all it does is slow my startup.

    Thanks for the suggestions anyway, Majestic.

    One more thing; if it is a glitch, could it possibly be fixed with a BIOS update? I'm running version 1.0.5 because that's what came on the new mobo, but the current version is 1.0.11.
  • Mayhemm,


    I was doing some thinking, which can be dangerous on my part and I thought of a few other things to try or check. 


    First, go into the system and make sure the hard drive is plugged into the SATA 0 port.  Since you had someone working on the system, he or she may have plugged the SATA drive into another port besides 0.  If so, this maybe causing the system to have a delay in finding the drive on another port so the Intel Boot Agent is then kicking in.  Click here <ADMIN NOTE: Broken link has been removed from this post by Dell> for a diagram of your system's motherboard from the on-line Service Manual.  The diagram notes the location of Port 0. The motherboard should also be labeled accordingly in small print.


    Secondly, try changing the mode of the USB Device Setting option in the BIOS.  That option can be found under the Integrated Peripherals menu.  Try another setting besides High Speed.  My reasoning is that system maybe hanging on a USB device during boot up thus causing the Intel Boot Agent to kick in.


    Thirdly, try clearing the CMOS.  It's possible there was a option set in the BIOS prior to the motherboard being placed in your system that your system doesn't like.  Click here <ADMIN NOTE: Broken link has been removed from this post by Dell> for instructions on how to clear the CMOS.  Chances are if you call tech support they will have to do it anyways.


     Keep in mind that clearing the CMOS will default all your BIOS options back to their factory recommended settings.  Not really a big deal since you're probably using most of the factory settings anyways.  The defaulting will require you to re-enter the time/date, re-adjust your boot order if you have made any changes, re-adjust your power management options if you have changed them, etc.  In otherwords settings that were changed to your personal liking will have to be re-set.  If your system doesn't have a floppy drive the defaulting will turn on the floppy drive controller.  If this happens and you get a Diskette Drive error on boot up then simply go into the BIOS and turn off the option for the Diskette Drive.  The error message will be gone on the next reboot.

    Lastly, if there is such a word, I would try a BIOS update.  Although there isn't anything listed in the file description related to a fix for your problem, it is not uncommon for a BIOS update to have undocumented fixes and improvements.  If anything the BIOS update will help rule out an out of date BIOS as being the cause.  Prior to doing the update you should closed out all unneeded Window applications and unplug all unneeded USB devices.  This will lessen the chance of the update hanging during the reboot phase of the upgrade.

  • Alright, here we go...

    I opened up the PC and verified that my boot drive was plugged into SATA 0 and it was. My second hard drive was in SATA 1 and my DVD drive in SATA 5, just for reference.

    While I was in there I reset the CMOS. I know it worked because the date/time reset to sometime in 2007. The PC started up as soon as I plugged it in, so I did not get the chance to adjust the USB settings right then (the BIOS passed before I could get back to my keyboard), but at that point I discovered the Boot Agent was still triggering.

    After booting into Windows, I restarted and changed the USB setting from High Speed to Full/Low Speed. I also verified that all the settings you mentioned earlier, such as the LAN Boot ROM, were configured correctly. However, the Boot Agent still appears.

    I guess the only thing remaining is to update the BIOS and hope for an undocumented fix.

    Am I right in assuming that the Boot Agent is a BIOS-only application?  That is, no setting in Windows (like a bad driver or setting) could trigger it?
  • Just a little update...

    Flashed the BIOS to 1.0.11 but that blasted Boot Agent is still coming up!

    Do you know how to disable the Dell logo so one can see the POST information at startup?  I saw a flash of a screen where it said something was not installed but it was only there for a split second.  If the Dell screen wasn't there I could probably read it better.  Maybe this thing is causing the problem?
  • Mayhemm,


    The Intel Boot Agent is tied into the BIOS so there is no setting in Windows to eliminate the problem.  Intel does offer a utility to disable the Boot Agent, but from reading the utility's description it doesn't apply to your system.  With a system like yours, Boot Agent must be configured in the BIOS.  You can click here for the Intel Utility I am referring to.


    As for the Dell logo splash screen, your model's BIOS doesn't offer any options to disable Fast Boot or Quick Boot so that the BIOS boot up screens will appear.  A few things to try.......   on the older Dell systems, if you pressed the ESC key during boot up it would minimize the Dell logo so that you could see the boot up display.  Give it a try.  Not sure if it will work on the newer models.  Secondly, try tapping the PAUSE key when the screen displays the error message about something not installed.  On a lot of systems the PAUSE key will stop the boot process and allow you to see the boot display screen.  Once paused, just press any key to continue the boot process.  Thirdly, you could also try changing the option for Halt On that should be listed in the Standard CMOS Features sub-menu of the BIOS Setup. There is one setting for halting on all errors that may display the error message.  


    What PCI cards do you have in the system?  My thought is something maybe causing a boot delay so that the Intel Boot Agent kicks in.  Try booting without any cards installed.


    You mentioned two SATA hard drives, are these setup as a RAID operation?  Are all the drives shown in the BIOS setup and the SATA HDD Auto-Detection option set to Auto.   If you don't have a floppy drive then make sure the Onboard FDC Controller is disabled.

  • Sorry for the long reply time, but I was out of town on business since Friday. Anyway, I'll get to the point.

    I tried your suggestions regarding extending bypassing the Logo screen to no effect. However I was able to use info in the link you provided to extend the Boot Agent screen by using CTRL-S. I think I have identified the thing triggering the Boot Agent.

    Before the Boot Agent initializes, the PC displays the following:

    "AHCI Option ROM (I don't recall the version)

    AHCI BIOS not installed!

    Then the boot agent starts.

    Just to be thorough, I don't have any PCI cards installed. My hard drives are not RAIDed and they are set to Auto Detect in the BIOS.

    The question is why the PC is searching for AHCI when it doesn't support it?
  • Mayhemm,


    Ah, you maybe on to something.  :smileyhappy: 


    Go into your BIOS Setup and look in the Integrate Peripheral sub-menu.  There is an option for SATA Mode.  Check to see that this is set for IDE.   

  • The SATA Mode is indeed set to IDE.