How do I configure PCI parallel port in BIOS? - General Hardware - Desktop - Dell Community

How do I configure PCI parallel port in BIOS?


Desktop computer Forums (Audio, General Hardware, Video)

How do I configure PCI parallel port in BIOS?

  • Having problems with printer compatiblility after installing PCI parallel port card since the E310 is coming without printer port(very smart...).
    Found a recommendation to change port mode to ECP from parallel.
    Where in BIOS do I find value for installed parallel port? Drivers work OK and the printer actually works. People keep refering to CMOS or BIOS but I don't see my port there. There is also no scroll down menue available in Device Manager.
    I have Dimension E310, running Windows Home Edition.

    Parallel Port details:
    Koutech Singel Parallel PCI (ECP/EPP/SPP)
    PCI Bus Single (1) 25-pin Enhanced Parallel Port (EPP)
    Easy jumperless Plug-N-Play installation automatically configures itself for a free PCI I/O address and IRQ level
    Software configurable for standard ISA legacy LPT addresses (3BCH, 378H, and 278H) for backward compatibility with legacy parallel port peripherals (e.g. ZIP?drives)
    Up to three (3) times faster data throughput than comparable ISA bus or motherboard parallel port
    Fully Plug-N-Play compatible
    Fully supports Enhanced Parallel Port (EPP) standard
    Fully compliant with PCI 2.1 specifications

  • If the parallel port did not come with the computer, then there will be no settings in the BIOS for the port.  You must have added some software for the card that adds BIOS extensions.  Look there.


  • Emailed the manufacturer since this port came with driver CD only and no software. Will post again when I hear back from them...
    Thanks for your clarification.
  • I too have installed a Koutech pci parallel port in a 9100, installed the driver and it worked fine with a HP inkjet when needed.  If you receive a useful reply from the mfg. I'll be surprised, but here's hoping . . . 
  • Port manufacturer replied that there's no way to change anything and Windows will choose port mode depending on printer mode.
    Meanwhile I solved the problem by changing LPT port properties to LPT1 (used to be LPT3 when installed).
    I also changed properties from "never use an interrupt" to "use any interrupt" and checked "enable legacy plug and play ...".
    After that I reinstalled Jetsuite - software for HP printer and restarted.
    The Found New Hardware wizard did not appear this time.
    I think HP printers are looking for LPT1 port only. I am not professional in the field and educated people will correct me if I said something funny.
    Anyway, problem solved.
    Thanks to all!