USB/PS2 Mouse doesn't work - General Hardware - Desktop - Dell Community

USB/PS2 Mouse doesn't work


Desktop computer Forums (Audio, General Hardware, Video)

USB/PS2 Mouse doesn't work

  • I have an optiplex gx270 with windows xp pro. I have a usb mouse that came with the PC. I have tried to install the mouse on the PS/2 port with and adapter but it doesn't work. I have upgraded the BIOS and re install the software but it still doesn't work. I have checked the cmos settings and the mouse port is ON.
    Any ideas?

    Any help would be appreciatted.
  • There really isnt such a thing as a universal PS2/USB adaptor.

    Its best to get mice that have the adaptor with them in the box.

    For example

    I have 3 USB mice that have USB to PS2 adaptors.

    1 Logitek
    1 Microsoft
    1 Kensington

    The PS2 to USB adaptor for each mouse LOOKS the same but will only work with the mouse that it came with.
    You cannot swap the adaptor from the logitek to the microsoft nor the kensington even though it "fits" it does not electrically operate or work the mouse. They even light up as they are all optical mice but that does not matter as they do not communcate with any mouse except the one they were made with.

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • Whoa! I didn't this was the case.
    I have plug in a regular ps/2 mouse on the PC performed a cold boot and it still didn't work!
    When I go to the the mouse doesn't show.
    Thanks for the information/help.
  • Check your motherboard . A lot of the GX270's have defective motherboards. If the capacators infront of the processor has an 'X' stamped on the top it could be a bad one. We replace at lease one every week.