F2 doesn't get to Bios. F12 doesn't get to boot menu. - General Hardware - Desktop - Dell Community

F2 doesn't get to Bios. F12 doesn't get to boot menu.


Desktop computer Forums (Audio, General Hardware, Video)

F2 doesn't get to Bios. F12 doesn't get to boot menu.

  • The opening screen on my new 4600 says F2=Bios and F12=Boot Menu.  However, holding either down before or after I get to that opening page doesn't get me anything but a bunch of beeping.  F2 sometimes gets me a blank dead black screen and then I have to do alt-ctrl-delete to restart.


    Any advice?




  • You shouldn't have to hold the key down. Wait until the keyboard resets (you should see the lights flash), then press either F2 or F12 once. If you press F2, you should see a message on the screen that says it is entering setup. If you press F12, the system should beep once. If you press the key before the keyboard resets, it won't work, and it might lock up the keyboard.
  • Thanks for answering, Duhhhhhh.  But I still just get a black screen.  It looks as if the screen does change, so it's more midnight grey than black, but then it just sits like that and nothing happens until I press ctl-alt-delete and the boot process continues so Windows loads.

    My keyboard is the free one that arrived with the machine.  It's a stand alone 4600, Win XP Pro, can't think of any reason I'm locked out of the bios.

    I'm getting to the point where I want to drive a tire iron through it just about now!  Between that and the slow modem, this is NOT a fun new-machine-experience I was looking for.

    Thanks for any advice,


  • When you press F2, you see a blank screen - is there a blinking cursor in the top left corner? If so, let it sit there a while (a few minutes). There may be some kind of error that stops it from going into setup right away - if you let it sit, the error may time out, so you can get into setup.

    Has this been happening since you got the computer, or were you originally able to get into setup?
  • Thanks for coming back, Duhhh.  No, there's nothing blinking, just a dark screen.  And I've waited as long as two minutes, several times, hoping something would happen.


    The keyboard lights up as soon as the machine starts to power up.  Then it lights up again when the Dell screen comes on and shows the F2=bios and F12=bootmenu, up in the right corner.  I've tried pushing the function buttons right after the first light-up of the keyboard, and I've tried doing it after the second light-up..........I've tried every combination, and alone, and rebooted between each trial, as if I were a scientist testing the variables.  The one beep happens after I click on F12, but then it's just like when I click on F2.......very dark screen that sits there forever, until I push alt-ctl-del.  This machine was delivered around 3 p.m. last friday, and shortly after that, I tried to get into the bios and the boot menu.....just part of my routine when learning a new machine and a new os.

    Thanks in advance,


  • Definitely weird. After the second flash is when you should press the key. Since it beeps when you press F12, that means the BIOS is seeing the key press. I wonder if the video is just not displaying setup. Here's a way to find out. If you boot your system with a floppy in it, does it boot to the floppy? If so, great - that means floppy is set as the first boot device. Leave a bootable floppy in the drive and turn on your system. When you get the message, press F12. You should hear the beep. Wait about 15 seconds after the screen blanks, then press 2 and ENTER. That will tell your system to boot the hard drive instead of the floppy. If it boots the HD, you'll know that the BIOS is working, but video is dead. If this test doesn't work, it means the problem is deeper than a video problem. Let me know what happens and I'll try to help you take the next step.
  • Swell!  I couldn't think of even one reason I would need a floppy drive.  I don't have one. When's the last time you used yours? 

    As for this being a video problem, wouldn't such a problem have symptoms elsewhere?  How could it display everything EXCEPT the set up and boot menu.  Rhetorical question.......I'm no techie.  But I know enough to want to access the bios and the boot menu.




  • Do you have a USB keyboard?  If so, try borrowing a PS/2 keyboard and see if that will get you into the BIOS setup program.


  • No, my keyboard is the ordinary one that comes with a Dell machine.  I put an optical mouse on this afternoon, and now I can click on F2 and the screen says "Entering set up", but then it goes dark and does nothing.  I left it for 5 minutes to see if something would time-out, but it's not happening.  Before the optical mouse, I was just using the mouse Dell sends with all their machines.

    I'm looking for clues but am not tech-savy enough.......  I ran Spybot, which uses sytem Internals, and it named some files that it says have  "wrong app path".  One of those is  "Windows Registry: setup.exe"  I'm not sure how it got a wrong app path or how to give it a right one or if it matters anyway or if it has anything at all to do with the bios.

     Just got advice from Tech support to do a flash bios, to try and solve the problem.  I've never been a flasher........is this complicated?  Since the bios is May 2003, I wouldn't think I need a new one already.  Besides, isn't that something they do before they ship?  Would you recommend doing that?



  • Not having a floppy doesn't stop us from doing the test. You have a CD-ROM, right? Do you have a bootable CD? If so, insert a bootable CD and start your system. Press F12, then wait 15 seconds. Press 3 and ENTER, and your system should boot the hard drive. Press 4 and ENTER and the system should boot the CD. If this works, then we know your video is messed up. If it doesn't boot, then we can look for something else.

    Here's another test you can do. Boot your system, and press F2. Wait 15 seconds. If you're in SETUP, but you can't see anything, we can make the speaker beep. Press your NUMLOCK, CAPSLOCK and SCROLL LOCK until all 3 lights are on, then press ALT-E. You should hear a beep after a second. If so, press ESC and the system should reboot. If it does all this, I'm pretty sure that your system's video is busted.

    Why do I suspect video? Because SETUP and the BOOT MENU use the old TEXT MODE video (mode 3). That mode isn't used by Windows (unless you press F8 at boot to get to the windows boot option screen). I have no idea why mode 3 wouldn't work, but nothing else makes sense either.

    Flashing the BIOS would only help if there were some really weird corruption to your non-volatile memory (something that the CRCs didn't catch, which is doubtful). I don't think it'll hurt, but if you can prove that mode 3 is blank, you may have a lot more success dealing with tech support.
  • Thanks a bunch!  While I'm doing the other stuff you recommend, could you answer maybe-stupid question?  I'm not sure what you mean when you say "busted video", but I have a new flat-panel Proview monitor on this machine, and a new Dell 17" monitor on my year 0ld Dell Dimension 4400.  It's (tight space, short cables, etc.) to get behind the CPU and undo all the cables etc., but if you think it would matter which monitor I'm using, I'll move this machine to the other monitor(it's in another room so have to swap the whole set-up).



  • I'm guessing that any video failure would be on your video adapter, not the monitor. What video card did you get with your system? You could try a different monitor, but I don't think the results would be different (it might be information that tech support would want to hear, however - the more info you have, the easier it will be for them to diagnose the problem).
  • I booted, pressed F2, num lock light was on, waited 15 seconds, pressed capslock and scroll lock so all 3 lights on, pressed alt-E, beeps didn't stop until after I pressed ESC and windows began loading.

    Did this 4 times, fiddling with getting all 3 lights on at once, since num lock is already on and turns off if I press all 3 buttons at once.

    Meantime I also tried booting and then pressing F8.  Got the same dark screen that sits and does nothing.

    Does this tell you anything?

    I don't have a bootable CD, and no floppy drive of course.  But I start a new job tomorrow and am supposed to be loading all the prerequisites on my machine today.....don't have alot of time to learn to make any CD, let alone a bootable one.  I've never burned a CD before.  Wouldn't it be faster to just wipe the hard drive and start over?  Hmmmm, but can't do that because can't get to the bios to change it so system will go to the CD ROM first, right?

    If I thought flashing the bios would do anything, I'd go buy an external floopy drive....I assume there is such a thing....just to save time.  would that be faster than learning how to make a bootable CD, do you think?


    Sure glad you're here.  thanks for the help.  REALLY don't want to box up this whole mess and send it back to Dell if there's any alternative.



  • Video card is Dell's NVIDIA GeForce4 MX 440 with AGP8X .

    Is there any other way to tell if that is the problem?

  • Duuuuuhhh!, many thanks for all your help.  Turned out my ProView monitor is a wonderful thing UNLESS I want to view the bios and/or boot menu.  Switching to the cheapest Dell monitor in the valley did the trick.

    You taught me so much, while researching this problem......I'm gonna learn how to make a bootable CD before this day is finished, just for starters.

    Thanks again,