Disable Speaker Optiplex 9020 - Audio - Desktop - Dell Community

Disable Speaker Optiplex 9020

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Disable Speaker Optiplex 9020

This question is not answered

Hello, we installed Windows 7 Professional on our Optiplex 9020s. Whenever a user inputs a headphone, into the front Headphone jack, the audio works fine (it will only play from the headphones and not the internal speaker - as it should). When we unplug the headphones from the jack, the internal speaker plays the audio then. Is there a way to permanently disable the internal speaker without cutting/disconnect it from the Motherboard?

I've tried the following:

Disabling the device (found in Control Panel > Sound) - This also makes the headphone input disabled.

I've tried

  • Open Device Manager
  • In Device Manager click View and click "Show hidden devices"
  • This should make "Non-Plug and Play Drivers" visible in Device Manager.
  • Expand Non-Plug and Play Drivers by clicking the plus and double-click Beep.
  • Within the "Beep properties" window click the Driver tab.
  • Under the driver tab if you wish to temporarily disable this device click the Stop button. If you wish to permanently disable this device under the Startup Type select Disabled.


Any other suggestions would be helpful. Thanks in advance

All Replies
  • The easiest way to resolve this is to simply remove the speaker.  Select your correct form factor from the list of manuals below and then look for the section titled "Removing the Speaker."

    www.dell.com/.../manuals

    Tested this just now with successful result

  • Also looking for this.

    The CCTK doesn't seem to be able to touch the internal speaker setting in the bios, which probably would have been the easiest solution.