2nd HDMI does not work - Realtek soundcard on Inspiron 580 MT

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

2nd HDMI does not work - Realtek soundcard on Inspiron 580 MT

This question is not answered

Hi

 

I have 3 HDMI ports on the back of my desktop, 1 works with a microsoft driver and under configure audio devices it only seems to register 2.0 sound. Although if I play a movie using SMPlayer its menu lets me select 5.1, but I'm not sure if that  I'm actually getting 5.1 through my Onkyo 5.1 AV system.

There are 2 more HDMI ports at the back, one had been blocked off by Dell, I assume this is because it isn't supposed to work, maybe it is blocked by the video driver as I read elsewhere. But there is a 3rd HDMI port which is slightly countersunk and just above the analog audio sockets however if I insert a hdmi cable it never registers, I'm not sure the cable goes in far enough to register it. In device manager it appears as another Microsoft driver hdmi port, in any case I can't use it.

If I plug a regular small audio cable in then I get to use the RealTek software to configure it but never for the HDMI which is what I want.

There is a RealTek 7.1 soundcard that came with the PC and a Video Card ATI Radeon™ HD 5450 1GB DDR3 graphics.

If anyone can help I'd be very happy

 

Regards

 

Steve

All Replies
  • Steve,

    With the video card installed, all of the HDMI ports built into the motherboard are disabled. So the HDMI port you see on the back I/O panel directly above the blue VGA port is a no go. There is not an HDMI port directly above the audio ports? I only see the onboard NIC and 4 USB ports.

    (Liaison for Desktops, Alienware, Monitors)
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?
    Drivers
    Order Status

  • I can use the one lower HDMI port, it carries video and I presume 2.0 sound to my AV via a Microsoft driver. This is the lowest port in the horizontal bay next to my monitor cable.

    The 2 HDMI ports don't work in the vertical section with black backing containing the realtek analog audio ports, network cable and USB sockets. Presumably as you say because of the video card. I find this very misleading of the design.

    I guess my question remains as I have one working HDMI port how do I get it to output 5.1 audio? Is it possible to disable my video card to achieve this? Not sure what this would mean, perhaps lower graphic res in games? Can I disable/enable the video card as I need it on a daily basis?

    Thanks for your time

     

    I've attached a photo to make things easier to see.

  • As Chris noted, you only have ONE active HDMI port and that is on the separate Video card.  The top HDMI port, if you were using Integrated Video is "Video ONLY" according to other posts on the forum and not both video and audio.  It was intended to provide Video to a montior that has an HDMI input. The port that is covered is a VGA video port, which would be used if you only had Integrated Video.  Thus the ONLY active HDMI port is on the separate Video card.

    As to why you are only getting 2.0 audio via the HDMI, depends on the sound driver for the Video card and the type of HDMI audio you have. Some video cards require an S/PDIF connection from the motherboard for audio and other cards generate their own audio (built on the video card).  Some S/PDIF outputs only supply 2.0 sound and not 5.1 sound.  The type of sound also depends on the source (e.g. if you are listening to a stereo audio file you may only get 2.0 or 2.1 sound).

    I'm not sure this works but give it a try.  With the HDMI cable plugged into the Video card, go to the Control Panel/Hardware and Sound and finally the Sound.  In the Playback section the HDMI should be set as the Default playback device. Click to highligh the device and then click the Configure button (this is the part I'm not sure works) and see if there is any options for the type of audio.

     

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  •  

    Thanks for the explanation, I tried in Windows 7 opening the HDMI audio device and 'configure speakers' but only get options for stereo with 2 speakers, it is using the Microsoft 3- Hight Definition Audio Device driver, not the RealTek. In contrast my PC speaker connected by regular 3.5mm jack gets the Realtek HD audio driver and options for 5.1 that it doesn't have.

    Can I use the RealTek driver already on my PC for the working HDMI port? or will the RealTek 7.1 soundcard that Dell supplied work only with the analog jacks?

    I don't have the S/PDIF option unfortunately and am testing with BluRay quality sound and 5.1 test audio files.

  • First, you must use the Dell RealTek sound driver as non-Dell supplied drivers will either not work or not work correctly.  Allowing Windows to install a sound driver is a "non Dell" driver.  The RealTek is not a "sound card" it's only a chip on the motherboard and yes, it ONLY works with the analog jacks on the motherboard I/O panel. 

    Depending on the video card you have, some have a sound chip built on the video card that supplies sound for HDMI and others rely on an S/PDIF connection to the motherboard for the HDMI sound.

    If you look at the Control Panel/Hardware and Sound and finally the Sound panel, in the Playback section you should have an icon for "Speakers" and it set as default playback device and this is your RealTek sound module.  When you plug in an HDMI cable you will see an icon for HDMI audio and in some model when you plug in a cable it will automatically select itself as the default playback device (and you will only get HDMI audio) or in some models you must manually select this as the default playback device to get HDMI audio.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • Yo so fireberd, what can I do about the speakers? Can I just reinstall all the drivers in the correct order?

  • Try installing only the Dell RealTek drivers and see what happens. 

    Worst case you can do a complete reinstall back to factory condition by using the Dell recovery partition - F8 at power on.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.



  • From what you are saying I can only get 5.1 audio from the analog outputs on my PC.

    So what I need are 5 x 10 metre audio cables with 3.5mm jacks to PC and S/PDIF jacks to AV receiver. Gonna need a wide bit of trunking to hide this against the wall.

    Regarding the HDMI connector, it works with the current driver well enough, I'm not going to get any real difference with a different driver, certainly not 5.1 which is my goal.

    Thanks for you help people, sorry it took so long to respond I've been busy at work and thinking about it.

     

    Steve

  • more precisely:

     

    On PC 3.5mm

        * Pink = Microphone In (mono)
        * Blue = Line-In (stereo)
        * Green = Line-Out / Front Speakers / Headphones
        * Orange = Center Speaker and Subwoofer
        * Black = Rear Surround Speakers (5.1, 7.1 systems)
        * Grey = Mid Surround Speakers (7.1 systems)
       
       
    to AV:
       
        S/PDIF
       
        2 audio in
        1 video in