IDT High Definition Audio Codec code 10

Desktop

Desktop
Desktop computer Hardware and Software discussion

IDT High Definition Audio Codec code 10

This question is answered

Hello,

I recently got a new graphic card (nvidia ENGT240) in my pc ( a Dell XPS 710)  and after i installed the card my sound stopped working.

And i got the IDT HD audio error message

Ive looked around for solutions but most of the posts were from 2007-2008, maybe if anyone got a more recent solution to this problem it would be great.

Verified Answer
  • HERE is the XP drivers.  Uninstall the IDT and Install the Dell SigmaTel or you MAY be able to just install the Dell drivers over the IDT. 

    SigmaTel was bought by IDT and about 1 1/2 years ago they dropped the SigmaTel name for IDT.  However, due to custom implementation of the chipset by the various PC and motherboard vendors, drivers from the PC or motherboard vendor is recommended. 

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

All Replies
  • That's a device failed to start error.  It could be caused by a conflict with the new video card.

    First thing, you have the "IDT" installed and it should be the Dell SigmaTel driver.  Usually the IDT driver, which is a much later driver or another non-Dell driver, does not work or work correctly.   Uninstall the sound in the Device Manager - RIGHT click on the entry for the sound and then LEFT click "uninstall".  Then restart the PC and when Windows starts it should detect and reinstall the sound. 

    If the reinstall does not fix it, check the BIOS (F2 Setup) to verify it's still enabled and did not somehow get disabled.  If it's enabled, the next step is to reinstall the drivers, but I would use the Dell provided drivers first.   You didn't include your OS so I can't link you directly to the driver, but HERE is the Dell drivers for the XPS710.  Select your OS (If you have Win 7 installed use the Vista 32 or 64 bit drivers).

     

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • Im running windows xp on this machine, and your link doesnt work. Can u maybe check it again for what driver i need?

    I uninstalled the sound and rebooted but it just reinstalled the IDT driver.

  • HERE is the XP drivers.  Uninstall the IDT and Install the Dell SigmaTel or you MAY be able to just install the Dell drivers over the IDT. 

    SigmaTel was bought by IDT and about 1 1/2 years ago they dropped the SigmaTel name for IDT.  However, due to custom implementation of the chipset by the various PC and motherboard vendors, drivers from the PC or motherboard vendor is recommended. 

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • thx so much it works now,i already tried that one driver from the dell site

    i probably did something wrong then but thx a bunch!

  • Thanks for the feedback and that it's working.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • I have a Delll Dimension  E510 with XP Pro  with Media Center 2005 and had to reinstall XP using a Reinstalation cd   with SP2. After  taken care of updating Windows and several devices' drivers, I still show under Device Mgr  a yellow ! for IDT High Definition Audio CODEC.

    Tried using Device Mgr to update driver , did not work. Then I  uninstalled it and then using Add Hardware to install, got a message  from InstallShield Wizard for IDT Audio, labeled Configuring  IDT Audio :  Exit Error=  Device Object not present; restart abd run setup again.

    Then, uninstall it and found a driver update on CNET ( IDTv087), downloaded and ran it and got same messgae as with InsallShiled Wizard - not present.

    I tried your link to Dell and was not able to locate a driver there at all.

    I tried directx disgnostic tool ( dxdiag) under START/Run,  and under the Sound tab, there is nothing ??

    So, I'm not sure if it is an IDT or as you mentioned,  a SignaTel.

    I would appreciate any suggestions to fix this item.

     

     

     

     

     

  • I have an E510, the integrated audio in the E510 IS the SigmaTel and not the later IDT.   The link I had was a 710 and not an E510 and can be a different driver. 

    You MUST use the Dell provided driver for it to work or work correctly.   Also the Intel Motherboard Chipset Drivers MUST be installed BEFORE intalling or attempting to install device drivers such as the sound or the driver install will fail. 

    HERE is the Dell E510/5150 SigmaTel Windows XP drivers.  (The 5150 is identical to the E510).

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.