Audio drivers for my Dimension E310

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Audio drivers for my Dimension E310

This question is not answered

I reinstalled Windows XP on my Dell Dimension E310 which is about five years old. There was no sound, so I downloaded Audio drivers from the Dell site.The STAC 92XX C-Major HD Audio does not work. The drivers I have downloaded are R114566, R114282, and APOSRC4. Can anyone tell me what else I need to do to get sound. I have installed a PCI sound card which does not give me very good sound. Help !!!!!

All Replies
  • Sounds like you skipped the Intel motherboard chipset drivers (an often skipped item) and they MUST be installed BEFORE installing the sound.  The chipset drivers are key to a successful install as one of the main things they do is define (identify) all the devices on the motherboard.

    On an install the correct and required install sequence is (1) Install Windows (2) Install Dell Desktop System Software (on applicable models), (3) Install chipset drivers (4) Install device drivers including sound, video, ethernet, etc.

    Usually, if the chipset drivers have been skipped you can install them, restart the PC and then install the sound drivers (in your case the SigmaTel drivers).  In a few isolated cases it will take a new and correct install sequence to get everything working.

    We are just users on here and referring to the Dell driver "R" number doesn't help us without a lot of research, as they are not listed that way on the Dell downloads.

     

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  •  I just reinstalled the chipset and audio driver. No result. Do I need to install the video and ethernet drivers too?

  • Yes to the Video and Ethernet drivers. 

    However, since the chipset and sound drivers did not fix the sound problem it would appear the entire install may be the problem and a new correct sequence install may be needed to get things going. 

     

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • I could not locate the ethernet driver. Can you please tell me where to find it and also you have indicated I need to install them in the corret order. What is the correct order and how many drivers do I need. I have chipset, audio and seven video drivers so far.

  • The chipset driver must be installed first.  There is no "correct" sequence for the other drivers.  I think Dell says install video then sound then other devices such as ethernet. 

    THIS is the Dell install instructions.

    HERE is the Dell downloads for the E310  the Intel Pro/100 ethernet drivers are listed in the Network section.  The Dell Drivers and Utilities disc that came with the PC has all of these on it.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • I was looking into getting sound back on my Dell Dimension E310 and I ran across the advice you gave the person who was looking to do the same. You seemed very knowledgeable , however I am not. At least not when it comes to computers.

    My situation is a bit different in that I bought the computer used from a repair shop in town  and the software did not come with it.  When I brought it home it was fine. I have had it several months. My daughter who fancies herself a genius was cleaning it up for me and uninstalled my sound.  I ran a diagnostic test on in. I have paid for a driver update service.(which I sorely resent) When I go to  sound device properties it reads that I do not have a device.  Where can I find the sound card or whatever it is called to reinstall?

  • I assume you have a Windows XP system. This problem was more prone for Windows XP. Windows XP has reached End of Life and you should proceed with care if using the system online as Windows XP is vulnerable.

    Install the Windows XP Sigmatel Driver:

    http://ftp.dell.com/FOLDER96136M/2/R171789.exe

    Driver identifier software usually doesn't work very well and consists of Malware. I advise uninstalling it. Be cautious with the programs your daughter used to clean up.

    I advise performing a scan with Malwarebytes' Antimalware:

    http://dellwindowsreinstallationguide.com/software-maintenance/malwarebytes-antimalware/

    Ultimately money would be better spent buying a Windows 7 32 Bit license than driver identifier programs and cleanup programs... The system needs to have at least 1 GB of RAM installed. Likely this system won't run Windows 8.1 32 Bit very well unless you upgrade the video card, see here:

    http://en.community.dell.com/support-forums/desktop/f/3514/p/19487987/20283594.aspx

    For instructions in installing Windows 7 see Windows Reinstallation Guide:

    http://dellwindowsreinstallationguide.com/a-clean-install-of-windows/

    Use the following drivers:

    http://dellwindowsreinstallationguide.com/driver-sets/dimension-desktops/dimension-3100e310-windows-7-32-bit/

     

     

    Philip Yip

     

    Windows Reinstallation Guide and Related Wikies See here for other wikies such as Customising and Using Windows 8.1, Dell Wireless Cards and Unofficial Drivers.