{MOVED}IDT High Definition Audio Bus cant start 'Code 10' - Audio - Desktop - Dell Community

{MOVED}IDT High Definition Audio Bus cant start 'Code 10'


Desktop computer Forums (Audio, General Hardware, Video)

{MOVED}IDT High Definition Audio Bus cant start 'Code 10'

This question is not answered


My pc crashed and I had to reboot including the sp3 for XP. Now Im getting a message of 'code 10' regarding the IDT audio. I have tried uninstalling and reinstalling the hardware but to no avail. Can any one help???


All Replies
  • Welcome to the forums Yes



    No matter what the problem is, when you're asking for help/advice, you should always mention what model system you're using (model/laptop or desktop), and what OS is installed Idea


    You mention uninstalling/reinstalling the hardware.  Do you mean physically, or via (i.e.) Device Manager?

    Did you also reinstall/update the audio drivers?  Check the 'Drivers & Downloads' section for your system on the Dell website, to make sure you have the latest drivers available.


    In the meantime, have a look at these articles relating to Code 10 errors:


    (Microsoft) Code 10 + (Microsoft) This device cannot start (Code 10) (scroll down to see the advice offered under Code 10)

    USB Code 10

    From experience, I've found that:   “Beauty is in the eye of the beer-holder”!!


    XPS M1730:

    Smoke Grey Magnesium Alloy Chassis - with White LED Backlights
    17" UltraSharp WUXGA Widescreen TFT (1920 x 1200) with TrueLife
    Intel Core 2 Duo Processor T9300 @ 2.50GHz (800 MHz FSB, 4MB L2 cache)
    4GB (2x 2GB) Patriot Signature PC2-5400 @ 667MHz
    DUAL 512MB Nvidia 8800M GTX cards in SLi + 128MB Ageia PhysX
    640GB SATA II (2x 320GB WD Scorpio Black 7200rpm)
    8x Super-Multi DVD±RW
    Creative X-Fi Notebook (ExpressCard) + Creative GigaWorks T40 Series II
    Integrated 2MP Webcam
    Dell Wireless 355 Bluetooth 2.0 Module
    Intel Next-Gen Wireless-N Mini-Card
    TV Tuner and Dell Travel Remote Control
    4-in-1 Flash Card Reader (SSD/MMC/MS Pro/xD)

    230W AC Adapter / 9-cell Lithium-Ion Battery

    Windows 7 Home Premium (64bit)

  • Cheers Fireblade,


    i did mention the system specs in the tag but maybe it doesnt show??

    I have a dimension 9150 running XP sp3. I used device manager to install/unistall the hardware. As for Drivers, thats what im looking for but couldnt seem to locate them as when I typed in my service tag it came back as invalid??!??

    I will check out the link in the mean time. thanks.

  • Part of the problem is you've got IDT drivers in there, which probably came from Microsoft's online database, not Dell.   The original driver is a Sigmatel, which is the one you need to use, not the IDT.  IDT bought out Sigmatel a while ago, but the drivers they've supplied to Microsoft's database generally don't work correctly on Dell systems.

    Since you just reinstalled XP, might as well get all the drivers (not just audio) in correctly right off the bat.   Often people miss the Desktop System Software (under System Utilities) and chipset driver (under chipset) that should go in first to properly configure the rest of the hardware.  If that's the case, there's no harm in going ahead and trying those now, though it may help to install them in safe mode to prevent any other drivers you've installed from interfering.   Oh - and on the drivers page you can just go by model number (9150) for drivers (though it will list all possible drivers, not just the ones specific to your tag).


    As for the audio itself, you need to try and get rid of the IDT and load the Sigmatel.    Download the Sigmatel driver package under audio (but don't run it yet), then uninstall the IDT from device manager (and under Add/Remove, if they show up in there).  Reboot, but do NOT let the add hardware wizard cronnect to MS to get drives or load up the IDT - install the Sigmatel you downloaded instead.  Hopefully it will then take properly.



    'Tis a poor carpenter that blames his tools.

  • Alexandra,

    Thanks for the advice. It was the driver and after I removed/deleted the IDT driver and replaced it with the Sigmatel driver that I downloaded  everything is fine.

    So thank you to you and FireBlade!!


  • Help.  I have followed these directions carefully, many times now, trying to get rid of the IDT audio and install the other.  I can't seem to get rid of the IDT.  It keeps looking to that, and doesn't give me the option of installing the other sigmatel referenced in this thread. 

    I haven't uninstalled it in the add/remove hardware because I can't see one labeled IDT.  There is another "High Definition Audio Driver Package KB835221"  listed but when I try to uninstall that one it says it will affect this huge list of programs.   Should I remove that package to uninstall the IDT?  It isn't working now at all, but I don't want to damage the system further!  

    Help!  I am working on a Dell Latitude D530.  The Control Panel shows "NO sound card installed".  Not a good thing!  Your help/advice is much appreciated!

    Also the link to the Sigmatel audio driver is NOT working today, says the webpage has expired.  When I do manage to get rid of the IDT, I need the Sigmatel driver to isntall.  Help!



  • This morning as I tried once again to install the Sigmatel driver it is saying the download doesn't exist.  Suggestions Please?


  • Smile-adventures:

    The "download doesn't exist" problem is often caused by trying to use the Dell Download Manager - it's caused a lot of trouble.   Instead, do this:   clear your browser cookies to remove the Download Manager option, and uninstall Dell Download Manager from Add/Remove programs (if it's there).   Go back to Drivers and Downloads, select the driver you want, select Download, then choose "Use Internet Browser", instead of the Download Manager.

    Beyond that,    instead of tacking your new laptop problem onto this old thread about a desktop, you'll have better luck starting a new thread over in the Laptop Audio Forum HERE.  When you do, you should include the following information:

    1) Did you reinstall the operating system, and which one is it (Vista or XP, and what service pack)?  If so, did you follow the recommended driver install order (notebook system software, chipset, then remaining drivers)?

    2) Be as specific as possible - for example, when you say "There is another audio driver but when I try to uninstall that one it says it will affect this huge list of programs", exactly what is the name of that driver?


    'Tis a poor carpenter that blames his tools.

  • I have a Dimension E520 running Windows XP that I also had to rebuild.

    I have this IDT error code 10 problem.  I have tried lots of the suggestions on this site with no change.  I uninstalled the IDT audio codec drivers, installed the chipset drivers and then ran the SigmaTel install that I downloaded from this site.  The SigmaTel driver install dies with an error that no audio device is found.

    I have seen hints in the forums that if you did not install the chipset drivers first you may have to start over.  Does this mean uninstall Windows again?  I'm at my wits end so if that is the solution I have a computer without sound that I will gladly give to anyone that wants it.  Smile

    I also saw a mention of installing the drivers in safe mode.  Would reinstalling the chipset drivers and/or the SigmaTel drivers in safe mode help anything?

    Thanks for any assistance.

  • thoan02 - rather than tacking your problem onto old threads by replying, best to start a new message in the Desktop Audio forum - just click "Post a Message" at the top:


    It may seem logical to reply to a thread that seems similar, but it actually isn't a good idea - problems are rarely the same, and it gets confusing with too many people in one thread.   Plus AZ78 and SmileAdventures are going to get email notifications of both your reply and mine, and they probably don't care to get them.

    'Tis a poor carpenter that blames his tools.

  • Thank you, thank you, thank you. My audio went out many months ago, so I finally got around to looking into it. Nothing worked until I uninstalled IDT and installed Sigmatel. Works like a champ.

    Thank you very much sir.