Error: "Windows Media Player encountered a problem while playing the file." [Optiplex 740] - Audio - Desktop - Dell Community

Error: "Windows Media Player encountered a problem while playing the file." [Optiplex 740]


Desktop computer Forums (Audio, General Hardware, Video)

Error: "Windows Media Player encountered a problem while playing the file." [Optiplex 740]

  • Whenever a DRM protected WMA is played via Windows Media Player 11, an error message appears after Windows Media Player opens: "Windows Media Player encountered a problem while playing the file.  For additional assistance, click Web Help."  [Close] [Web Help]


    I updated the audio drivers and rebooted.  No change.

    I found a possible solution that called for installing the "K-Lite" codec pack and uninstalling it, but no change.

    I re-registered every version of the XML.DLL that I could find, but no change.


    These same DRM protected WMA files play on several other computers (both XP and Vista), just not on any of our Optiplex 740 series computers running XP with SP2.  Seems to be a problem with the 740 series software loadout of Media Player.


    Any help out there?  Thank you!



    EDIT:  Is there a chance this is a Internet Explorer security issue?  Normally, Windows Media will open and then connect to the site and ask for a login (on a correctly working system that is).

    Message Edited by emtownsend on 05-21-2008 02:13 PM
  • This seems like it would be a MS WMA software question best answered over in their forums as it appears nobody here is willing to take a shot at it.  Try here as a start:



    Cheers, Dave


    ps, your message subject was too long, I had to chop part of it off in order to post a reply!

  • Thanks!

      I think you are right.  I "rolled back" to Windows Media 9 and all worked well.  I re-upgraded to version 11 and it stopped working again.  Seems that this is a Dell specific problem though as we have a number of Optiplex 740 machines, none of which can play these DRM files.  Other machines that are not Optiplex 740's play the files just fine... So, this is a problem with Dell's implementation.  I may have to give them a call on our support plan.  I was just hoping this was a known issue, but it looks like it is not.

      For what it is worth, I tried all the Microsoft recommended fixes, none of which worked.  I do get closer to opening the file however.  Now, it does prompt me to login to get the license, but then responds back with, "A problem ocurred issuing a license on your machine"...

      I'll post once I find out a fix!

    Message Edited by emtownsend on 05-22-2008 03:04 PM
  • Well you get a "hummmmmm" out of that problem.  (That is what I do when I find an interesting problem like, haven't seen that one recently!)


    For sure let us know what you find, and mark the thread solved if you do find out a cure!

    Cheers, Dave