no audio on Dimension 5150 after reformatted to XP Pro - Audio - Desktop - Dell Community

no audio on Dimension 5150 after reformatted to XP Pro


Desktop computer Forums (Audio, General Hardware, Video)

no audio on Dimension 5150 after reformatted to XP Pro

  • I had Win Home edition and reformatted to computer. I upgraded to Pro, and realized that some devices were not properly installed. I have no audio, and i have downloaded EVERYTHING out there that can be downloaded and it is still not working. I have installed the intel chipset and everything. Do i have to reformat and install them all over again in some sort of special order? 
    On the device manager, i have two items unrecognized. a PCI and a USB Controller.
  • Hey man,
    I have a very similar problem yours...
    When you try to install the Sigmatel Audio driver, are you able to install it without a problem?
    If you go to the Control Panel and look up the Sound and Audio properties, is there a device installed?
    What type of card do you have?
  • hey,

    apparently, i dont have a sound card, the audio comes integrated... but i did try to install sigmatel and it didnt work. im not sure what i have to do next.... maybe i should just reformat the whole thing again :(

  • oh, and no, in the control panel i dont have an audio device installed. could it be that XP Pro is not compatible with Dell's integrated audio (??)
  • Kind of the same thing happened to me - I've set up new speakers and now no sound.  I'm :womanmad:
    went to check up in the control panel (sound/audio) guess what - no audio - tried to download the audio drivers - but unable to install.
    phoned the dell tech - they were closed - what do I do now??

    double help
  • jimcostarica: reformatting again wont do much good, and so I wouldnt bother.
    Could both of you specify the exact message that you get when you are unable to install?
    In my case, I seem to be able to install, but after I reboot and the setup loads again I get the error message.

    It'd be nice if someone with some more expertise could contribute... luck!

    -- Jake
  • when i try to set up the new driver, after it's installation, i'm told that there are no components.

    by the way i'm shocked as to how many people have a problem with the sound/audio with this dimension. :womansurprised:

    Message Edited by rrratze on 05-16-200607:18 PM

  • what is your exact error message?
    also, go to the device manager and check if there are any "sound" entries with a yellow ! next to it...

    ur right about the number of people with this problem, mabe we ought to send dell some sort of email complaining
  • thanks - there are no sound entries with a yellow "!" in the device manager.

    the msg reads:-  devise object not present, restart your computer and try to install again.

    I think the soundcard has disapeared - don't ask me how or even why

    I am  soooooooooooooooooooooo angry  -  i can't wait to call them tomorrow and give them a proper ear bashing. 

    the p.c. is not even a month old yet.

    thanks for your reply - let me know if there are any updates/news. :smileywink:

  • Hi jmcostarica

    I did a reinstall yesterday on a brand new Dimension 3100 because of Sigmatel audio problems with on board sound which made no difference. After reinstall the drivers should be installed in this order according to Dell.

    1. Chipset driver
    2. Video driver
    3. Audio driver
    4. Network adapter driver
    5. Modem driver if required.
    6. Other required drivers. like TV tuner card
    After doing this I returned the PC for refund and it is becoming more evident each day that there are serious issues regarding Dell computers and this Sigmatel codec. It does sound as if you may have a further problem with regards to your issues as most people report suspect sound devices not USB problems. I haven't heard of this except on Windows XP versions pre- service pack 1. In other words if it is an old version before SP1, it required this udate to support USB 2.0 or something.

    Sounds like you need help from an exprt which I am not? Good luck to everyone here with problems

  • ok, thing is... when i reinstalled the drivers, i didnt follow a specific order or anything...b/c i didnt know... anyway, after i reinstalled them, i was able to have everything up and running... but no audio. so i downloaded the audio drivers again, but they are useless b/c there's not a sound card in my PC. I tried installing the chipset again, and it requested a usheb(something).sys that other USB controllers have, but the computer was unable to locate them. When i browsed for the .sys myself, the PC still wouldnt recognize it and now everytime i turn my computer on, it tries to install the freaking USB controller. Its actually driving me nuts. Also, i went from a Home edition to a Pro edition, and i dont know if that has something to do with it also. Apparently i have a "unverified windows xp edition" which i didnt know by the way, so i cant install the SP2 update on my computer. Could that be whats keeping my computer to have the audio working? Maybe i should just buy a new soundcard and get it over with.... what do you guys think? ;)
  • I think the driver install order is relevant, but when you have a problem driver you can always reinstall it without uninstalling all the others. All I know is the chipset one goes in first, the rest usually go in the order in my post on page 1. As for you needing an audio driver, although you have no card, one is required for the onboard audio. So you will need to find out what that driver is and install it, or you could buy a card and disable onboard audio in the BIOS. While you are it you should maybe buy a genuine copy of XP pro. You can get it cheap these days and remember you'd be burned alive for using a counterfeit by Microsoft if they could get away with it, but I don't think this is causing your problem. But could it be a pre SP1 disc? Again as I said in the other post I've seen USB contoller problems on XP without SP1 not SP2. Installing SP1 solved it.
    You need answers that the experts here have, maybe they aren't helping you cause they are ethically bound not help people with 'dodgy' windows. Buy a real copy and try again. You might get their help.
  • ok so now - just came of the phone with a dell tech - and yes there is a fault the my sound card.

    the pc is being collected on friday - kept for 5 days - and fixed.  i was assured to receive a new motherboard and of course soundcard.

    i have to say thought - very polite techs -

    hope everybody is well - and - i still think there are an awful lot of audio probs happening with this sigmatel soundc.  must be a really cheap version.


    Message Edited by rrratze on 05-17-200602:33 PM

  • Hi all

    Read true and till the end, it should help many...

    I fixed my problems with my new dimension 5150 audio and the sigmatel high definition audio driver by doing the following....

    I had just installed a new xp pro partition with no sound.....

    1. I downloaded the sigmatel high definition audio driver from here..

    If the link changes you can find the driver on the dell site by going to driver downloads and specifying the dell domension 5150 model. Then click on audio drivers. The driver is called.....

    "SIGMATEL STAC 92XX C-Major HD Audio".

    2. I downloaded the driver to the desktop...Ran it and it asked for a reboot. Rebooted but still no sound but then the driver package popped back up and tried installing more drivers before telling me that this driver was not suitable for my hardware so i clicked OK.

    3. Oh well i thought, back to the drawing board. However i checked device manager to find that my sigmatel high definition audio codec had been installed for the first time. (progress).

    4. Then in device manager i right clicked and chose scan for hardware changes. The "found new hardware" wizard popped up telling me it had found the "microsoft UAA  bus driver for high definition audio" and i just used the automatic search for driver option in the found new hardware wizard - Hey presto both the sigmatel high definition audio codec and the Microsoft UAA driver for high definition audio were installed and i have sound.


    The bottom line with dimension 5150 systems at least is to download the above driver, install it, reboot, wait for the error stating that the driver is wrong for the system and then click ok. Then in device manager right click the top icon and choose "scan for hardware changes", the microsoft UAA high definition audio device is found and asks for you to install the driver. At this point you can select to search for the driver automatically and it shall install it. You now have all the sound you need!

    It seems that when you run the above driver it installs correctly before rebooting, after the reboot it tries to install additonal drivers that are not required or suited to the system. Click ok but at this point you have the driver for the "sigmatel high definition audio codec" installed....Then in device manager scanning for hardware changes triggers the system to find the "Microsoft UAA high definition audio" device. This in turn asks for you to install its driver which at this point can simply be installed automatically using the found new hardware wizard.

    Phew, great it all works now...

    I am away to image the thing now with the best imaging software out there, acronis true image..

    Hope this helps you

    Kind Regards

  • Hey man,
    Glad to hear your sound is fine!
    I tried doing as you said... but had little luck.
    I installed once again and the rebooted and go the error message. Then I went to the device manager and tried to scan for changes. It did a sort of "refreshing" and did a "Scanning Plug and Play compliant hardware" and then didnt find anything new.

    Under the soud, video and game controllers I have Audio Codecs and Legacy Audio Drivers... but I see nothing that you saw.

    Is my scanning for hardware even right (Scanning Plug and Play compliant hardware)
    Could you be specific about anything else... where did you find the Sigmatel codecs installed and everything..

    Thanks a lot!