sound is garbled in windows

Desktop

Desktop
Desktop computer Hardware and Software discussion

sound is garbled in windows

  • My speakers sound just awful. I have two pair. One set is the default set that came with my 3000, and the other is from my old system. They are Altec Lansing. When I ran the diagnostic on the computer, the computer played both sets as they should be. As soon as Windows boots up, they skip and scratch and sound horrid. Tech support had me running around in circles for about a month until they finally said it's not a hardware issue. I know the computer itself will play sound fine, but Windows is butchering my sound quality. If anyone has any ideas out there, I sure would love to hear them.
  • Please tell us whether you have integrated sound from the motherboard or a separate PCI sound card and if so, which make and model.  If you don't know, navigate to Device Manager, Sounds/Video/Game Controllers and click the plus sign.  What is listed there for sound devices? Are there any yellow exclamation points on any items?  How does an audio CD sound?  How about sounds from a game, if you play games?  If you have a DVD drive, how does sound from the DVD movie sound?  Giving all the info you can will help with a diagnosis.
  • In addition to info Europa303 requested, tell us what brand hard drive you have (eg, Samsung, Western Digital, Seagate). You can find that info in Device Manager too.

    And while in Device Manager, expand the list under IDE ATA/ATAPI controllers and double-click on Primary IDE Channel. Then click Advanced Settings tab. Tell us what it says for Current Transfer Mode for both device 0 and device 1. Do the same thing for Secondary IDE Channel.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I also have been having the same problem on my Dimension 5100 with the audio card, I am using a soundblaster 24 live. I have tried 2 set's of speakers, one old pair of Altec Lansing with a sub, and the cheapo dell's that came with my Dimension. I know the speaker's work as I hooked them in the headphone jack of my boombox, and they sounded great, boy if I could only get that sound quality out of my computer now. I am past my warrenty period so I went out and bought another soundblaster 24 live card and replaced it, the sound came back but I can't turn up the volume without alot of distortion and hissing, All my of diognostic testing say everything is running correctly, HUH. I beg to differ, must be a default message?  I have uninstalled all the driver's and software and updated with the newest driver's from Soundblaster. I did call creative labs but got more Bull. They were useless. Thats a whole nother story. Well I looked up my Primary IDE controllers and I have the following:

    Primary  Device 0 ultra DMA mode 2

                   Device 1 Ultral DMA Mode 1

    and on my other primary controller

                  Device 0 Ultra DMA Mode 5

                  Device 1  Not Applicable

    I am also using a western digital HD 60gig

    hope this helps and I do hope to get an answer soon.

             Thanks

                 Bob

     

  • I just figured it out!!! after reading a few other posts I figured I take a look at my BIOS the intergreted audio was on so I checked it to off seeing as I was using a soundcard, and wahoo it works just great, boy did I pull my hair out looking for this problem, well just check the bios and make sure there's no intergrated audio when using your soundcards.
  • OK I have no idea what BIOS is. I'm thinking I have to hit F2 or F12 before Windows boots up....Is that right?
  • Hold down the f2 key and look at the audio part of the bios.
  • Just be carefull what you are doing as this is the brain of your computer. You don't want to chang anything else just remember to save the changes when you exit the bios
  • OK,that didn't work. I had no sound at all after that. Here is all of my technical info out of my device manager...
    My Sound devices are Audio Codecs, (although tech support told me to disable them and I thought I had done this)Legacy Audio Drivers, Media Control Devices, SoundMAX Intergrated Digital Audio, Unimodem Half- Duplex Audio Device and Video Codecs.
    Also, I have a Samsung SPO401N HD.
    Hardware tech support told me to get rid of the Audio Codecs and install the SoundMAX. I thought I had, but, it looks like they're still there. The sound didn't change one way or the other, though.
    Where to now?
  • Your device manager SoundMax entry indicates you have integrated audio on the motherboard, and not a separate sound card, so disabling the integrated audio in the bios is NOT the answer for you. Here is the driver for the 3000 SoundMax, which you should try downloading and installing again, even if you think you already did this. Before doing this though you should right click the SoundMax entry in device manager and delete it. Then download and install this file:  http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R94481&SystemID=DIM_CEL_3000&os=WW1&osl=en&deviceid=2430&devlib=0&typecnt=1&vercnt=3&formatcnt=1&fileid=122481
    Also, can you answer the questions about sound quality I asked at the top of this thread?  Also, how much memory do you have in your system?  There are some reports of computers with not enough memory being bogged down with too many processes running which causes a lag in response. For a 300 with XP, I would recommend not less than 512 MB.
  • Oh, sorry. Sound is garbled when playing all forms of sounds. Streaming audio and CD's, DVD and all game files are equally as fuzzy the worst is the Windows start up file. It sounds worse than nails on a chalkboard! I have 512 MB of memory and the computer is only 6 months old. It's not even half full. I deleted the soundMAX and reinstalled. NO changes- it still sounds horrible. Could this be the Motherboard?  I spent four nights on Dell chat with hardware tech support and they finally told me it was a software problem and wished me well. Should I contact hardware support and ask them to send me someone to fix it?
     
  • This is frustrating because you have a modern system with enough memory and this really shouldn't be happening. By chance do you have any other speakers you could plug in and try?  You should certainly try to get Dell to resolve this issue, but that may be easier said than done. One alternative you may wish to consider is to purchase a PCI sound card, which is fairly inexpensive. If you do this be sure to disable the integrated audio in the bios.  Perhaps some other folks can help with suggestions.
  • Konagirl,
    Did you look at the Current Transfer Mode settings for both device 0 and device 1 on the Primary and Secondary IDE channels as I suggested in prior posting? I suspect your HD is running on the IDE channel in PIO mode which is too slow, causing the audio problems. It should be running in fast Ultra DMA mode 5. This seems to be a problem on the D3000, especially those with a Samsung HD.

    If you post the Current Transfer mode for each device (and it's PIO) we can attempt to fix it via software. Otherwise you may have to ask Dell for a new HD from a manufacturer other than Samsung.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Ron, I think you're on to something here.
    My primary IDE Device 0 Current transfer mode is in PIO Mode.
                              Device 1 is not aplicable.
    My secondary IDE Device 0  and Device 1 are the same. They both say Ultra DMA Mode 2.
     
    I'm starting to see a tiny little hole of light at the end of the tunnel! :-) Now what do I do?
    Incidently, tech support wanted me to run a custom test. The third one and for the third time, the computer passed all tests and played the speakers perfectly.
  • Konagirl,
    Your HD on primary IDE channel is running in slow PIO mode and that's the problem. (Secondary channel is OK.) Let's try simple fix first. Go here and download Dell's piotodma.exe. It's a compressed file so when you double-click it, it will unzip the file pushdma.exe.

    http://ftp1.us.dell.com/fixes/

    Run pushdma.exe, reboot and check your primary IDE channel. Current Transfer Mode for device 0 should now read Ultra DMA mode 5, and the audio should be better now. Let's hope it stays fixed.

    Unfortunately, others have noticed after a while the problem recurs. The IDE channel goes back to PIO mode because too many data errors are generated at the faster Ultra DMA speed. If that happens and you have Samsung HD, suggest you contact Dell and request new HD from either Seagate or Western Digital (not Maxtor). That seems to fix it for systems that keep reverting to PIO. You should tell Dell you ran pushdma and it worked for a while but reverted due to HD errors...

    Ron

    Message Edited by RoHe on 12-30-2005 10:52 AM

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee