Skipping stuttering sound

Desktop

Desktop
Desktop computer Hardware and Software discussion

Skipping stuttering sound

  • I have a Dimension 2400 with a SoundBlaster Live! sound card.  Any time I play ANY mp3's or video files the files skip every 5 to 25 seconds.  I've tried playing the files on another older computer and no problems so it's not the files.  My specs:
     
    2.4GHz Pentium processor
    768MB RAM (1-512, 1-256)
    Windows XP Professional
    Service Tag: DJ65631
     
    I've tried the integrated sound, switched to the SB Live card, tried a Soundblaster Live 24-bit card all with jumpy sound.  Even when I first boot the machine up and log in, the initial startup sounds of XP are jumpy.  I've switched out memory to as well as tried each DIMM seperately in case one of them was bad with the same results, I tried to add another 512MB DIMM in case for some reason 768MB wasn't enough with the same results.  I tried upgrading to a G-Force128MB video card instead of the onboard video thinking that maybe the main processor would be less taxed that way...same results.  I've disabled all antivirus software and even rebuilt the computer thinking there maybe something running that I don't know about...same results.  I even tried running the Diagnostics CD on all hardware available with the same results.  I've checked my different devices for new, updated drivers....same results.  I've noticed that sometimes my mouse can get jumpy at times too but I haven't seen any IRQ issues and nothing in the device manager seems to be having problems.  I thought there may be a problem with the speakers and purchased DELL surround sound speakers because I would like to watch a DVD or two some day on this machine...same results.
     
    I'm at my wit's end here, I can't think of anything else to try.  Every other process I run as long as there is no sound associated with it runs fine.  The other machine I have is a 5 year old DELL Dimension 667L with 384MB RAM and a 667MHz processor and everything plays fine on that.  Did I get a lemon?  Does anyone have any other ideas other than scrapping this piece of junk and finding another computer?  Any help would be greatly appreciated.
     
     
  • I had the same symptoms on my 8400.  Today, dell had me download this PIOtoDMA utility to set IDE devices back to UDMA mode.  Don't know how they got to be in PIO mode.  I ran the download earlier today and for the past couple of hours everything is fine.  I'll keep my fingers crossed.

    http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R53986&formatcnt=1&fileid=63977

    Hope this helps - it's a really frustrating problem.
     
    FastFrankie
  • I tried your suggestion but unfortunately the sound seems just as bad.  I appreciate the help though.
  • The solution doesn't have staying power.  My sound is stuttering and the mouse movement is jerky again this morning.
  • It would seem that the computer is getting an interrupt to do something periodically.  Have you used the task manager to see what the processor usage looks like during mp3 playback?  There is also a list of processes that gives the percentage of processor time spent on each that might be helpful.  Also, what bios are you using?  The most recent bios for the D2400 is A05 which was issued to resolve some audio problems.  The most significant was loss of audio following a restart but perhaps there were other things involved as well.
     
    Good luck!
     

    Dell Forum member since 2005

  • jvolz -piotodma.exe is just a zipped file. Did you expand it and run pushdma.exe?
    Open Device Manager, double-click on Primary IDE channel and see what it says for Current Transfer Mode for device 0 and device 1; do the same thing for Secondary IDE channel, if you have it. If it still says PIO anywhere, run pushdma again. Check the channels again. HD should be Ultra ATA mode 5 and optical drives probably Ultra ATA mode 2. If sound is still poor, go into Device Manager and uninstall the IDE controllers. Reboot and let XP reinstall the channels.

    FastFrankie - IDE channels default to PIO when there are too many errors on the channel to support Ultra DMA mode 2 for your optical drives. Make sure your CD/DVDs are clean. You man want to unintall and reinstall the drivers for your optical drives too.

    If you have nvidia 6800 video card in your 8400, go to www.sysinternals.com and download free Process Explorer. Run PE and under Options on toolbar, set it to 'Always on top'. When music stutters, look in PE window to see what's using CPU time, other than Systme Idle process. That may tell you what's causing the problem. If you see Deferred Procedure Calls using maybe 5% or more CPU time, and you have nvidia card, you need to ask Dell to replace it, assuming you're still under warranty.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I did run the pushdma.exe file but still nothing.  One thing I forgot to mention was that I have a 160gb hard drive installed using a ATA/133 PCI controller card.  Under controllers in device manager I'm showing Intel 82801DB Ultra ATA Storage Controller-24CB.  I don't see any properties for Transfer mode with that.  My secondary IDE Channel shows DMA if available and Ultra DMA Mode 2 for Device 0 and 1.  Forgive my ignorance in terminology here.  This is a little more nuts and bolts than I'm used to.
     
    When I tried to change my video card to G-Force 5500, I tried using the Process Explorer but didn't see anything cropping up when I played music.  I've also watched task manager but have noticed nothing glaring there either.  I'm already on BIOS A05 as well.  Thanks again for all the suggestions.  I will try to uninstall controllers when I get home from work tonight.
  • jvolz

    Is the 160GB HD on the ATA/133 controller the boot drive or do you have another HD? Do you have a primary IDE channel listed in Device Manager?

    I'm guessing here, but if device 0 on 2nd IDE is your HD, that may be the problem. Ultra DMA mode 2 is too slow for a HD. HDs should be running Ultra DMA mode 5. Mode 2 is OK for optical drives.

    You need to troubleshoot the IDE channel(s) and installation of HD(s). Are jumpers on the HD connected to controller card set properly?

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • The 160GB HD is my only drive.  Unfortunately the DELL Dimensions have limited slots so I removed the 40GB drive I originally had because I wanted a CD burner drive and a DVD burner drive.  I have a secondary IDE channel and an Intel Ultra ATA Storage Controller but nothing shows as primary.  When I first boot the machine, it shows Ultra DMA 6 next to the ATA listing but the Secondary IDE channel still shows 'DMA if available' for Transfer Mode and 'Ultra DMA Mode 2' for current device mode.
     
    Again we're getting into shaky ground for me so if you could spell out what I'd need to do I'd greatly asppreciate it.  I checked the jumpers on the hard drive and they're set at Cable Select.  I tried to uninstall the IDE/ATA controller and reboot but still nothing, it's still at DMA Mode 2.

    Message Edited by jvolz on 01-30-2006 07:40 PM

  • It sounds like the 2 devices on the 2nd IDE channel must be your DVD and CD drives and both are running in Ultra DMA mode 2, That's correct mode for them and the problem must be elsewhere.

    Before I forget to ask, did this problem arise only after you replaced the original HD with the ATA/ card and 160GB HD? Or has it always been this way?

    I don't know your system, but are you sure it's ok to mix 1 512MB and 1 256MB RAM module? Or did you install extra RAM after you got it? Are they both the same (correct) type RAM and speed for your system? If one is slower than the other, it may make both run at the slower speed which could affect audio.

    Boot the system and press F2 before XP starts to load to open BIOS setup. Look for an option to change CPU speed with the choices of "Normal" and "Compatible". Make sure it's set to Normal.

    Go to www.sysinternals.com. Download free Process Explorer. Run PE and on toolbar click Options>always on top. Now when music starts to skip, look in PE window for something using lots of CPU time, aside from System Idle Process. Something may be running in the background that hogs the CPU and makes the music stutter. As little as 5% CPU usage could be enough to cause the problem.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I'm pretty sure this problem has been this way for probably about as long as I've had the ATA but I'm not positive.  I've been struggling with this problem for about 5 months.  I just thought I had a short in my speakers for the longest time.
     
    The RAM that I put in this system is what I ordered off the upgrade your system website from DELL.  It originally came with 256 but I added the 512.  I thought there might be a memory issue and I actually tested the system with ONLY one dimm at a time for both DIMMs but still had the same problem.  I've also double-checked the CPU speed is set at Normal.
     
    I just retried the Process Explorer software and noticed that EVERY time I get the skip, the Hardware Interrupts shoot up to 15-20%.  I went through all the interrupts and noticed that my Broadcom 10/100 Integrated Controller and the SBLive Series WDM and Soundmax Integrated Digital Audio all use IRQ 17.  The Intel USB Universal Host Controller, Intel Graphics controller and WinXP Promise Ultra 133 IDE controller are all using IRQ 16.  Could that be the issue?  If so, how can I reassign IRQ?  Regedits?  Thanks again for all your help.
  • Just to be clear, I don't work for Dell and the only Dell employees that generally read the forums are the Moderators. So they're not 'my' web sites.

    Am I missing something? You said the system has only 2 slots. Did you mean 2 PCI card slots or 2 drive bays? According to the 2400 manual, you have 3 externally accessible drive bays suitable for CD, DVD, and floppy drives, plus 1 internal bay for IDE HD. And, you have 2 IDE channels which would allow you to connect up to 4 IDE devices (eg, HD, CD, DVD). So why the ATA card? Seems to me, you should connect the HD to the same connector where OEM HD was connected on primary IDE channel, and have the 2 optical drives on the secondary (where they are) and get rid of the ATA card you added.

    http://support.dell.com/support/edocs/systems/dim2400/en/sm_en/specs.htm

    If you're not using the Broadcom integrated controller for a network connection, you could disable it in BIOS setup and that will stop it from sharing the IRQ.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Actually, that line with 'your' was meant differently.  I meant it as the 'Upgrade Your DELL' website, not that it was your site, if that makes any sense.
     
    I had all 3 externally accessible drive bays in use with the CD burner, DVD burner and a floppy drive.  My one and only HD, the 160GB, was in the internal bay.  I was trying to use the ATA card because I didn't want to lose about 20GB of hard drive space.  You can only use up to 137GB without the ATA.  I tried using the primary IDE channel now and everything works without skipping!  I can trade 20GB for no skipping, planning on getting an external drive anyway, especially now that I didn't have to buy a new vid card, sound card or memory.
     
    Thanks again for your help Ron (and FastFrankie).  It was greatly appreciated!
     
    Jerry

    Message Edited by jvolz on 02-01-2006 06:03 AM

  • Sounds good (pun intended!). Glad you've resolved the sound problems. See if there's a BIOS update or some Dell Desktop System Software update that will let you access the rest of that HD.

    Ron

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • RoHe, you're the man!  Read my post from a few minutes ago.  You pointed right to a solution.