Dell C6100 BMC / BIOS HELP - Cloud Services - Forum - Cloud Services - Dell Community

Dell C6100 BMC / BIOS HELP

Cloud Services

Cloud Services
Connect with those using Dell Cloud Services

Dell C6100 BMC / BIOS HELP

This question is not answered

We're having a ton of issues with our Dell C6100. We bought 10 clusters and here are the issues

Cluster #1 - worked fine, BIOS 1.50 and flashed firmware for BMC to 1.69 - worked fine, can set IP and netmask and all's gravy

However, issues for the other clusters include

1) RAM shows up as wrong speed in bios. Also when you boot into bios, the bios system information page does not detect any chassis info, etc - this is the most alarming

2) BMC detected and you can set IP ONCE, after that, no IP changes will be written no matter how long you wait and the netmask is defaulted to in BIOS

3) BIOS firmware flash won't work as it says the ROM image is the wrong version (using the dos bootable)

4) BMC not detected alive on some of them

5) BMC when detected cannot change IP

We're very frustrated and given the IPMI is onboard - if its bricked is there anyway to replace them? Any help would be GREATLY appreciated

Stop receiving emails on this subject.

All Replies
  • As for your point 4 above,

    Yes, I have just updated a series of C6100's as well to BMC version 1.69. We now have about 10% which don't respond during boot (not alive). The problem we are seeing, is that this number has increased over the last couple of days, usually with more disappearing after rebooting the machines. Could the firmware have modified the chip functions to make it draw excessive current and fry the chip over time?


  • Matt,

    We've solved all of our issues - what issues are you seeing.




  • We have quite a few machines which show that there is no BMC module alive, how did you fix this, and did you stay with 1.29, or did you revert to an earlier version?

  • We've fixed all 20 of our units - BIOS and BMC firmware updated.

    The trick is to use the AOCFlash utility first - do NOT re-flash with the KCSFlash. Flash with AOC and reboot then flash your bios (in bios update you need to ignore the checksum)

    When both done, your BMC will show as alive and you can set IP

  • ejc317: You mentioned in your first post you were having issues flashing the BIOS from the dos bootable (fbios.bat I'm assuming).  How exactly did you resolve this issue?

    We have 3 C6100's.  All nodes in each unit report the same error when attempting to flash with fbios.bat... "Different ROM ID between current system and update BIOS rom file".  Is that the error you had?

    BIOS currently shows it's on v1.50 (9/23/2010), and I'm trying to get to v1.69.  However, it looks as though the issue lies with the ROM ID, which shows in BIOS as 5442A150.  From what I can tell, the fbios.bat is looking for a minimum safe version of 5442B139 to proceed.  The key difference I assume being the "A" and the "B"?

    I could maybe run afudos program directly, but I don't want to brick anything.

  • Ok, here are detailed instructions on how to flash the old Plutonium xs23-ty3 to C6100 firmware.

    It probably can be done much faster. I am just reporting what I have done. You can skip whatever you think you should.


    Original BIOS version 1.04!!! Dated back to 2009. Probably one of the first units.

    Target BIOS version 1.69.


    1. Installed Windows 2003 on the server! However at this point Dell updates for windows would not work throwing incompatibility error.


    2. From Dell website downloaded Floppy ESM firmware v 1.28. (ESM - Embedded Server management - BMC)

    3. Copied it to a bootable DOS Floppy .IMG image file and attached it as remote media through BMC console.


         There are two folders KCSFlash and SOCFlash in that floppy. I used firmware from SOCFlash. 

          I do not remember exactly, but I think I flashed it with SOCFlash/dos/flash8.bat

          At this poing BMC resets and its NIC has to be set to SHARED mode and IP address configured again.


    4. Than power cycle the whole chassis. (After each firmware flash, the BMC has to be powered off or it will be unstable)

    5. Now downloaded the Floppy BIOS v1.69, copied it to the same bootable DOS image file and attached it again as remote media.

           The FBIOS.BAT would not work. Error: Incompatible ROM ID (or something like that)

           You have to execute the following command:            afudos 6100v169.ROM /p /b /n /c /x

           The /x switch tells it to skip ROM ID compatibility check.

           The BIOS flashed successfully and BMC worked but when I went to system BIOS and saved it the BMC configuration disappeared and could not be set anymore. I would type IP click save but after reboot, it was not there.


    6. Booted server into Windows 2003.

    7. Run BIOS update v1.69 (Windows package downloaded from Dell). It said the version was the same but I flashed it anyway.

    8. Run ESM update v1.29 (Windows package downloaded from Dell). Updated successfully.


    Power cycle server. Set BMC IP and it is working now!

    What to try:

    In the first step, flash the v1.29 of ESM firmware instead of v1.28 so it maybe, would not be required to install Windows etc...

  • Update

    These old model C6100 server nodes have mezzanine HBA LSI SAS1068E that supposed to sync with SATA 2.0 - 3Gbps

    However, mine were synchronizing only to SATA 1 - 1.5Gbps.

    There were no firmware update for them on the Dell website.

    After doing some research, I found out that these were analogs of LSI SAS 3081E-R HBA and LSI site has the firmware and BIOS update for them.

    Section FIRMWARE, Installer_P21_for_DOS_Windows

    Here are instructions:

    1. Unzip the package

    2. Copy sasflash.exe from subfolder "SASflash_DOS_rel" to the root folder. It will overwrite the existing sasflash.exe, which would not start from DOS.

    3. Copy content of this package to a bootable DOS image and attach it as virtual media to BMC console. (You can also copy it to a DOS bootable USB stick)

    3. Boot into DOS and run hbaFlash.bat

       It will ask some questions. My answers: HBA - 3081, PCIe, ER, chip - B3, force firmware flash

    Flashed it without problem and now all my SATA drives synchronizing at 3Gbps!

    For those who wants to install vSphere on it should check out the following KB and enable write caching or else the HBA performance will be terrible:

    Note that while the article is only mentioning ESXi3.5 and 4.0 it works just fine on vSphere 5.1

  • dazipe

    2. From Dell website downloaded Floppy ESM firmware v 1.28. (ESM - Embedded Server management - BMC)

    3. Copied it to a bootable DOS Floppy .IMG image file and attached it as remote media through BMC console.

     5. Now downloaded the Floppy BIOS v1.69, copied it to the same bootable DOS image file and attached it again as remote media.

    Can you explain these steps in more detail?  What DOS floppy .img did you use and how did you add multi-megabyte files to them?

    I've spent hours trying to make this work, and feel like a numbskull.  I can't add files in total of more than 1.44MB to a floppy .img.  I've tried modifying bootable isos, booting dos from a floppy disk and putting the bios binaries on a cd iso.. nothing is working for me.

    Thanks for taking the time to outline your steps here.

  •  ***USE AT YOUR OWN RISK***  I made it through, so can you.

    You need a floppy bootdisk and boot with it.  After you prepare the files..

    Make a partition on your HD 2 gig or so and IMPORTANT format FAT32.

    download the floppy versions of firmware.  run them to unzip.  For ease of use, collect the binaries and dos folder contents and put them in the root of the new FAT32 partition in folders with short names that work for you.

    I used the most current files as of 4/2013


    For the BMC - BACKUP - socflash -t 1 BMCBACK.ROM

    then flash   socflash -sf romfile.rom

    for Bios afudos romfile.rom -x -reboot  choose 'F' when prompted

    for fan fcbflash -o file.bin

    Use whichever names the rom files are named.

    I had a few mishaps before I got this to work, NTFS Bootdisk does not work.  Thought I lost my BMC.  using the above method resurrected it.

    SIDE NOTE:  I did run the windows BIOS update after I booted up, and reinstalled.  But I was just paranoid.  But you can use the current update files in Windows after you update to a more current version.

    I found a link for AFUDOS commands


  • I got my C6100 to update everything but the fan's I am getting an error "image file tag checking failed" any ideas? I used from windows cmd prompt, fcbflash -o PICImage.bin