Studio XPS 1645 blank screen

XPS Club

XPS Club
Share your XPS experiences and join in the conversation with other XPS users.

Studio XPS 1645 blank screen

This question is not answered

I have a studio XPS 1645 running windows 7 pro. Recently started having a problem of blank screen after shutting down / restarting. Screen comes back normally if i have hibernated the laptop. However it becomes blank (no bios screen either) if a have restarted/ shut down. External monitor connected to the video connector works fine. However it does not detect the actual laptop screen at all. Only way to correct it is to start/ shut down multiple times and sometimes with luck screen comes on. I now always hibernate the laptop to avoid this problem. But everytime i have to restart laptop because of some updates/ some software installation then problem comes again. Help needed Please!!

All Replies
  • Hi Shravan,

    There could be few reasons for this to happen. If the display on the external monitor is fine, it means the video card is good. However we cannot consider the LCD as the point of failure, because the issue occurs only when restarting the system. Lets try few steps to isolate further.

    1. Update the video drivers to the latest version available at the Dell support site. (The video card model number can be located in Device Manager under Display adapters)

    2. Run the LCD built in self test by performing the steps using this link - http://dell.to/UMTbOO

    3. Disconnect and external devices and peripherals to see if that makes any difference.

    4. Disable start up items. To disable start up, check this link - http://bit.ly/q3HMvH 

    Please reply with the results.

    Thanks and Regards
    Satya P
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

    If a post answers your question, please click the green "
    Yes" button.

  • Hi Satya

    1. I updated the video driver from the dell site to a newer (latest) version. Restarted couple of times. No change

    2. Restarted the computer couple of times till the screen started working. Carried out the BIST test after hibernating. Test carried out fine-cycled through white-black-red-green-blue and then again with a series of beeps. After that i started the laptop and the screen worked fine as usual. So i shut down the laptop and then did the BIST test. Same behavior for the test, except after the test when i started the laptop the screen again became blank.- No change

    3. Disconnected external hard drive, usb mouse etc. (No printer connected). No change

    4. Disabled all startup items except Windows and internet security(Kaspersky).- it stays selected by default.  No change.

  • Hi Shravan,

    Thanks for the detailed reply. I have researched about this issue and found few interesting steps that we can try.

    1. Shutdown the system. Remove the battery and unplug the power adapter. Press and hold the power button for 20 seconds. This will discharge the residual electricity from the system board.

    2. Start the system and check if the screen is blank. If the system boots fine, go to the power setting and set everything to 'Never'.

    3. Insert the battery and start the system again.

    This is the link where I have found this information - http://bit.ly/OQvFgp

    Based on the reviews this seem to have worked for few users. Hope this works for us too.

    Please reply with the results.

    Thanks and Regards
    Satya P
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

    If a post answers your question, please click the green "
    Yes" button.

  • Hello, I have a Studio XPS 1645 with exactly the same problem. Disconnecting the power adapter and pulling the battery, then reinserting the batter usually works, but this is an unacceptable solution. Is there a real fix for this?

  • Hi ppappas

    I had gone to the service centre. Initially they thought the RAM was faulty so they tested it with new RAM chips but the problem remained. Finally they said the motherboard was faulty and advised me that I would have to get the motherboard replaced @ Rs.12000 or get a  6 month warranty @ Rs. 19000 (which wud include a new motherboard). I didnt want to spend this amount so for the time being I am using the laptop as such only. (Only hibernating and not shutting down). I have turned off automatic updates to avoid the laptop shutting down /restarting by itself.

    I didn't find any other solution. If you do please advise me too..

    thanks

  • This is the exact thing they told me and they did with my laptop when I went the Dell Support @ Domlur.  That was in October 2012. They were keeping on asking me to pay 12k warranty and change the MB.

    Then 3 weeks before I followed what

    Change your all power settings to Never including remove battery and press 20 sec etc. It did work for me for a week , then back to old blank screen issue. Now I do it regularly in a week or 10 days when the screen goes blank.

    This is temporary fix. If you find a solution which is Permanent, do tell me.

    Regards