Alienware 14 - Terrible Sound Quality?

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware 14 - Terrible Sound Quality?

This question is not answered

Hello~

I just upgraded from an M14X to an Alienware 14. It's amazing - it truly is. However, there's one small issue I can't quite get around:

The built-in Klipsch speakers sound hardly worthy of the name. The quality, at best, is really no better than I get from the speaker in my iPhone. It's really disconcerting, especially for a brand new laptop, and even more so because the (from what I can tell) similar speaker set in my M14X could pump out sound that would rattle the table, and often didn't even warrant the thought of external speakers.

At first, I suspected that maybe the subwoofer was nonfunctional, so I took it for my father to inspect, in all his knowledge as an audio engineer. We discovered that while it is, indeed, working, it's playing nothing but high-end and mid-range sound, with only hints at lower range. Meanwhile, the front speakers are handling all ranges and making it sound very tinny and high, which, frankly, is incredibly hard on the ears. The problem is worsened when the Dolby Digital Plus (which is frustrating at best) is turned off. The sound loses 90% of its volume and becomes almost harshly geared for high-end only, making it almost painful to listen to.

I called support and was given quite a bit of attitude from the guy on the other end, who vehemently insisted that nothing is wrong after remote-controlling my computer and cycling the drivers, which did all of nothing (though he claimed it sounded 100% better to him - there was no change).

My question is this: Is there anyone else with a similar issue? Should I send it in and suffer for the three weeks the man on the phone suggested it would take without a computer - which is vital to my work, home, and entertainment, effectively crippling my productivity - just risk them sending it back telling me nothing is wrong? Is this the way it's supposed to work, and just a corner that was cut? An inherent design flaw?

To clarify here, it sound perfectly fine when speakers are plugged in to either of the analog outputs. USB is the same - crystal clear, high quality. Alone, the laptop is ear-bleedingly bad and, frankly, very depressing for a machine that, in every other way, is absolutely fantastic. But as someone who is highly focused on audio and sound quality... it's a problem that is very hard for me to ignore.'

Thanks in advance for any helpful input or solutions!

All Replies
  • Hi,

    Please send me a private message with your Service Tag and contact information so I can review your case further. 

    Alienware-Naomi
    Dell | Alienware Technical Support Alienware Arena
    #iwork4Dell
    Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
    I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

  • Done. =-)